libmodpbase64-dev_3.10.3+git20180306-1_amd64.deb


Advertisement

Description

libmodpbase64-dev - collection of high performance c-string transformations (development files)

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename libmodpbase64-dev_3.10.3+git20180306-1_amd64.deb
Package name libmodpbase64-dev
Package version 3.10.3+git20180306
Package release 1
Package architecture amd64
Package type deb
Category devel::library libdevel role::devel-lib
Homepage https://github.com/client9/stringencoders
License -
Maintainer Lennart Weller <lhw@ring0.de>
Download size 10.87 KB
Installed size 76.00 KB

Alternatives

Package Version Architecture Repository
libmodpbase64-dev_3.10.3+git20160924-3_i386.deb 3.10.3+git20160924 i386 Debian Main
libmodpbase64-dev - - -

Requires

Name Value
libmodpbase64-0 = 3.10.3+git20180306-1

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libmodpbase64-dev_3.10.3+git20180306-1_amd64.deb
Source Package stringencoders

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmodpbase64-dev deb package:
    # sudo apt-get install libmodpbase64-dev

Files

Path
/usr/include/extern_c_begin.h
/usr/include/extern_c_end.h
/usr/include/modp_ascii.h
/usr/include/modp_b16.h
/usr/include/modp_b2.h
/usr/include/modp_b64.h
/usr/include/modp_b64r.h
/usr/include/modp_b64w.h
/usr/include/modp_b85.h
/usr/include/modp_bjavascript.h
/usr/include/modp_burl.h
/usr/include/modp_html.h
/usr/include/modp_json.h
/usr/include/modp_numtoa.h
/usr/include/modp_qsiter.h
/usr/include/modp_stdint.h
/usr/include/modp_xml.h
/usr/lib/x86_64-linux-gnu/libmodpbase64.so
/usr/lib/x86_64-linux-gnu/pkgconfig/stringencoders.pc
/usr/share/doc/libmodpbase64-dev

Changelog

2018-11-20 - Lennart Weller <lhw@ring0.de>
stringencoders (3.10.3+git20180306-1) unstable; urgency=medium
* Updated to a slightly newer upstream version
* Added FTCBFS fixing patch from bug tracker (Closes: #903502) 
2016-12-07 - Lennart Weller <lhw@ring0.de>
stringencoders (3.10.3+git20160924-3) unstable; urgency=medium
* Removed extern_c includes from the headers in -dev package (Closes: #846750)
2016-11-23 - Lennart Weller <lhw@ring0.de>
stringencoders (3.10.3+git20160924-2) unstable; urgency=low
* Reintroduced an old Patch for wrong casts in test cases on
some architectures
* Added modp_stdint.h to the -dev package install (Closes: #841612)
2016-11-15 - Lennart Weller <lhw@ring0.de>
stringencoders (3.10.3+git20160924-1) unstable; urgency=medium
[ Lennart Weller ]
* Update to new upstream version
- Upstream has dropped the support for the (incomplete) MessagePack API
* Removed upstreamed patches
[ Daniel Knezevic ]
* Disable -Werror flag for builds (Closes: #843154)
* Remove distinction for big endian on shift (Closes: #843155)
2016-10-19 - Sebastian Reichel <sre@debian.org>
stringencoders (3.10.3+git20160118-1) unstable; urgency=low
[ Lennart Weller ]
* New upstream release
* Updated Standards-Version to 3.9.7
* Updated watchfile
* Updated homepage
* Updated exported symbols
* Removed unnecessary patches 
[ Sebastian Reichel ]
* Use secure VCS urls
* Updated Standards-Version to 3.9.8
* Switch to compat level 10
2012-12-06 - Lennart Weller <lhw@ring0.de>
stringencoders (3.10.3-2) unstable; urgency=low
* Fix for build from source errors on some architectures. (Closes: #695024)
2012-10-25 - Lennart Weller <lhw@ring0.de>
stringencoders (3.10.3-1) unstable; urgency=low
* Initial release. (Closes: #593462)

See Also

Package Description
libmodplug-dev_0.8.9.0-2_amd64.deb development files for mod music based on ModPlug
libmodplug1_0.8.9.0-2_amd64.deb shared libraries for mod music based on ModPlug
libmods-record-perl_0.13-1_all.deb module for handling MODS records
libmodsecurity-dev_3.0.3-1_amd64.deb ModSecurity v3 library component (development files)
libmodsecurity3_3.0.3-1_amd64.deb ModSecurity v3 library component
libmodulator-java_1.0-3_all.deb Java small shim library that wraps Java 9 APIs and exposes them to recent JDKs
libmodule-build-cleaninstall-perl_0.5-3_all.deb module for removing the old module before installing the new one
libmodule-build-perl_0.422400-1_all.deb framework for building and installing Perl modules
libmodule-build-pluggable-perl_0.10-1_all.deb plugins for the perl module Module::Build
libmodule-build-pluggable-ppport-perl_0.04-1_all.deb module to generate a ppport.h file automatically
libmodule-build-tiny-perl_0.039-1_all.deb tiny replacement for Module::Build
libmodule-build-using-pkgconfig-perl_0.02-1_all.deb Module::Build extension for using platform libraries provided by pkg-config
libmodule-build-withxspp-perl_0.14-3_all.deb XS++ enhanced flavour of Module::Build
libmodule-build-xsutil-perl_0.19-1_all.deb Module::Build class for building XS modules
libmodule-bundled-files-perl_0.03-1_all.deb perl module to access files bundled with your module
Advertisement
Advertisement