libmimetic0v5_0.9.8-7_amd64.deb


Advertisement

Description

libmimetic0v5 - C++ MIME library (runtime)

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename libmimetic0v5_0.9.8-7_amd64.deb
Package name libmimetic0v5
Package version 0.9.8
Package release 7
Package architecture amd64
Package type deb
Category libs role::shared-lib
Homepage http://www.codesink.org/mimetic_mime_library.html
License -
Maintainer gregor herrmann <gregoa@debian.org>
Download size 99.21 KB
Installed size 374.00 KB

Alternatives

Package Version Architecture Repository
libmimetic0v5_0.9.8-7_i386.deb 0.9.8 i386 Debian Main
libmimetic0v5 - - -

Requires

Name Value
libc6 >= 2.14
libgcc1 >= 1:3.0
libstdc++6 >= 5.2

Conflicts

Name Value
libmimetic0 -

Replaces

Name Value
libmimetic0 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libmimetic0v5_0.9.8-7_amd64.deb
Source Package mimetic

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmimetic0v5 deb package:
    # sudo apt-get install libmimetic0v5

Files

Path
/usr/lib/x86_64-linux-gnu/libmimetic.so.0
/usr/lib/x86_64-linux-gnu/libmimetic.so.0.0.0
/usr/share/doc/libmimetic0v5/changelog.Debian.gz
/usr/share/doc/libmimetic0v5/changelog.gz
/usr/share/doc/libmimetic0v5/copyright

Changelog

2018-10-27 - gregor herrmann <gregoa@debian.org>
mimetic (0.9.8-7) unstable; urgency=medium
* debian/control: update Vcs-* fields.
* Drop unneeded lintian overrides about Vcs-* URLs.
* Mark libmimetic-doc as Multi-Arch: foreign.
* Use debhelper compat level 11.
Additionally adjust paths for doc-base registration.
* Declare compliance with Debian Policy 4.2.1.
* Remove trailing whitespace from debian/*.
* Update years of packaging copyright.
2017-08-07 - gregor herrmann <gregoa@debian.org>
mimetic (0.9.8-6) unstable; urgency=medium
* Adapt to C++ name mangling in GCC 7:
- Build-Depend on g++ (>= 4:7)
- Override dh_makeshlibs for new symbols from gcc 7
Thank to James Cowgill for the bug report.
Closes: #871307
* Update years of packaging copyright.
* Bump debhelper compat level and dependency to 10.
Drop manual autoreconf fragments.
* Support DEB_BUILD_OPTIONS/DEB_BUILD_PROFILES "nodoc".
* Use HTTPS for Format URL in debian/copyright.
* Add linitian override about insecure Vcs URLs.
* Add all hardening options in debian/rules.
* Declare compliance with Debian Policy 4.0.1.
2017-04-14 - gregor herrmann <gregoa@debian.org>
mimetic (0.9.8-5) unstable; urgency=medium
* Add patch signed-char.patch to fix build failure on architectures
where char is unsigned.
Thanks to Adrian Bunk for the bug report. (Closes: #859963)
2016-01-15 - gregor herrmann <gregoa@debian.org>
mimetic (0.9.8-4) unstable; urgency=medium
* debian/rules: change dh_strip argument from --ddeb-migration to
--dbgsym-migration.
* debian/control: build-depend on debhelper 9.20160114 to ensure support
for --dbgsym-migration in dh_strip.
2015-12-20 - gregor herrmann <gregoa@debian.org>
mimetic (0.9.8-3) unstable; urgency=medium
* Migrate from manual "-dbg" package to automatic "-dbgsym" one:
+ debian/control: drop "Package: libmimetic0-dbg".
+ debian/rules: change override_dh_strip to use dh_strip's
"--ddeb-migration" option.
2015-08-24 - Simon McVittie <smcv@debian.org>
mimetic (0.9.8-2.1) unstable; urgency=medium
* Non-maintainer upload.
* Upload libmimetic0v5 to unstable.
2015-08-03 - gregor herrmann <gregoa@debian.org>
mimetic (0.9.8-2) experimental; urgency=medium
* Rename libmimetic0 to libmimetic0v5 (libstdc++6 ABI changes).
Add Conflict/Replaces on old libmimetic0. (Closes: #791203)
* Upload to experimental for now.
* Declare compliance with Debian Policy 3.9.6.
2014-06-17 - gregor herrmann <gregoa@debian.org>
mimetic (0.9.8-1) unstable; urgency=medium
* New upstream release.
* Drop patches, both merged upstream.
* debian/{rules,control}: split building of arch:indep -doc package (use
Build-Depends-Indep and override_dh_build-indep target).
* Update years of packaging copyright.
* Declare compliance with Debian Policy 3.9.5.
2013-07-30 - gregor herrmann <gregoa@debian.org>
mimetic (0.9.7-4) unstable; urgency=low
* Fix upstream URL in debian/{control,copyright,watch}.
Thanks to Bart Martens for the bug report.
(Closes: #697171)
* Add patch to fix build failure with clang.
Thanks to Raphael Rigo for the bug report and the patch.
(Closes: #718306)
* Mark -dbg package as Multi-Arch: same.
Thanks to lintian.
* Update regexp in debian/watch.
Thanks to Bart Martens.
* Make doc-base file installation less confusing.
* Update years of packaging copyright.
* Remove empty maintainer script from source package.
debhelper adds them anyway.
* Declare compliance with Debian Policy 3.9.4.
2012-04-13 - gregor herrmann <gregoa@debian.org>
mimetic (0.9.7-3) unstable; urgency=low
* Revert "Move building of -doc package to override_dh_auto_build-indep,
and split Build-Depends and Build-Depends-Indep."
Fails on half of the buildds which call `debian/rules build' and not
`debian/rules build-arch', and then don't find doxygen from
Build-Depends-Indep.

See Also

Package Description
libmimic-dev_1.0.4-2.3+b11_amd64.deb A video codec for Mimic V2.x content (development files)
libmimic-doc_1.0.4-2.3_all.deb A video codec for Mimic V2.x content (documentation)
libmimic0_1.0.4-2.3+b11_amd64.deb A video codec for Mimic V2.x content
libmina-java-doc_1.1.7.dfsg-13_all.deb Java network application framework - documentation
libmina-java_1.1.7.dfsg-13_all.deb Java network application framework
libmina2-java-doc_2.0.19-2_all.deb Java network application framework - documentation
libmina2-java_2.0.19-2_all.deb Java network application framework
libminc-dev_2.4.03-2+b1_amd64.deb MNI medical image format development environment
libminc2-5.2.0_2.4.03-2+b1_amd64.deb MNI medical image format library
libmini18n-dev_0.2.1-1_amd64.deb minimal internationalization library - devel headers
libmini18n1_0.2.1-1_amd64.deb minimal internationalization library
libminicoredumper-dev_2.0.1-1_amd64.deb minicoredumper library development files
libminicoredumper2_2.0.1-1_amd64.deb minicoredumper library
libminidjvu-dev_0.8.svn.2010.05.06+dfsg-6_amd64.deb Small DjVu encoder/decoder, development files
libminidjvu0_0.8.svn.2010.05.06+dfsg-6_amd64.deb Small DjVu encoder/decoder, shared library
Advertisement
Advertisement