libmiaviewit-dev_1.0.5-2_amd64.deb


Advertisement

Description

libmiaviewit-dev - development files for the 3D visualization library

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename libmiaviewit-dev_1.0.5-2_amd64.deb
Package name libmiaviewit-dev
Package version 1.0.5
Package release 2
Package architecture amd64
Package type deb
Category devel::library libdevel role::devel-lib
Homepage http://mia.sourceforge.net
License -
Maintainer Debian Med Packaging Team <debian-med-packaging@lists.alioth.debian.org>
Download size 193.80 KB
Installed size 1.28 MB

Alternatives

Package Version Architecture Repository
libmiaviewit-dev_1.0.5-2_i386.deb 1.0.5 i386 Debian Main
libmiaviewit-dev - - -

Requires

Name Value
libboost-thread-dev -
libgle3-dev -
libgtkglextmm-x11-1.2-dev -
libgtkmm-2.4-dev -
libmia-2.4-dev -
libmiaviewit0 = 1.0.5-2
libvistaio-dev -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libmiaviewit-dev_1.0.5-2_amd64.deb
Source Package miaviewit

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmiaviewit-dev deb package:
    # sudo apt-get install libmiaviewit-dev

Files

Path
/usr/include/miaviewit-1.0/viewit/4DVector.hh
/usr/include/miaviewit-1.0/viewit/arrow.hh
/usr/include/miaviewit-1.0/viewit/brown_diffuser.hh
/usr/include/miaviewit-1.0/viewit/camera.hh
/usr/include/miaviewit-1.0/viewit/clip_plane.hh
/usr/include/miaviewit-1.0/viewit/coordaxes.hh
/usr/include/miaviewit-1.0/viewit/cp_draw.hh
/usr/include/miaviewit-1.0/viewit/drawable.hh
/usr/include/miaviewit-1.0/viewit/event.hh
/usr/include/miaviewit-1.0/viewit/glerror.hh
/usr/include/miaviewit-1.0/viewit/glimage.hh
/usr/include/miaviewit-1.0/viewit/glmesh.hh
/usr/include/miaviewit-1.0/viewit/gltext.hh
/usr/include/miaviewit-1.0/viewit/glvector.hh
/usr/include/miaviewit-1.0/viewit/glviewer.hh
/usr/include/miaviewit-1.0/viewit/light.hh
/usr/include/miaviewit-1.0/viewit/measure.hh
/usr/include/miaviewit-1.0/viewit/mesh.hh
/usr/include/miaviewit-1.0/viewit/pixel.hh
/usr/include/miaviewit-1.0/viewit/planeexpose.hh
/usr/include/miaviewit-1.0/viewit/pov_output.hh
/usr/include/miaviewit-1.0/viewit/selector.hh
/usr/include/miaviewit-1.0/viewit/shader.hh
/usr/include/miaviewit-1.0/viewit/shape.hh
/usr/include/miaviewit-1.0/viewit/slice.hh
/usr/include/miaviewit-1.0/viewit/smarty.hh
/usr/include/miaviewit-1.0/viewit/snapshot.hh
/usr/include/miaviewit-1.0/viewit/sphere.hh
/usr/include/miaviewit-1.0/viewit/status.hh
/usr/include/miaviewit-1.0/viewit/structures.hh
/usr/include/miaviewit-1.0/viewit/texture.hh
/usr/include/miaviewit-1.0/viewit/trajects.hh
/usr/include/miaviewit-1.0/viewit/vistaloader.hh
/usr/include/miaviewit-1.0/viewit/voxelmove.hh
/usr/include/miaviewit-1.0/viewit/voxelmover.hh
/usr/include/miaviewit-1.0/viewit/wireframe.hh
/usr/lib/x86_64-linux-gnu/libmiaviewit.a
/usr/lib/x86_64-linux-gnu/libmiaviewit.so
/usr/lib/x86_64-linux-gnu/pkgconfig/miaviewit.pc
/usr/share/doc/libmiaviewit-dev/changelog.Debian.gz
/usr/share/doc/libmiaviewit-dev/changelog.gz
/usr/share/doc/libmiaviewit-dev/copyright

Changelog

2018-09-09 - Gert Wollny <gewo@debian.org>
miaviewit (1.0.5-2) unstable; urgency=medium
* d/* cme fix dpkg  
- update standards to 4.2.1  (no changes needed) 
- fix VCS urls 
- fix copyright format
2017-06-23 - Gert Wollny <gewo@debian.org>
miaviewit (1.0.5-1) unstable; urgency=medium
* New upstream version 1.0.5, Closes: #865575
* d/control: update standards version to 4.0.0
* d/control: correct my uploader e-mail address
2016-08-23 - Gert Wollny <gw.fossdev@gmail.com>
miaviewit (1.0.4-1) unstable; urgency=medium
* Add d/gbp.conf
* Imported Upstream version 1.0.4
* d/control: update dependencies to libmia-2.4-dev
2016-05-31 - Gert Wollny <gw.fossdev@gmail.com>
miaviewit (1.0.2-2) unstable; urgency=medium
* d/rules,d/control: Switch to automatic debug packages and 
update standards version
* d/control: cme fix dpkg-control
* d/rules: add -WL,-z,now to linker flags 
2015-10-27 - Gert Wollny <gw.fossdev@gmail.com>
miaviewit (1.0.2-1) unstable; urgency=medium
* New upstream release, Closes: #803050
* d/control: - update standarts version to 3.9.6
- add libxml++2.6-dev since libmia-2.2-dev no longer 
pulls it in  
- tighen build dependency on libmia-2.2-dev
* d/rules:   correct the buildflags 
* d/copyright: Correct copyright for viewit/trackball.*
2014-09-09 - Gert Wollny <gw.fossdev@gmail.com>
miaviewit (1.0.1-1) unstable; urgency=medium
* New upstream release
* d/control: Update dependencies to libmia-2.2-dev
* d/control: correct spelling errors (Closes: #743799 #743800)
* d/control: update standards version to 3.6.5
* d/control: Add dependency on libboost-thread-dev because 
libmia-2.2.-dev no longer pulls this in. 
2013-07-04 - Gert Wollny <gw.fossdev@gmail.com>
miaviewit (1.0.0-1) unstable; urgency=low
* Initial release (Closes: #694442)

See Also

Package Description
libmiaviewit0_1.0.5-2_amd64.deb MIA addon library for 3D visualization
libmicroba-java-doc_0.4.4.3-5_all.deb Documentation for libmicroba-java
libmicroba-java_0.4.4.3-5_all.deb set of JFC (Swing) components
libmicroblog4_4.14.10-11_amd64.deb library for using the Microblog Akonadi Resource
libmicrodns-dev_0.0.10-1_amd64.deb minimal mDNS resolver and announcer library (development files)
libmicrodns0_0.0.10-1_amd64.deb minimal mDNS resolver and announcer library (shared library)
libmicrohttpd-dev_0.9.62-1_amd64.deb library embedding HTTP server functionality (development)
libmicrohttpd12_0.9.62-1_amd64.deb library embedding HTTP server functionality
libmidi-perl_0.83-1_all.deb module to read, compose, modify, and write MIDI files in Perl
libmigemo-dev_1.2+gh0.20150404-7_amd64.deb Japanese incremental search tool written in C - development binaries
libmigemo1_1.2+gh0.20150404-7_amd64.deb Japanese incremental search tool written in C - library
libmiglayout-java_5.1-2_all.deb Java Layout Manager
libmigrate-parsetree-ocaml-dev_1.2.0-2_amd64.deb Convert OCaml parsetrees between different major versions (Development package)
libmigrate-parsetree-ocaml-doc_1.2.0-2_all.deb Documentation for ocaml-migrate-parsetree
libmigrate-parsetree-ocaml_1.2.0-2_amd64.deb Convert OCaml parsetrees between different major versions (Runtime library)
Advertisement
Advertisement