libmemtailor0_1.0~git20160311-2_amd64.deb


Advertisement

Description

libmemtailor0 - C++ library of special purpose memory allocators (shared library)

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename libmemtailor0_1.0~git20160311-2_amd64.deb
Package name libmemtailor0
Package version 1.0~git20160311
Package release 2
Package architecture amd64
Package type deb
Category libs role::shared-lib
Homepage https://github.com/Macaulay2/memtailor
License -
Maintainer Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>
Download size 7.19 KB
Installed size 32.00 KB

Alternatives

Package Version Architecture Repository
libmemtailor0_1.0~git20160311-2_i386.deb 1.0~git20160311 i386 Debian Main
libmemtailor0 - - -

Requires

Name Value
libc6 >= 2.2.5
libgcc1 >= 1:3.0
libstdc++6 >= 4.1.1

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libmemtailor0_1.0~git20160311-2_amd64.deb
Source Package memtailor

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmemtailor0 deb package:
    # sudo apt-get install libmemtailor0

Files

Path
/usr/lib/x86_64-linux-gnu/libmemtailor.so.0
/usr/lib/x86_64-linux-gnu/libmemtailor.so.0.0.0
/usr/share/doc/libmemtailor0/changelog.Debian.gz
/usr/share/doc/libmemtailor0/copyright

Changelog

2018-07-14 - Doug Torrance <dtorrance@piedmont.edu>
memtailor (1.0~git20160311-2) unstable; urgency=medium
* debian/tests/control
- Add build-essential to Depends.  Tests were failing with
'g++: Command not found'.
2018-07-05 - Doug Torrance <dtorrance@piedmont.edu>
memtailor (1.0~git20160311-1) unstable; urgency=medium
* debian/compat
- Bump debhelper compatibility level to 11.
* debian/control
- Bump versioned dependency on debhelper to >= 11.
- Drop dh-autoreconf from Build-Depends; default since debhelper 10.
- Drop dpkg-dev (>= 1.18.0) from Build-Depends; debhelper depends on a
higher version.
- Bump Standards-Version to 4.1.5.
- Update Vcs-* links to Salsa.
* debian/copyright
- Use https in Format.
* debian/rules
- Remove explicit call to dh_autoreconf; default since debhelper 10.
- Drop get-orig-source target; replaced by uscan.
* debian/tests
- Replace smoke test with upstream unit tests.
* debian/upstream/metadata
- New file; add DEP-12 upstream metadata.
* debian/watch
- Use uscan with git mode to obtain upstream tarball.
2016-03-03 - Doug Torrance <dtorrance@piedmont.edu>
memtailor (1.0~git20160302-1) unstable; urgency=medium
* New upstream release.
- Now maintained by Macaulay2 developers.
* debian/control
- Bump Standards-Version to 3.9.7.
- Update Homepage.
- Use https protocol for Vcs-Browser.
- Drop libmemtailor-dbg package in favor of automatically generated
memtailor-dbgsym.
* debian/copyright
- Update Source.
* debian/libmemtailor0.symbols
- Add MEMTAILOR_VERSION_STRING.
* debian/patches
- Remove directory; patches applied upstream.
* debian/rules
- Remove override_dh_strip target; no longer needed.
- Update get-orig-source target.
- Update GTEST_PATH in override_dh_auto_configure target.
- Add --enable-shared to override_dh_auto_configure target.
- Enable all hardening flags.
2015-08-29 - Doug Torrance <dtorrance@piedmont.edu>
memtailor (1.0~git20130809-5) unstable; urgency=medium
* Update my email address.
2015-06-28 - Doug Torrance <dtorrance@monmouthcollege.edu>
memtailor (1.0~git20130809-4) unstable; urgency=medium
* debian/control
- Add dpkg-dev (>= 1.18.0) to Build-Depends; needed for arch-bits tags in
symbols file.
- Tidy using wrap-and-sort.
2015-06-19 - Doug Torrance <dtorrance@monmouthcollege.edu>
memtailor (1.0~git20130809-3) unstable; urgency=medium
* debian/tests/control
- Add pkg-config to Depends; fixes failing CI test.
2015-06-09 - Doug Torrance <dtorrance@monmouthcollege.edu>
memtailor (1.0~git20130809-2) unstable; urgency=medium
* debian/libmemtailor0.symbols
- Add arch-bits tags to certain symbols to enable builds on 32-bit
architectures.
* debian/tests/*
- Add test.
2015-03-18 - Doug Torrance <dtorrance@monmouthcollege.edu>
memtailor (1.0~git20130809-1) unstable; urgency=low
* Initial release (Closes: #780766).

See Also

Package Description
libmenhir-ocaml-dev_20181113-1_amd64.deb Menhir library for OCaml
libmenlo-legacy-perl_1.9022-1_all.deb legacy internal and client support for Menlo
libmenlo-perl_1.9019-1_all.deb CPAN client backend
libmenu-cache-bin_1.1.0-1_amd64.deb LXDE implementation of the freedesktop Menu's cache (libexec)
libmenu-cache-dev_1.1.0-1_amd64.deb LXDE implementation of the freedesktop Menu's cache (devel)
libmenu-cache-doc_1.1.0-1_all.deb LXDE implementation of the freedesktop Menu's cache (docs)
libmenu-cache3_1.1.0-1_amd64.deb LXDE implementation of the freedesktop Menu's cache
libmercator-0.3-4_0.3.3-5_amd64.deb WorldForge terrain library
libmercator-0.3-dev_0.3.3-5_amd64.deb WorldForge terrain library - development files
libmeryl-dev_0~20150903+r2013-6_amd64.deb in- and out-of-core kmer counting and utilities (development lib)
libmeschach-dev_1.2b-14_amd64.deb development files for meschach
libmeschach1.2_1.2b-14_amd64.deb library for performing operations on matrices and vectors
libmessage-filters-dev_1.14.3+ds1-5_amd64.deb Development files for Robot OS message-filters
libmessage-filters1d_1.14.3+ds1-5_amd64.deb Library for Robot OS message-filters
libmessage-passing-amqp-perl_0.007-1_all.deb input and output message-pass messages via AMQP
Advertisement
Advertisement