libmathic0v5_1.0~git20180311-2_amd64.deb


Advertisement

Description

libmathic0v5 - C++ library for Groebner basis computation (runtime library)

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename libmathic0v5_1.0~git20180311-2_amd64.deb
Package name libmathic0v5
Package version 1.0~git20180311
Package release 2
Package architecture amd64
Package type deb
Category libs role::shared-lib
Homepage https://github.com/Macaulay2/mathic
License -
Maintainer Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>
Download size 35.86 KB
Installed size 118.00 KB

Alternatives

Package Version Architecture Repository
libmathic0v5_1.0~git20180311-2_i386.deb 1.0~git20180311 i386 Debian Main
libmathic0v5 - - -

Requires

Name Value
libc6 >= 2.14
libgcc1 >= 1:3.0
libstdc++6 >= 5.2

Replaces

Name Value
libmathic0 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libmathic0v5_1.0~git20180311-2_amd64.deb
Source Package mathic

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmathic0v5 deb package:
    # sudo apt-get install libmathic0v5

Files

Path
/usr/lib/x86_64-linux-gnu/libmathic.so.0
/usr/lib/x86_64-linux-gnu/libmathic.so.0.0.0
/usr/share/doc/libmathic0v5/changelog.Debian.gz
/usr/share/doc/libmathic0v5/copyright

Changelog

2018-07-13 - Doug Torrance <dtorrance@piedmont.edu>
mathic (1.0~git20180311-2) unstable; urgency=medium
* debian/tests/control
- Add build-essential and libgtest-dev to Depends (Closes: #903720).
2018-07-09 - Doug Torrance <dtorrance@piedmont.edu>
mathic (1.0~git20180311-1) unstable; urgency=medium
* debian/compat
- Bump debhelper compatibility level to 11.
* debian/control
- Bump versioned dependency on debhelper to >= 11.
- Bump Standards-Version to 4.1.5.
- Update Vcs-* links to Salsa.
* debian/rules
- Drop get-orig-source target: replaced by uscan.
* debian/tests
- Replace smoke test with upstream unit tests.
* debian/upstream/metadata
- New file; add DEP-12 upstream metadata.
* debian/watch
- Use uscan with git mode to obtain upstream tarball.
2017-08-12 - Doug Torrance <dtorrance@piedmont.edu>
mathic (1.0~git20170606-1) unstable; urgency=medium
* New upstream release (git snapshot).
* debian/control
- Bump Standards-Version to 4.0.1.
- Bump versioned dependency on debhelper to >= 10.
- Remove Build-Depends on dh-autoreconf.
* debian/compat
- Bump debhelper compatibility level to 10.
* debian/copyright
- Use https in Format.
* debian/libmathic0v5.symbols
- Remove file for ease of maintainability (Closes: #853540).
* debian/patches/fix_typo.patch
- Remove patch; applied upstrem.
* debian/rules
- Remove call to dh_autoreconf; enabled by default with debhelper 10.
- New override_dh_makeshlibs target.  Generates tightest possible
dependency.
2016-07-15 - Doug Torrance <dtorrance@piedmont.edu>
mathic (1.0~git20160320-4) unstable; urgency=medium
* debian/control
- Bump Standards-Version to 3.9.8.
* debian/libmathic0v5.symbols
- Add optional tags to symbols missing when compiled with gcc-6
(Closes: #831109).
2016-07-12 - Doug Torrance <dtorrance@piedmont.edu>
mathic (1.0~git20160320-3) unstable; urgency=medium
* debian/libmathic0v5.symbols
- Mark additional symbols optional that are optimized away at -O3.
Thanks to Steve Langasek <steve.langasek@ubuntu.com> (Closes: #830811).
2016-03-25 - Doug Torrance <dtorrance@piedmont.edu>
mathic (1.0~git20160320-2) unstable; urgency=medium
* debian/libmathic0v5.symbols
- Add some arch-specific tags to fix FTBFS.
* debian/patches/fix_typo.patch
- Switch Forwarded to Applied-Upstream.
2016-03-20 - Doug Torrance <dtorrance@piedmont.edu>
mathic (1.0~git20160320-1) unstable; urgency=medium
* New upstream release.
- Now maintained by Macaulay2 developers.
* debian/control
- Bump versioned dependency on debhelper to >= 9.20160114.  Needed for
--dbgsym-migration option to dh_strip.
- Bump Standards-Version to 3.9.7.
- Update Homepage.
- Use https protocol for Vcs-Browser.
- Drop libmathic-dgb in favor of automatically generated
libmathic0v5-dbgsym package.
* debian/copyright
- Update Source.
- Change license to LGPL-2+. (This has actually always been the license;
I must have misread it when initially preparing the package.)
* debian/libmathic0v5.symbols
- Restore symbols file.
* debian/patches
- Remove previous patches; patches applied upstream.
* debian/patches/fix_typo.patch
- New patch. Fixes spelling-error-in-binary Lintian warning.
* debian/rules
- Enable all hardening flags.
- Update definition of GTEST_PATH for dh_auto_configure.
- Add --enable-shared to dh_auto_configure.
- Modify override_dh_strip target. Instead of building the libmathic-dbg
package, we use the --dbgsym-migration option to ensure proper migration
to the new automatically generated package.
- Update get-orig-source target with new location.
* debian/watch
- Update with new upstream webpage. Note that this is merely a comment;
upstream does not tag their releases and uscan is currently not
functional.

See Also

Package Description
libmathicgb-dev_1.0~git20170606-2_amd64.deb Compute Groebner bases (developer tools)
libmathicgb0_1.0~git20170606-2_amd64.deb Compute Groebner bases (runtime library)
libmathlib2-dev_20061220+dfsg3-4.4_amd64.deb CERNLIB data analysis suite - core mathematical library (development files)
libmathlib2-gfortran_20061220+dfsg3-4.4_amd64.deb CERNLIB data analysis suite - core mathematical library
libmatio-dev_1.5.13-3_amd64.deb MAT File I/O Library - development files
libmatio-doc_1.5.13-3_all.deb MAT File I/O Library - documentation files
libmatio4_1.5.13-3_amd64.deb Library to read and write Matlab MAT files
libmatroska-dev_1.4.9-1_amd64.deb extensible open standard audio/video container format (development files)
libmatroska6v5_1.4.9-1_amd64.deb extensible open standard audio/video container format (shared library)
libmatthew-io-java_0.8.1-1_all.deb Extra IO library for Java
libmatthew-java-doc_0.8.1-1_all.deb API documentation for the libmatthew-java libraries
libmaven-antrun-extended-plugin-java_1.43-1_all.deb Extended integration between Maven and Ant
libmaven-antrun-plugin-java_1.8-3_all.deb Maven AntRun Plugin
libmaven-archiver-java-doc_3.2.0-2_all.deb Archiver component for Maven - API documentation
libmaven-archiver-java_3.2.0-2_all.deb Archiver component for Maven
Advertisement
Advertisement