libmagickcore-6.q16-5-extra_6.9.9.39+dfsg-1_amd64.deb


Advertisement

Description

libmagickcore-6.q16-5-extra - low-level image manipulation library - extra codecs (Q16)

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name libmagickcore-6.q16-5-extra
Package version 6.9.9.39+dfsg
Package release 1
Package architecture amd64
Package type deb
Installed size 375 B
Download size 196.05 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
libmagickcore-6.q16-5-extra_6.9.9.34+dfsg-3+b1_i386.deb 6.9.9.34+dfsg i386 Debian Main
libmagickcore-6.q16-5-extra - - -

Requires

Name Value
libc6 >= 2.14
libcairo2 >= 1.6.0
libdjvulibre21 >= 3.5.27.1
libglib2.0-0 >= 2.12.0
libmagickcore-6.q16-5 >= 8:6.9.9.5
libmagickwand-6.q16-5 >= 8:6.9.9.5
libopenexr23 -
libpango-1.0-0 >= 1.22.0
libpangocairo-1.0-0 >= 1.14.0
libwmf0.2-7 >= 0.2.8.4
libxml2 >= 2.7.4

Provides

Name Value
libmagickcore-6.q16-1-extra -
libmagickcore-6.q16-2-extra -
libmagickcore-6.q16-3-extra -
libmagickcore-6.q16-4-extra -
libmagickcore-extra -

Download

Type URL
Binary Package libmagickcore-6.q16-5-extra_6.9.9.39+dfsg-1_amd64.deb
Source Package imagemagick

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmagickcore-6.q16-5-extra deb package:
    # sudo apt-get install libmagickcore-6.q16-5-extra

Files

Path
/usr/lib/x86_64-linux-gnu/ImageMagick-6.9.9/modules-Q16/coders/djvu.la
/usr/lib/x86_64-linux-gnu/ImageMagick-6.9.9/modules-Q16/coders/djvu.so
/usr/lib/x86_64-linux-gnu/ImageMagick-6.9.9/modules-Q16/coders/dot.la
/usr/lib/x86_64-linux-gnu/ImageMagick-6.9.9/modules-Q16/coders/dot.so
/usr/lib/x86_64-linux-gnu/ImageMagick-6.9.9/modules-Q16/coders/exr.la
/usr/lib/x86_64-linux-gnu/ImageMagick-6.9.9/modules-Q16/coders/exr.so
/usr/lib/x86_64-linux-gnu/ImageMagick-6.9.9/modules-Q16/coders/pango.la
/usr/lib/x86_64-linux-gnu/ImageMagick-6.9.9/modules-Q16/coders/pango.so
/usr/lib/x86_64-linux-gnu/ImageMagick-6.9.9/modules-Q16/coders/svg.la
/usr/lib/x86_64-linux-gnu/ImageMagick-6.9.9/modules-Q16/coders/svg.so
/usr/lib/x86_64-linux-gnu/ImageMagick-6.9.9/modules-Q16/coders/wmf.la
/usr/lib/x86_64-linux-gnu/ImageMagick-6.9.9/modules-Q16/coders/wmf.so
/usr/share/bug/libmagickcore-6.q16-5-extra
/usr/share/doc/libmagickcore-6.q16-5-extra/NEWS.Debian.gz
/usr/share/doc/libmagickcore-6.q16-5-extra/changelog.Debian.gz
/usr/share/doc/libmagickcore-6.q16-5-extra/changelog.gz
/usr/share/doc/libmagickcore-6.q16-5-extra/copyright

Changelog

2018-03-19 - Bastien Roucariès <rouca@debian.org>
imagemagick (8:6.9.9.39+dfsg-1) unstable; urgency=medium
* Fix security bugs (Closes: #890805):
+ Fix CVE-2018-7443: The ReadTIFFImage function in coders/tiff.c
does not properly validate the amount of image data in a file,
which allows remote attackers to cause a denial of service
(memory allocation failure in the AcquireMagickMemory function
in MagickCore/memory.c). (Closes: #891291)
+ Fix CVE-2018-7470: The IsWEBPImageLossless function in
coders/webp.c allows attackers to cause a denial of service
(segmentation violation) via a crafted file.(Closes: #891420)
+ Fix CVE-2017-17880:  there is a stack-based buffer over-read in
WriteWEBPImage in coders/webp.c, related to a
WEBP_DECODER_ABI_VERSION check.
* Provide transitional packages from arch:any packages.
(Closes: #893030)
2018-02-18 - Bastien Roucariès <rouca@debian.org>
imagemagick (8:6.9.9.34+dfsg-3) unstable; urgency=high
* Upload to unstable (urgency high due to security issues).
2018-02-12 - Bastien Roucariès <rouca@debian.org>
imagemagick (8:6.9.9.34+dfsg-2) experimental; urgency=high
* Fix FTBFS for s390x where float_t is double

See Also

Package Description
libmagickcore-6.q16-5_6.9.9.39+dfsg-1_amd64.deb low-level image manipulation library -- quantum depth Q16
libmagickcore-6.q16-6-extra_6.9.10.8+dfsg-1_amd64.deb low-level image manipulation library - extra codecs (Q16)
libmagickcore-6.q16-6_6.9.10.8+dfsg-1_amd64.deb low-level image manipulation library -- quantum depth Q16
libmagickcore-6.q16-dev_6.9.10.8+dfsg-1_amd64.deb low-level image manipulation library - development files (Q16)
libmagickcore-6.q16hdri-5-extra_6.9.9.39+dfsg-1_amd64.deb low-level image manipulation library - extra codecs (Q16HDRI)
libmagickcore-6.q16hdri-5_6.9.9.39+dfsg-1_amd64.deb low-level image manipulation library -- quantum depth Q16HDRI
libmagickcore-6.q16hdri-6-extra_6.9.10.8+dfsg-1_amd64.deb low-level image manipulation library - extra codecs (Q16HDRI)
libmagickcore-6.q16hdri-6_6.9.10.8+dfsg-1_amd64.deb low-level image manipulation library -- quantum depth Q16HDRI
libmagickcore-6.q16hdri-dev_6.9.10.8+dfsg-1_amd64.deb low-level image manipulation library - development files (Q16HDRI)
libmagickcore-dev_6.9.10.8+dfsg-1_all.deb low-level image manipulation library -- dummy package
libmagickcore-dev_6.9.9.39+dfsg-1_all.deb low-level image manipulation library -- dummy package
libmagickwand-6-headers_6.9.10.8+dfsg-1_all.deb image manipulation library - headers files
libmagickwand-6-headers_6.9.9.39+dfsg-1_all.deb image manipulation library - headers files
libmagickwand-6.q16-5_6.9.9.39+dfsg-1_amd64.deb image manipulation library -- quantum depth Q16
libmagickwand-6.q16-6_6.9.10.8+dfsg-1_amd64.deb image manipulation library -- quantum depth Q16
Advertisement
Advertisement