libmagick++-6-headers_6.9.9.39+dfsg-1_all.deb


Advertisement

Description

libmagick++-6-headers - object-oriented C++ interface to ImageMagick - header files

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name libmagick++-6-headers
Package version 6.9.9.39+dfsg
Package release 1
Package architecture all
Package type deb
Installed size 330 B
Download size 46.42 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
libmagick++-6-headers_6.9.10.8+dfsg-1_all.deb 6.9.10.8+dfsg all Debian Main
libmagick++-6-headers_6.9.10.8+dfsg-1_all.deb 6.9.10.8+dfsg all Debian Main
libmagick++-6-headers_6.9.9.34+dfsg-3_all.deb 6.9.9.34+dfsg all Debian Main
libmagick++-6-headers_6.9.7.4+dfsg-16.1_all.deb 6.9.7.4+dfsg all Debian Main
libmagick++-6-headers - - -

Requires

Name Value
dpkg >= 1.15.7.2
imagemagick-6-common = 8:6.9.9.39+dfsg-1
libmagickcore-6-headers = 8:6.9.9.39+dfsg-1
libmagickwand-6-headers = 8:6.9.9.39+dfsg-1

Download

Type URL
Binary Package libmagick++-6-headers_6.9.9.39+dfsg-1_all.deb
Source Package imagemagick

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmagick++-6-headers deb package:
    # sudo apt-get install libmagick++-6-headers

Files

Path
/usr/include/ImageMagick-6/Magick++.h
/usr/include/ImageMagick-6/Magick++/Blob.h
/usr/include/ImageMagick-6/Magick++/ChannelMoments.h
/usr/include/ImageMagick-6/Magick++/CoderInfo.h
/usr/include/ImageMagick-6/Magick++/Color.h
/usr/include/ImageMagick-6/Magick++/Drawable.h
/usr/include/ImageMagick-6/Magick++/Exception.h
/usr/include/ImageMagick-6/Magick++/Functions.h
/usr/include/ImageMagick-6/Magick++/Geometry.h
/usr/include/ImageMagick-6/Magick++/Image.h
/usr/include/ImageMagick-6/Magick++/Include.h
/usr/include/ImageMagick-6/Magick++/Montage.h
/usr/include/ImageMagick-6/Magick++/Pixels.h
/usr/include/ImageMagick-6/Magick++/ResourceLimits.h
/usr/include/ImageMagick-6/Magick++/STL.h
/usr/include/ImageMagick-6/Magick++/TypeMetric.h
/usr/share/bug/libmagick++-6-headers
/usr/share/doc/libmagick++-6-headers

Changelog

2018-03-19 - Bastien Roucariès <rouca@debian.org>
imagemagick (8:6.9.9.39+dfsg-1) unstable; urgency=medium
* Fix security bugs (Closes: #890805):
+ Fix CVE-2018-7443: The ReadTIFFImage function in coders/tiff.c
does not properly validate the amount of image data in a file,
which allows remote attackers to cause a denial of service
(memory allocation failure in the AcquireMagickMemory function
in MagickCore/memory.c). (Closes: #891291)
+ Fix CVE-2018-7470: The IsWEBPImageLossless function in
coders/webp.c allows attackers to cause a denial of service
(segmentation violation) via a crafted file.(Closes: #891420)
+ Fix CVE-2017-17880:  there is a stack-based buffer over-read in
WriteWEBPImage in coders/webp.c, related to a
WEBP_DECODER_ABI_VERSION check.
* Provide transitional packages from arch:any packages.
(Closes: #893030)
2018-02-18 - Bastien Roucariès <rouca@debian.org>
imagemagick (8:6.9.9.34+dfsg-3) unstable; urgency=high
* Upload to unstable (urgency high due to security issues).
2018-02-12 - Bastien Roucariès <rouca@debian.org>
imagemagick (8:6.9.9.34+dfsg-2) experimental; urgency=high
* Fix FTBFS for s390x where float_t is double

See Also

Package Description
libmagick++-6.q16-8_6.9.10.8+dfsg-1_amd64.deb C++ interface to ImageMagick -- quantum depth Q16
libmagick++-6.q16-dev_6.9.10.8+dfsg-1_amd64.deb C++ interface to ImageMagick - development files (Q16)
libmagick++-6.q16hdri-8_6.9.10.8+dfsg-1_amd64.deb C++ interface to ImageMagick -- quantum depth Q16HDRI
libmagick++-6.q16hdri-dev_6.9.10.8+dfsg-1_amd64.deb C++ interface to ImageMagick - development files (Q16HDRI)
libmagick++-dev_6.9.10.8+dfsg-1_all.deb object-oriented C++ interface to ImageMagick -- dummy package
libmagick++-dev_6.9.9.39+dfsg-1_all.deb object-oriented C++ interface to ImageMagick -- dummy package
libmagickcore-6-arch-config_6.9.10.8+dfsg-1_amd64.deb low-level image manipulation library - architecture header files
libmagickcore-6-headers_6.9.10.8+dfsg-1_all.deb low-level image manipulation library - header files
libmagickcore-6-headers_6.9.9.39+dfsg-1_all.deb low-level image manipulation library - header files
libmagickcore-6.q16-5-extra_6.9.9.39+dfsg-1_amd64.deb low-level image manipulation library - extra codecs (Q16)
libmagickcore-6.q16-5_6.9.9.39+dfsg-1_amd64.deb low-level image manipulation library -- quantum depth Q16
libmagickcore-6.q16-6-extra_6.9.10.8+dfsg-1_amd64.deb low-level image manipulation library - extra codecs (Q16)
libmagickcore-6.q16-6_6.9.10.8+dfsg-1_amd64.deb low-level image manipulation library -- quantum depth Q16
libmagickcore-6.q16-dev_6.9.10.8+dfsg-1_amd64.deb low-level image manipulation library - development files (Q16)
libmagickcore-6.q16hdri-5-extra_6.9.9.39+dfsg-1_amd64.deb low-level image manipulation library - extra codecs (Q16HDRI)
Advertisement
Advertisement