libmagic-ocaml_0.7.3-5+b6_amd64.deb


Advertisement

Description

libmagic-ocaml - OCaml bindings for the File type determination library

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name libmagic-ocaml
Package version 0.7.3
Package release 5+b6
Package architecture amd64
Package type deb
Installed size 29 B
Download size 6.99 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
libmagic-ocaml_0.7.3-5+b6_i386.deb 0.7.3 i386 Debian Main
libmagic-ocaml - - -

Requires

Name Value
libc6 >= 2.4
libmagic1 >= 5.12
ocaml-base-nox-4.05.0 -

Provides

Name Value
libmagic-ocaml-9qa38 -

Download

Type URL
Binary Package libmagic-ocaml_0.7.3-5+b6_amd64.deb
Source Package ocaml-magic

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmagic-ocaml deb package:
    # sudo apt-get install libmagic-ocaml

Files

Path
/usr/lib/ocaml/stublibs/dllmagic_stubs.so
/usr/share/doc/libmagic-ocaml/README
/usr/share/doc/libmagic-ocaml/changelog.Debian.amd64.gz
/usr/share/doc/libmagic-ocaml/changelog.Debian.gz
/usr/share/doc/libmagic-ocaml/changelog.gz
/usr/share/doc/libmagic-ocaml/copyright

Changelog

2009-10-12 - Romain Beauxis <toots@rastageeks.org>
ocaml-magic (0.7.3-5) unstable; urgency=low
* Bumped standards version to 3.8.3
* Switch to new automatic dependency system.
* Changed section to ocaml. 
* Versioned licenses in debian/copyright
* Fixed Vcs-* fields.
* Added patch to build with NO_CUSTOM
* Added doc-base registration.
* Clean generated files in debian/rules clean
2009-02-25 - Samuel Mimram <smimram@debian.org>
ocaml-magic (0.7.3-4) unstable; urgency=low
* Rebuild with OCaml 3.11.
* Switch packaging to git.
* Update compat to 7.
2008-12-13 - Romain Beauxis <toots@rastageeks.org>
ocaml-magic (0.7.3-3) experimental; urgency=low
* New upload to build against released 3.11
* Updated ocaml-related build-deps.
* Changed maintainer to debian ocaml packaging team. 
2008-12-02 - Romain Beauxis <toots@rastageeks.org>
ocaml-magic (0.7.3-2) experimental; urgency=low
* Upload to experimental to build against 3.11
* Versioned ocaml related build-dep to avoid confusion
* Added dh-ocaml to build-dep
* Bumped standards version (no change needed)
2008-03-24 - Romain Beauxis <toots@rastageeks.org>
ocaml-magic (0.7.3-1) unstable; urgency=low
* New upstream release
* Dropped make install fix patch: applied upstream.
* Fixed watchfile
2008-03-24 - Romain Beauxis <toots@rastageeks.org>
ocaml-magic (0.7.2-2) unstable; urgency=low
* Patched makefile to fix FTBFS on arch with no ocamlopt
2008-03-19 - Romain Beauxis <toots@rastageeks.org>
ocaml-magic (0.7.2-1) unstable; urgency=low
* New upstream release
* Better build system: patch removed
* Switched to cdbs
2008-03-07 - Romain Beauxis <toots@rastageeks.org>
ocaml-magic (0.6-3) unstable; urgency=low
* Fixed previous patch when compiling native code module binary. 
Closes: #469857
2008-02-28 - Romain Beauxis <toots@rastageeks.org>
ocaml-magic (0.6-2) unstable; urgency=low
* Fixed compilation on archs with no native compiler. 
2008-02-10 - Romain Beauxis <toots@rastageeks.org>
ocaml-magic (0.6-1) unstable; urgency=low
* Initial release. (Closes: #463500)

See Also

Package Description
libmagic1_5.34-2_amd64.deb Recognize the type of data in a file using "magic" numbers - library
libmagick++-6-headers_6.9.10.14+dfsg-7_all.deb object-oriented C++ interface to ImageMagick - header files
libmagick++-6.q16-8_6.9.10.14+dfsg-7_amd64.deb C++ interface to ImageMagick -- quantum depth Q16
libmagick++-6.q16-dev_6.9.10.14+dfsg-7_amd64.deb C++ interface to ImageMagick - development files (Q16)
libmagick++-6.q16hdri-8_6.9.10.14+dfsg-7_amd64.deb C++ interface to ImageMagick -- quantum depth Q16HDRI
libmagick++-6.q16hdri-dev_6.9.10.14+dfsg-7_amd64.deb C++ interface to ImageMagick - development files (Q16HDRI)
libmagick++-dev_6.9.10.14+dfsg-7_all.deb object-oriented C++ interface to ImageMagick -- dummy package
libmagickcore-6-arch-config_6.9.10.14+dfsg-7_amd64.deb low-level image manipulation library - architecture header files
libmagickcore-6-headers_6.9.10.14+dfsg-7_all.deb low-level image manipulation library - header files
libmagickcore-6.q16-6-extra_6.9.10.14+dfsg-7_amd64.deb low-level image manipulation library - extra codecs (Q16)
libmagickcore-6.q16-6_6.9.10.14+dfsg-7_amd64.deb low-level image manipulation library -- quantum depth Q16
libmagickcore-6.q16-dev_6.9.10.14+dfsg-7_amd64.deb low-level image manipulation library - development files (Q16)
libmagickcore-6.q16hdri-6-extra_6.9.10.14+dfsg-7_amd64.deb low-level image manipulation library - extra codecs (Q16HDRI)
libmagickcore-6.q16hdri-6_6.9.10.14+dfsg-7_amd64.deb low-level image manipulation library -- quantum depth Q16HDRI
libmagickcore-6.q16hdri-dev_6.9.10.14+dfsg-7_amd64.deb low-level image manipulation library - development files (Q16HDRI)
Advertisement
Advertisement