liblldb-8_8.0.1-3+b1_amd64.deb


Advertisement

Description

liblldb-8 - Next generation, high-performance debugger, library

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename liblldb-8_8.0.1-3+b1_amd64.deb
Package name liblldb-8
Package version 8.0.1
Package release 3+b1
Package architecture amd64
Package type deb
Category libs role::shared-lib
Homepage https://www.llvm.org/
License -
Maintainer LLVM Packaging Team <pkg-llvm-team@lists.alioth.debian.org>
Download size 7.73 MB
Installed size 31.82 MB

Alternatives

Package Version Architecture Repository
liblldb-8_8.0.1-3+b1_i386.deb 8.0.1 i386 Debian Main
liblldb-8 - - -

Requires

Name Value
libc6 >= 2.14
libedit2 >= 2.11-20080614-0
libgcc1 >= 1:3.0
libllvm8 = 1:8.0.1-3+b1
libncurses6 >= 6
libpython3.7 >= 3.7.0
libstdc++6 >= 9
libtinfo6 >= 6

Download

Type URL
Mirror ftp.br.debian.org
Binary Package liblldb-8_8.0.1-3+b1_amd64.deb
Source Package llvm-toolchain-8

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liblldb-8 deb package:
    # sudo apt-get install liblldb-8

Files

Path
/usr/lib/llvm-8/lib/liblldb.so.1
/usr/lib/llvm-8/lib/liblldbIntelFeatures.so.8
/usr/lib/llvm-8/lib/python3.7/site-packages/readline.so
/usr/lib/x86_64-linux-gnu/liblldb-8.so
/usr/lib/x86_64-linux-gnu/liblldb-8.so.1
/usr/share/doc/liblldb-8/NEWS.Debian.gz
/usr/share/doc/liblldb-8/changelog.Debian.amd64.gz
/usr/share/doc/liblldb-8/changelog.Debian.gz
/usr/share/doc/liblldb-8/copyright
/usr/share/lintian/overrides/liblldb-8

Changelog

2019-08-07 - Gianfranco Costamagna <locutusofborg@debian.org>
llvm-toolchain-8 (1:8.0.1-3) unstable; urgency=medium
* llvm-tools: depend on python2 packages too, the move to python3 was
premature and broke opt-viewer.py
2019-08-06 - Gianfranco Costamagna <locutusofborg@debian.org>
llvm-toolchain-8 (1:8.0.1-2) unstable; urgency=medium
[ Gianfranco Costamagna ]
* clangd: Fix breaks+replaces missing epoch (Closes: #934016)
* Add python to testsuite, still required by some test
2019-08-03 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-8 (1:8.0.1-1) unstable; urgency=medium
* New stable release
* Ship python3-lldb-8 as a new package
* Ship clangd-8 as a new package (Closes: #932432)
[ Gianfranco Costamagna ]
* Fixed wrong shlib generation of libomp5 library
2019-07-18 - Christian Biesinger <cbiesinger@google.com>
llvm-toolchain-8 (1:8.0.1~+rc4-2) unstable; urgency=medium
* Compile against Python 3
(Closes: #931029)
2019-07-11 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-8 (1:8.0.1~+rc4-1) unstable; urgency=medium
* New snapshot release
2019-06-28 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-8 (1:8.0.1~+rc3-1) unstable; urgency=medium
* New testing release in unstable
[ Gianfranco Costamagna ]
* Enable thinlto everywhere except armhf
* Drop wrong exit 1 from testsuite
[ Andreas Beckmann ]
* For now, lld doesn't generate shared libs. Removing the files
(Closes: #857653, LP: #1829677)
2019-06-08 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-8 (1:8.0.1~+rc2-1~exp1) experimental; urgency=medium
* New testing release
* Only enable thinlto on archs with gold, should fix the ftbfs
* Add libpfm4-dev as build dep + -DLLVM_ENABLE_LIBPFM=ON as it is
needed for llvm-exegesis https://bugs.llvm.org/show_bug.cgi?id=42187
* Improve the rendering of the qualify-clang.sh testsuite
2019-05-19 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-8 (1:8.0.1~+rc1-1~exp2) experimental; urgency=medium
* Build using thinlto on non stretch, xenial and trusty
(fails with some undef symbols)
Option -DLLVM_ENABLE_LTO="Thin" added
* WebAssembly is now build by default, remove it from the
experimental list
* check-polly was executed twice
* Move the default ARM arch from arm1176jzf-s (armv6) to cortex-a7
(Closes: #930008)
[ John Paul Adrian Glaubitz ]
* Use dh-exec to exclude lib/LLVM*.so on powerpc and
powerpcspe from llvm-X.Y-dev.install.in
2019-05-17 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-8 (1:8.0.1~+rc1-1~exp1) experimental; urgency=medium
* New testing release
2019-05-13 - Sylvestre Ledru <sylvestre@debian.org>
llvm-toolchain-8 (1:8-5) unstable; urgency=medium
* Try another way to address the mips64el issue

See Also

Package Description
liblldb-9-dev_9-3_amd64.deb Next generation, high-performance debugger, header files
liblldb-9_9-3_amd64.deb Next generation, high-performance debugger, library
liblldb-dev_8.0-48.3_amd64.deb Next generation, high-performance debugger, header files
liblldpctl-dev_1.0.4-1+b2_amd64.deb implementation of IEEE 802.1ab (LLDP) - development files
libllvm-7-ocaml-dev_7.0.1-9+b1_amd64.deb Modular compiler and toolchain technologies, OCaml bindings
libllvm-8-ocaml-dev_8.0.1-3+b1_amd64.deb Modular compiler and toolchain technologies, OCaml bindings
libllvm-9-ocaml-dev_9-3_amd64.deb Modular compiler and toolchain technologies, OCaml bindings
libllvm-ocaml-dev_8.0-48.3_amd64.deb Low-Level Virtual Machine (LLVM), bindings for OCaml
libllvm6.0_6.0.1-11_amd64.deb Modular compiler and toolchain technologies, runtime library
libllvm7_7.0.1-9+b1_amd64.deb Modular compiler and toolchain technologies, runtime library
libllvm8_8.0.1-3+b1_amd64.deb Modular compiler and toolchain technologies, runtime library
libllvm9_9-3_amd64.deb Modular compiler and toolchain technologies, runtime library
libllvmspirvlib-dev_8.0.1-1+b1_amd64.deb bi-directional translator for LLVM/SPIRV -- development files
libllvmspirvlib8_8.0.1-1+b1_amd64.deb bi-directional translator for LLVM/SPIRV -- shared library
liblmdb++-dev_0.9.14.1+git20160228.0b43ca8-1+b1_amd64.deb C++ wrapper for LMDB
Advertisement
Advertisement