liblbfgsb0_3.0+dfsg.3-7_amd64.deb


Advertisement

Description

liblbfgsb0 - Limited-memory quasi-Newton bound-constrained optimization

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename liblbfgsb0_3.0+dfsg.3-7_amd64.deb
Package name liblbfgsb0
Package version 3.0+dfsg.3
Package release 7
Package architecture amd64
Package type deb
Category libs role::shared-lib
Homepage http://users.iems.northwestern.edu/~nocedal/lbfgsb.html
License -
Maintainer Gard Spreemann <gspr@nonempty.org>
Download size 28.84 KB
Installed size 80.00 KB

Alternatives

Package Version Architecture Repository
liblbfgsb0_3.0+dfsg.3-7_i386.deb 3.0+dfsg.3 i386 Debian Main
liblbfgsb0 - - -

Requires

Name Value
libblas.so.3 -
libblas3 -
libc6 >= 2.14
libgfortran5 >= 8
liblapack.so.3 -
liblapack3 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package liblbfgsb0_3.0+dfsg.3-7_amd64.deb
Source Package lbfgsb

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liblbfgsb0 deb package:
    # sudo apt-get install liblbfgsb0

Files

Path
/usr/lib/x86_64-linux-gnu/liblbfgsb.so.0
/usr/share/doc/liblbfgsb0/changelog.Debian.gz
/usr/share/doc/liblbfgsb0/copyright

Changelog

2019-08-26 - Gard Spreemann <gspr@nonempty.org>
lbfgsb (3.0+dfsg.3-7) unstable; urgency=medium
* Man page stub for -examples package.
* Add superficial test that just checks that the upstream examples run.
2019-08-21 - Gard Spreemann <gspr@nonempty.org>
lbfgsb (3.0+dfsg.3-6) unstable; urgency=medium
* Reorder linking flag for tests.
2019-07-18 - Gard Spreemann <gspr@nonempty.org>
lbfgsb (3.0+dfsg.3-5) unstable; urgency=medium
* Remove broken symbols file.
2019-07-17 - Gard Spreemann <gspr@nonempty.org>
lbfgsb (3.0+dfsg.3-4) unstable; urgency=medium
* Standards-version 4.4.0. No changes needed.
* Compat level 12.
* Add symbols file.
* Rules-Requires-Root: no
* Change maintainer email address.
2018-06-17 - Gard Spreemann <gspreemann@gmail.com>
lbfgsb (3.0+dfsg.3-3) unstable; urgency=medium
* Statically linked test binary should link with LAPACK.
* Allow tests to print to stderr.
2018-06-13 - Gard Spreemann <gspreemann@gmail.com>
lbfgsb (3.0+dfsg.3-2) unstable; urgency=medium
* compat level 10.
* Standards-version 4.1.4. No changes needed.
* Introduce tests.
* Correct installation path for -doc package.
* Install doc-base control file.
2016-09-19 - Gard Spreemann <gspreemann@gmail.com>
lbfgsb (3.0+dfsg.3-1) unstable; urgency=medium
* Remove repack script and have uscan read Files-Excluded from
debian/copyright instead.
2016-05-20 - Gard Spreemann <gspreemann@gmail.com>
lbfgsb (3.0+dfsg.2-1) unstable; urgency=medium
* Remove unused blas.f and linpack.f during repack.
* -examples package with example programs (compiled and source) and
output from upstream.
* -doc package split off from main lib package.
* Multi-arch support for the library packages.
* Explicitly set compile flags.
* Enable hardening.
2016-05-11 - Gard Spreemann <gspreemann@gmail.com>
lbfgsb (3.0+dfsg.1-1) unstable; urgency=medium
* Initial packaging. Closes: #811069

See Also

Package Description
liblcas-dev_1.3.19-2+b2_amd64.deb Local Centre Authorization Service development files
liblcas0_1.3.19-2+b2_amd64.deb Local Centre Authorization Service runtime
liblcgdm-dev_1.13.0-1+b1_amd64.deb LCG Data Management common development files
liblcgdm1_1.13.0-1+b1_amd64.deb LHC Computing Grid Data Management common libraries
liblchown-perl_1.01-3+b6_amd64.deb Perl interface to the lchown() system call
liblcm-bin_1.3.1+repack1-2.2_amd64.deb Lightweight Communications and Marshalling
liblcm-dev_1.3.1+repack1-2.2_amd64.deb Lightweight Communications and Marshalling
liblcm-doc_1.3.1+repack1-2.2_all.deb Lightweight Communications and Marshalling
liblcm-java_1.3.1+repack1-2.2_amd64.deb Lightweight Communications and Marshalling
liblcm-lua_1.3.1+repack1-2.2_amd64.deb Lightweight Communications and Marshalling
liblcm1_1.3.1+repack1-2.2_amd64.deb Lightweight Communications and Marshalling
liblcmaps-dev_1.6.6-2+b1_amd64.deb LCMAPS development libraries
liblcmaps-without-gsi-dev_1.6.6-2+b1_amd64.deb LCMAPS development libraries (Without GSI)
liblcmaps-without-gsi0_1.6.6-2+b1_amd64.deb Grid mapping service without GSI
liblcmaps0_1.6.6-2+b1_amd64.deb Grid (X.509) and VOMS credentials to local account mapping service
Advertisement
Advertisement