libktpcommoninternals9_17.08.3-1_amd64.deb


Advertisement

Description

libktpcommoninternals9 - KDE Telepathy common internal library

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name libktpcommoninternals9
Package version 17.08.3
Package release 1
Package architecture amd64
Package type deb
Installed size 449 B
Download size 119.45 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
libktpcommoninternals9_17.08.3-1_i386.deb 17.08.3 i386 Debian Main
libktpcommoninternals9 - - -

Requires

Name Value
kaccounts-integration >= 15.04
libc6 >= 2.14
libgcc1 >= 1:3.0
libkf5configcore5 >= 4.97.0
libkf5coreaddons5 >= 4.99.0
libkf5i18n5 >= 4.97.0
libkf5iconthemes5 >= 4.96.0
libkf5notifications5 >= 4.96.0
libkf5people5 >= 0.3.0
libkf5service-bin -
libkf5service5 >= 4.96.0
libkf5wallet-bin -
libkf5wallet5 >= 4.96.0
libqt5core5a >= 5.9.0~beta
libqt5dbus5 >= 5.4
libqt5gui5 >= 5.7.0
libqt5widgets5 >= 5.4
libqt5xml5 >= 5.4
libstdc++6 >= 4.1.1
libtelepathy-logger-qt5 >= 15.04
libtelepathy-qt5-0 >= 0.9.5
telepathy-accounts-signon -

Replaces

Name Value
libktpcommoninternalsprivate6 << 0.7.80

Download

Type URL
Binary Package libktpcommoninternals9_17.08.3-1_amd64.deb
Source Package ktp-common-internals

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libktpcommoninternals9 deb package:
    # sudo apt-get install libktpcommoninternals9

Files

Path
/usr/lib/x86_64-linux-gnu/libKTpCommonInternals.so.17.08.3
/usr/lib/x86_64-linux-gnu/libKTpCommonInternals.so.9
/usr/share/doc/libktpcommoninternals9/changelog.Debian.gz
/usr/share/doc/libktpcommoninternals9/copyright

Changelog

2017-12-09 - Pino Toscano <pino@debian.org>
ktp-common-internals (17.08.3-1) unstable; urgency=medium
* Team upload.
* Upload to unstable.
* New upstream release.
* Bump Standards-Version to 4.1.2, no changes required.
* Simplify watch file, and switch it to https.
* Remove trailing whitespaces in changelog.
* Update few build & runtime dependencies:
- bump libtelepathy-logger-qt-dev to >= 17.08~
- bump libtelepathy-qt5-dev to >= 0.9.7~
* Update symbols files.
* Remove duplicated Priority in kde-telepathy-debugger.
* Adjust l10npkgs_firstversion_ok to the version where kde-l10n will
drop translations.
2017-09-11 - Maximiliano Curia <maxy@debian.org>
ktp-common-internals (17.08.1-1) experimental; urgency=medium
* Set Priority to optional
* New upstream release (17.08.1).
* Update symbols files
* Add breaks/replaces against the kde-l10n packages
* Bump group breaks (17.08)
* Release to experimental
2016-06-23 - Maximiliano Curia <maxy@debian.org>
ktp-common-internals (16.04.2-1) experimental; urgency=medium
[ Automatic packaging ]
* Update symbols files from buildds logs (16.04.1-1).
2016-05-27 - Maximiliano Curia <maxy@debian.org>
ktp-common-internals (16.04.1-1) experimental; urgency=medium
[ Maximiliano Curia ]
* New upstream release (15.12.2).
* Add dependency required by the cmake files
* Update install files
[ Automatic packaging ]
* Bump Standards-Version to 3.9.8
* Update build-deps and deps with the info from cmake
* Update symbols files.
2016-02-12 - Maximiliano Curia <maxy@debian.org>
ktp-common-internals (15.12.1-2) experimental; urgency=medium
* Add missing dependency to the -dev package.
2016-02-01 - Maximiliano Curia <maxy@debian.org>
ktp-common-internals (15.12.1-1) experimental; urgency=medium
[ Harald Sitter ]
* KDE Frameworks 5 port
+ rename lib packages for sobump
+ rename -dev package to libktp-dev to match the cmake config one
would be looking for. Also it contains more than one library anyway.
+ rename -dbg to libktp-dbg to align with the dev and also because it
affects more than one lib
+ Add all library packages as possibly depends for the dbg package. Any
one of them may be neeeded depending on the app one wants to debug.
+ Remove kde-telepathy-kpeople for now as kpeople is not released.
+ Rename kde-telepathy-declarative to qml-module-org-kde-telepathy to
align with the implicit naming policy for qml modules in Qt5 (no
conflicts)
+ Update watch file. The source now is released as part of applications.
[ Scarlett Clark ]
* This needs libtelepathy-logger-qt5-dev it is a kf5 app.
* Remove the non existant version dep for above.
* Try libtelepthy-logger-qt-dev again.
* OTR requires telepathy-qt5 >= 0.9.5
[ Diane Trout ]
* Remove all 4 relicensing patches, applied upstream.
[ Maximiliano Curia ]
* New upstream release (15.12.0).
* New upstream release (15.12.1).
2017-03-21 - Andreas Beckmann <anbe@debian.org>
ktp-common-internals (15.08.3-1.1) unstable; urgency=medium
* Non-maintainer upload.
* libktpcommoninternals9: Add Breaks: libktpcommoninternalsprivate7 to
ensure smooth upgrade paths from jessie.  (Closes: #856599)
2015-12-02 - Diane Trout <diane@ghic.org>
ktp-common-internals (15.08.3-1) unstable; urgency=medium
* New upstream release.
2015-11-10 - Diane Trout <diane@ghic.org>
ktp-common-internals (15.08.2-3) unstable; urgency=medium
* Add kaccounts-integration dependes to libktpcommoninternals9
2015-11-09 - Diane Trout <diane@ghic.org>
ktp-common-internals (15.08.2-2) unstable; urgency=medium
* Update libktpcommoninternals9 qt logger dependency to
libtelepathy-logger-qt5 (>= 15.04) (Closes: #804409)
* Change Diane Trouts email address back. (ease of SPAM filtering)
* Add telepathy-accounts-signon dependency to libktpcommoninternals9,
which is needed to integrate with kaccounts system.
* Confirm symbols on other architectures.

See Also

Package Description
libktplogger9_17.08.3-1_amd64.deb KDE Telepathy internal logger library
libktpmodels9_17.08.3-1_amd64.deb KDE Telepathy data models internal library
libktpotr9_17.08.3-1_amd64.deb KDE Telepathy internal OTR library
libktpwidgets9_17.08.3-1_amd64.deb KDE Telepathy common internal widgets library
libkunitconversion4_4.14.38-2_amd64.deb Unit Conversion library for the KDE Platform
libkutils4_4.14.38-2_amd64.deb dummy transitional library
libkvilib4_4.9.3~git20180404+dfsg-1+b1_amd64.deb KVIrc (IRC client) base library
libkwalletbackend5-5_5.51.0-1_amd64.deb Secure and unified container for user passwords
libkwargs-perl_0.01-1_all.deb Perl module for simple and clean handling of named arguments
libkwin4-effect-builtins1_5.13.5-1+b1_amd64.deb KDE window manager effect builtins library
libkwineffects11_5.13.5-1+b1_amd64.deb KDE window manager effects library
libkwinglutils11_5.13.5-1+b1_amd64.deb KDE window manager gl utils library
libkwinxrenderutils11_5.13.5-1+b1_amd64.deb KDE window manager render utils library
libkwnn-dev_1.1.1~a021+cvs20130302-7+b1_amd64.deb Header files and static library for kWnn (FreeWnn kserver)
libkwnn0_1.1.1~a021+cvs20130302-7+b1_amd64.deb FreeWnn library for kWnn (FreeWnn kserver)
Advertisement
Advertisement