libhttp-daemon-ssl-perl_1.05-01-1_all.deb


Advertisement

Description

libhttp-daemon-ssl-perl - Simple HTTP server class with SSL support

Distribution: Debian Sid
Repository: Debian Main amd64
Package name: libhttp-daemon-ssl-perl
Package version: 1.05
Package release: 01-1
Package architecture: all
Package type: deb
Installed size: 29 B
Download size: 10.03 KB
Official Mirror: ftp.br.debian.org
Description: unavailable.

Alternatives

    Download

    Source package: libhttp-daemon-ssl-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libhttp-daemon-ssl-perl deb package:
      # sudo apt-get install libhttp-daemon-ssl-perl

    Changelog

    2017-09-18 - Mike Gabriel <sunweaver@debian.org> libhttp-daemon-ssl-perl (1.05-01-1) unstable; urgency=medium * New upstream release. * debian/patches: + Drop pod-errors.diff. Not needed anymore. Resolved upstream. * debian/patches: + Update/adapt testmodule.diff. Make t/testmodule.t functional again. + Add testpost.diff. Make post.t work against with latest SSL crypto libraries. * debian/rules: + Run post.t after testmodule.t by renaming it to testpost.t (nasty hack, but works). * debian/control: + Add B-D (for t/post.t): libtest-www-mechanize-perl.

    2017-09-18 - Mike Gabriel <sunweaver@debian.org> libhttp-daemon-ssl-perl (1.04-4) unstable; urgency=medium * debian/control: + Move package under the umbrella of the Debian Perl Group with myself under Uploaders: field. (Closes: #868689). + Bump Standard-Version: to 4.1.0. Several changes needed. + Process with wrap-and-sort -t -s -a. + Add Vcs-*: fields. + Don't let SYNOPSIS start with an article. * debian/rules: + Add get-orig-source rule. * debian/watch: + Compensate 'underscore' in upstream version, by replacing it to 'dash'. * debian/copyright: + Turn into DEP-5 compliant format.

    2016-12-27 - Mike Gabriel <sunweaver@debian.org> libhttp-daemon-ssl-perl (1.04-3.1) unstable; urgency=medium * Non-maintainer upload. * debian/{control,compat}: Bump to DH version level 9. * debian/patches: Add testmodule.diff. Fix FTBFS during unit testing due to incompatibility with latest SSL libs. (Closes: #711628). This patch amongst other things regenerate the test certificates at build time. * debian/rules: Save upstream's certificate files, so that the package build stays idempotent.

    2011-04-02 - Matej Vela <vela@debian.org> libhttp-daemon-ssl-perl (1.04-3) unstable; urgency=low * Prepare for libwww-perl 6; thanks to Nicholas Bamber. Closes: #620485. - Depend on libhttp-daemon-perl | libwww-perl (<< 6). - Suggest libhttp-message-perl for HTTP::Status. * Use new 3.0 (quilt) source format. * Switch to debhelper 8. * debian/patches/pod-errors.diff: Fix missing POD markup, <http://rt.cpan.org/Ticket/Display.html?id=46038>. * debian/control: Add Homepage field. * debian/control: Drop versioned dependency on perl (>= 5.6.0-16) (a no-op since woody). * Conforms to Standards version 3.9.1.

    2008-02-26 - Matej Vela <vela@debian.org> libhttp-daemon-ssl-perl (1.04-2) unstable; urgency=low * Don't try to remove /usr/lib/perl5 if it's not there. Closes: #467907.

    2008-02-13 - Matej Vela <vela@debian.org> libhttp-daemon-ssl-perl (1.04-1) unstable; urgency=low * New upstream release. * debian/copyright: Add new upstream maintainer. * debian/rules: Install README. * debian/control: Drop versioned dependency on libio-socket-ssl-perl (the one in etch is fine). * Conforms to Standards version 3.7.3.

    2006-08-11 - Matej Vela <vela@debian.org> libhttp-daemon-ssl-perl (1.02-1) unstable; urgency=low * Initial release. Closes: #379228.

    Advertisement
    Advertisement