libgwrap-runtime2_1.9.15-3+b1_amd64.deb


Advertisement

Description

libgwrap-runtime2 - scripting interface generator for C - runtime

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename libgwrap-runtime2_1.9.15-3+b1_amd64.deb
Package name libgwrap-runtime2
Package version 1.9.15
Package release 3+b1
Package architecture amd64
Package type deb
Category libs role::shared-lib
Homepage http://www.nongnu.org/g-wrap/
License -
Maintainer Tommi Höynälänmaa <tommi.hoynalanmaa@iki.fi>
Download size 32.24 KB
Installed size 103.00 KB

Alternatives

Package Version Architecture Repository
libgwrap-runtime2_1.9.15-3_i386.deb 1.9.15 i386 Debian Main
libgwrap-runtime2 - - -

Requires

Name Value
guile-2.2-libs -
libc6 >= 2.14
libffi6 >= 3.0.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libgwrap-runtime2_1.9.15-3+b1_amd64.deb
Source Package g-wrap

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgwrap-runtime2 deb package:
    # sudo apt-get install libgwrap-runtime2

Files

Path
/usr/lib/x86_64-linux-gnu/libgwrap-core-runtime.so.2
/usr/lib/x86_64-linux-gnu/libgwrap-core-runtime.so.2.0.0
/usr/lib/x86_64-linux-gnu/libgwrap-guile-runtime.so.2
/usr/lib/x86_64-linux-gnu/libgwrap-guile-runtime.so.2.0.0
/usr/share/doc/libgwrap-runtime2/AUTHORS
/usr/share/doc/libgwrap-runtime2/NEWS.gz
/usr/share/doc/libgwrap-runtime2/README
/usr/share/doc/libgwrap-runtime2/THANKS
/usr/share/doc/libgwrap-runtime2/TODO
/usr/share/doc/libgwrap-runtime2/changelog.Debian.amd64.gz
/usr/share/doc/libgwrap-runtime2/changelog.Debian.gz
/usr/share/doc/libgwrap-runtime2/changelog.gz
/usr/share/doc/libgwrap-runtime2/copyright
/usr/share/lintian/overrides/libgwrap-runtime2

Changelog

2018-12-28 - Tommi Höynälänmaa <tommi.hoynalanmaa@iki.fi>
g-wrap (1.9.15-3) unstable; urgency=medium
* Fixed missing .asc file in upload.
2018-12-15 - Tommi Höynälänmaa <tommi.hoynalanmaa@iki.fi>
g-wrap (1.9.15-2) unstable; urgency=medium
* Changed Vcs-Git and Vcs-Browser to point into Salsa.
2018-12-13 - Tommi Höynälänmaa <tommi.hoynalanmaa@iki.fi>
g-wrap (1.9.15-1) unstable; urgency=medium
* Built for Guile 2.2.
* Changed installation directory /usr/lib to /usr/lib/<arch>.
2018-11-22 - Tommi Höynälänmaa <tommi.hoynalanmaa@iki.fi>
g-wrap (1.9.15-0.3) unstable; urgency=medium
* New maintainer (closes: #880433)
2017-07-15 - Hideki Yamane <henrich@debian.org>
g-wrap (1.9.15-0.2) unstable; urgency=medium
* Non-maintainer upload.
* debian/control
- update Vcs-*
- set Standards-Version: 4.0.0
- use Build-Depends: debhelper (>= 10) and drop unnecessary packages
* debian/compat
- set 10
* debian/rules
- simplify with debhelper 10
* debian/watch
- update version4, add pgpsig check
* add debian/upstream/signing-key.asc
2015-07-26 - Hideki Yamane <henrich@debian.org>
g-wrap (1.9.15-0.1) unstable; urgency=medium
* Non-maintainer upload.
* Imported Upstream version 1.9.15
* debian/patches
- drop 0001-Use-GUILE-instead-of-hardcoding-guile-binary-name.patch
since merged to upstream
2014-03-06 - Hideki Yamane <henrich@debian.org>
g-wrap (1.9.14-2.1) unstable; urgency=low
* Non-maintainer upload.
* Upload to unstable (Closes: #761210).
* merge changes with 1.9.14-1.1 and 1.9.14-2.
* debian/rules
- automatically use aclocal/autoconf/automake version (Closes: #713203)
- include autoreconf.mk
* debian/control
- add "Build-Depends: dh-autoreconf" to use above autoreconf.mk
* debian/patches
- add delete_aclocal_flags.patch to avoid define loop in Makefile.am
2012-06-05 - Andreas Rottmann <rotty@debian.org>
g-wrap (1.9.14-2) experimental; urgency=low
* Build against guile-2.0:
- Build-Depends, Depends and 'configure' invocation adapted.
2012-12-06 - Andreas Tille <tille@debian.org>
g-wrap (1.9.14-1.1) unstable; urgency=low
* Non-maintainer upload.
* Add missing Breaks+Replaces
Closes: #694272
2012-05-30 - Andreas Rottmann <rotty@debian.org>
g-wrap (1.9.14-1) unstable; urgency=low
* New upstream version (obsoletes the fixes/manpages patch).
* Standards-Version 3.9.3 (no changes).
* Hand-expand brace expansions in debian/*.install files, as this was an
accidential debhelper feature, according to lintian.
* Drop tg2quilt in favor of gbp-pq to ease collaboration: -
* debian/import-upstream: new helper script, taken from openafs
packaging.
* New patch "0001-Use-GUILE-instead-of-hardcoding-guile-binary-name", to
allow building with guile-1.8 even if /usr/bin/guile points to
guile-2.0.
* debian/rules: enable re-autotooling to activate patch (Build-Depends
adjusted).
* debian/rules: Explicitly set path to guile binary when invoking
configure to enforce building against guile-1.8 (for now).

See Also

Package Description
libgwyddion2-0_2.52-1_amd64.deb libraries for Gwyddion SPM analysis tool
libgwyddion20-dev_2.52-1_amd64.deb header files for Gwyddion SPM analysis tool
libgwyddion20-doc_2.52-1_all.deb HTML library API documentation for Gwyddion SPM analysis tool
libgxps-dev_0.3.1-1_amd64.deb handling and rendering XPS documents (development files)
libgxps-doc_0.3.1-1_all.deb library for handling and rendering XPS documents (documentation)
libgxps-utils_0.3.1-1_amd64.deb handling and rendering XPS documents (utilities)
libgxps2_0.3.1-1_amd64.deb handling and rendering XPS documents (library)
libgxw-dev_0.38.1-1_amd64.deb Guitarix - GTK+ library (development files)
libgxw0_0.38.1-1_amd64.deb Guitarix - GTK+ library
libgxwmm-dev_0.38.1-1_amd64.deb Guitarix - GTK+ C++ widget library (development files)
libgxwmm0_0.38.1-1_amd64.deb Guitarix - GTK+ C++ widget library
libgyoto7-dev_1.3.6-1_amd64.deb development files for libgyoto
libgyoto7_1.3.6-1_amd64.deb Gyoto framework main library an standard plug-in
libgzstream-dev_1.5+dfsg-4_amd64.deb provide functionality of zlib C-library in a C++ iostream (development)
libgzstream-tulip-4.8-0_4.8.0dfsg-2+b7_amd64.deb gzstream shared library, built for Tulip
Advertisement
Advertisement