libgit2-glib-1.0-0_0.28.0.1-1_amd64.deb


Advertisement

Description

libgit2-glib-1.0-0 - glib wrapper library around the libgit2 git access library

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename libgit2-glib-1.0-0_0.28.0.1-1_amd64.deb
Package name libgit2-glib-1.0-0
Package version 0.28.0.1
Package release 1
Package architecture amd64
Package type deb
Category libs role::shared-lib
Homepage https://wiki.gnome.org/Projects/Libgit2-glib
License -
Maintainer Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Download size 73.72 KB
Installed size 312.00 KB

Alternatives

Package Version Architecture Repository
libgit2-glib-1.0-0_0.28.0.1-1_i386.deb 0.28.0.1 i386 Debian Main
libgit2-glib-1.0-0 - - -

Requires

Name Value
libc6 >= 2.14
libgit2-27 >= 0.26.0
libglib2.0-0 >= 2.44.0

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libgit2-glib-1.0-0_0.28.0.1-1_amd64.deb
Source Package libgit2-glib

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgit2-glib-1.0-0 deb package:
    # sudo apt-get install libgit2-glib-1.0-0

Files

Path
/usr/lib/x86_64-linux-gnu/libgit2-glib-1.0.so.0
/usr/lib/x86_64-linux-gnu/libgit2-glib-1.0.so.0.2800.0
/usr/share/doc/libgit2-glib-1.0-0/NEWS.gz
/usr/share/doc/libgit2-glib-1.0-0/changelog.Debian.gz
/usr/share/doc/libgit2-glib-1.0-0/copyright

Changelog

2019-08-26 - Simon McVittie <smcv@debian.org>
libgit2-glib (0.28.0.1-1) unstable; urgency=medium
* Team upload
[ Simon McVittie ]
* New upstream release
- Compatible with libgit2 0.28 (Closes: #931684)
* d/tests/build: Rebuild and run upstream's unit test as an autopkgtest.
This exercises basic functionality of the library itself, as well as
the -dev package.
* d/p/Use-basename-in-enumtypes-templates.patch:
Add patch from Chris Lamb to make the build more reproducible
(Closes: #907793)
* Use a temporary home directory to work around #935817
(Closes: #934673)
* Standards-Version: 4.4.0 (no changes required)
* Set Rules-Requires-Root to no
[ Jongmin Kim ]
* Add new symbols
[ Pirate Praveen ]
* Use libgit2-dev >= 0.28
[ Simon McVittie ]
* Revert "Use libgit2-dev >= 0.28".
This version can be binNMU'd to be rebuilt against the new version
of libgit2 when the time comes.
2019-03-17 - Jeremy Bicha <jbicha@debian.org>
libgit2-glib (0.27.8-1) experimental; urgency=medium
* New upstream release
* Bump minimum meson to 0.48.0
* deiban/libgit2-glib-1.0-0.symbols: Add new symbols
2018-12-23 - Jeremy Bicha <jbicha@debian.org>
libgit2-glib (0.27.7-1) unstable; urgency=medium
* New upstream release
* Add -Wl,-O1 to our LDFLAGS
* Drop libgit2-0.27-compat.patch: Applied in new release
* debian/watch: Watch for odd-numbered release too
* Bump Standards-Version to 4.3.0
2018-07-08 - Simon McVittie <smcv@debian.org>
libgit2-glib (0.26.4-1) unstable; urgency=medium
* Team upload
[ Jeremy Bicha ]
* New upstream release
- No longer uses gnome-common (Closes: #829841)
* Build with meson
* Drop obsolete debian/source/options
* Bump Standards-Version to 4.1.4
[ Simon McVittie ]
* d/p/libgit2-0.27-compat.patch:
Add patch from Steve Langasek to adapt to libgit2 0.27's API,
modified so that we can build against either libgit2 0.26 or 0.27
and so will only need a binNMU for the transition (Closes: #903146)
2018-01-20 - Jeremy Bicha <jbicha@debian.org>
libgit2-glib (0.26.2-1) unstable; urgency=medium
* New upstream release
* debian/libgit2-glib-1.0-0.symbols: Add new symbols
* Add debian/docs to install NEWS
* Update debian/gbp.conf for Debian GNOME conventions
* Update Vcs fields for migration to https://salsa.debian.org/
* Bump debhelper compat to 11
2017-09-14 - Laurent Bigonville <bigon@debian.org>
libgit2-glib (0.26.0-3) unstable; urgency=medium
* Upload to unstable
2017-08-25 - Laurent Bigonville <bigon@debian.org>
libgit2-glib (0.26.0-2) experimental; urgency=medium
* Rename gir1.2-git2-glib-1.0 to gir1.2-ggit-1.0
2017-08-25 - Laurent Bigonville <bigon@debian.org>
libgit2-glib (0.26.0-1) experimental; urgency=medium
* New upstream version 0.26.0 (Closes: #872850)
* debian/control: Bump libgit2 build-dependency to 0.26.0
* debian/libgit2-glib-1.0-0.symbols: Adjust the symbols file
* Drop -dbg package and rely on the dbgsym one
* gir1.2-git2-glib-1.0.install: Install the typelib file in the m-a path
* debian/control: Bump Standards-Version to 4.1.0 (no further changes)
* Adopt the package in behalf of the Debian GNOME Maintainers team
(Closes: #851451)
* debian/control.in: Drop libgirepository1.0-dev from the
libgit2-glib-1.0-dev deps
2016-10-16 - Dmitry Smirnov <onlyjob@debian.org>
libgit2-glib (0.24.4-1) unstable; urgency=medium
* New upstream release [September 2016].
* Standards-Version: 3.9.8.
* Modernised Vcs-Browser URL.
* Fixed Vcs-Git URL.
2016-04-14 - Dmitry Smirnov <onlyjob@debian.org>
libgit2-glib (0.24.0-3) unstable; urgency=medium
* Upload to unstable.

See Also

Package Description
libgit2-glib-1.0-dev_0.28.0.1-1_amd64.deb glib wrapper library around the libgit2 git access library - development files
libgit2-glib-1.0-doc_0.28.0.1-1_all.deb glib wrapper library around the libgit2 git access library - documentation
libgitlab-api-v4-perl_0.22-1_all.deb GitLab API v4 module and command-line client
libgivaro-dev_4.1.1-2_amd64.deb arithmetic and algebraic computations - development files
libgivaro-doc_4.1.1-2_all.deb Documentation for Givaro
libgivaro9_4.1.1-2_amd64.deb arithmetic and algebraic computations
libgiza0_1.1.0-1_amd64.deb Lightweight scientific plotting library (shared library)
libgjs-dev_1.58.1-1_amd64.deb Mozilla-based javascript bindings for the GNOME platform
libgjs0g_1.58.1-1_amd64.deb Mozilla-based javascript bindings for the GNOME platform
libgkarrays-dev_2.1.0+dfsg-2+b1_amd64.deb library to query large collection of NGS sequences (development)
libgkarrays1_2.1.0+dfsg-2+b1_amd64.deb library to query large collection of NGS sequences
libgkeyfile-cil-dev_0.1-5_all.deb GObject-based wrapper library for GKeyFile -- CLI development files
libgkeyfile1.0-cil_0.1-5_all.deb GObject-based wrapper library for GKeyFile -- CLI bindings
libgkl-java_0.8.6+dfsg-1_amd64.deb Java library to manipulate SAM and BAM files
libgkl-jni_0.8.6+dfsg-1_amd64.deb native libraries of Java library to manipulate SAM and BAM files
Advertisement
Advertisement