libghc-x509-system-dev_1.6.6-4+b2_amd64.deb


Advertisement

Description

libghc-x509-system-dev - per-operating-system X.509 accessors and storage

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename libghc-x509-system-dev_1.6.6-4+b2_amd64.deb
Package name libghc-x509-system-dev
Package version 1.6.6
Package release 4+b2
Package architecture amd64
Package type deb
Category haskell
Homepage http://github.com/vincenthz/hs-certificate
License -
Maintainer Debian Haskell Group <pkg-haskell-maintainers@lists.alioth.debian.org>
Download size 23.34 KB
Installed size 151.00 KB

Alternatives

Package Version Architecture Repository
libghc-x509-system-dev_1.6.6-4+b2_i386.deb 1.6.6 i386 Debian Main
libghc-x509-system-dev - - -

Requires

Name Value
libatomic1 >= 4.8
libc6 >= 2.2.5
libghc-base-dev-4.12.0.0-a86a1 -
libghc-bytestring-dev-0.10.8.2-20f27 -
libghc-containers-dev-0.6.0.1-b7319 -
libghc-directory-dev-1.3.3.0-40647 -
libghc-filepath-dev-1.4.2.1-774a0 -
libghc-mtl-dev-2.2.2-07ff1 -
libghc-pem-dev-0.2.4-bf150 -
libghc-process-dev-1.6.5.0-e8028 -
libghc-x509-dev-1.7.5-ca103 -
libghc-x509-store-dev-1.6.7-70978 -
libgmp10 -

Provides

Name Value
libghc-x509-system-dev-1.6.6-4013c -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libghc-x509-system-dev_1.6.6-4+b2_amd64.deb
Source Package haskell-x509-system

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libghc-x509-system-dev deb package:
    # sudo apt-get install libghc-x509-system-dev

Files

Path
/usr/lib/haskell-packages/ghc/lib/x86_64-linux-ghc-8.6.5/libHSx509-system-1.6.6-4AALZvjSKPPQTnrmoyp9L-ghc8.6.5.so
/usr/lib/haskell-packages/ghc/lib/x86_64-linux-ghc-8.6.5/x509-system-1.6.6-4AALZvjSKPPQTnrmoyp9L/libHSx509-system-1.6.6-4AALZvjSKPPQTnrmoyp9L.a
/usr/lib/haskell-packages/ghc/lib/x86_64-linux-ghc-8.6.5/x509-system-1.6.6-4AALZvjSKPPQTnrmoyp9L/System/X509.dyn_hi
/usr/lib/haskell-packages/ghc/lib/x86_64-linux-ghc-8.6.5/x509-system-1.6.6-4AALZvjSKPPQTnrmoyp9L/System/X509.hi
/usr/lib/haskell-packages/ghc/lib/x86_64-linux-ghc-8.6.5/x509-system-1.6.6-4AALZvjSKPPQTnrmoyp9L/System/X509/MacOS.dyn_hi
/usr/lib/haskell-packages/ghc/lib/x86_64-linux-ghc-8.6.5/x509-system-1.6.6-4AALZvjSKPPQTnrmoyp9L/System/X509/MacOS.hi
/usr/lib/haskell-packages/ghc/lib/x86_64-linux-ghc-8.6.5/x509-system-1.6.6-4AALZvjSKPPQTnrmoyp9L/System/X509/Unix.dyn_hi
/usr/lib/haskell-packages/ghc/lib/x86_64-linux-ghc-8.6.5/x509-system-1.6.6-4AALZvjSKPPQTnrmoyp9L/System/X509/Unix.hi
/usr/share/doc/libghc-x509-system-dev/buildinfo_amd64.gz
/usr/share/doc/libghc-x509-system-dev/changelog.Debian.amd64.gz
/usr/share/doc/libghc-x509-system-dev/changelog.Debian.gz
/usr/share/doc/libghc-x509-system-dev/copyright
/usr/share/lintian/overrides/libghc-x509-system-dev
/var/lib/ghc/package.conf.d/x509-system-1.6.6.conf

Changelog

2018-10-01 - Ilias Tsitsimpis <iliastsi@debian.org>
haskell-x509-system (1.6.6-4) unstable; urgency=medium
* Remove build dependency on libghc-mtl-dev (provided by ghc-8.4.3)
2018-09-30 - Ilias Tsitsimpis <iliastsi@debian.org>
haskell-x509-system (1.6.6-3) unstable; urgency=medium
[ Clint Adams ]
* Set Rules-Requires-Root to no.
[ Ilias Tsitsimpis ]
* Bump debhelper compat level to 10
2018-04-09 - Clint Adams <clint@debian.org>
haskell-x509-system (1.6.6-2) unstable; urgency=medium
[ Ilias Tsitsimpis ]
* Change Priority to optional. Since Debian Policy version 4.0.1,
priority extra has been deprecated.
* Use the HTTPS form of the copyright-format URL
* Modify d/watch and Source field in d/copyright to use HTTPS
* Declare compliance with Debian policy 4.1.1
* Use salsa.debian.org URLs in Vcs-{Browser,Git} fields
[ Clint Adams ]
* Bump to Standards-Version 4.1.4.
2017-09-03 - Sean Whitton <spwhitton@spwhitton.name>
haskell-x509-system (1.6.6-1) unstable; urgency=medium
* New upstream release
2016-10-27 - Clint Adams <clint@debian.org>
haskell-x509-system (1.6.4-2) unstable; urgency=medium
* Upload to unstable as part of GHC 8 transition.
2016-10-10 - Clint Adams <clint@debian.org>
haskell-x509-system (1.6.4-1) experimental; urgency=medium
[ Dmitry Bogatov ]
* Use secure (https) uri in Vcs-Git field in 'debian/control'
* Bump standards version to 3.9.8 (no changes needed)
[ Clint Adams ]
* New upstream version.
2016-01-10 - Clint Adams <clint@debian.org>
haskell-x509-system (1.6.3-1) unstable; urgency=medium
* New upstream release
2015-12-04 - Clint Adams <clint@debian.org>
haskell-x509-system (1.6.1-1) unstable; urgency=medium
* New upstream release
2015-12-03 - Clint Adams <clint@debian.org>
haskell-x509-system (1.6.0-2) unstable; urgency=medium
* Switch Vcs-Git/Vcs-Browser headers to new location.
2015-08-20 - Joachim Breitner <nomeata@debian.org>
haskell-x509-system (1.6.0-1) experimental; urgency=medium
* New upstream release
* Bump standards-version to 3.9.6
* Depend on haskell-devscripts >= 0.10 to ensure that this package
builds against GHC in experimental

See Also

Package Description
libghc-x509-system-doc_1.6.6-4_all.deb per-operating-system X.509 accessors and storage; documentation
libghc-x509-system-prof_1.6.6-4+b2_amd64.deb per-operating-system X.509 accessors and storage; profiling libraries
libghc-x509-validation-dev_1.6.11-1_amd64.deb X.509 certificate and CRL validation
libghc-x509-validation-doc_1.6.11-1_all.deb X.509 certificate and CRL validation; documentation
libghc-x509-validation-prof_1.6.11-1_amd64.deb X.509 certificate and CRL validation; profiling libraries
libghc-xcb-types-dev_0.10.0-1_amd64.deb parses XML files used by the XCB project
libghc-xcb-types-doc_0.10.0-1_all.deb parses XML files used by the XCB project; documentation
libghc-xcb-types-prof_0.10.0-1_amd64.deb parses XML files used by the XCB project; profiling libraries
libghc-xdg-basedir-dev_0.2.2-10+b3_amd64.deb basic implementation of the XDG Base Directory specification
libghc-xdg-basedir-doc_0.2.2-10_all.deb basic implementation of the XDG Base Directory specification; documentation
libghc-xdg-basedir-prof_0.2.2-10+b3_amd64.deb basic implementation of the XDG Base Directory spec; profiling libraries
libghc-xml-conduit-dev_1.8.0.1-2_amd64.deb HTTP client package with conduit interface and HTTPS support
libghc-xml-conduit-doc_1.8.0.1-2_all.deb HTTP client package with conduit interface and HTTPS support; documentation
libghc-xml-conduit-prof_1.8.0.1-2_amd64.deb HTTP/HTTPS client package with conduit interface; profiling libraries
libghc-xml-conduit-writer-dev_0.1.1.2-4+b2_amd64.deb warm and fuzzy creation of XML documents
Advertisement
Advertisement