libghc-pipes-safe-dev_2.3.1-1_amd64.deb


Advertisement

Description

libghc-pipes-safe-dev - safety for the pipes ecosystem

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename libghc-pipes-safe-dev_2.3.1-1_amd64.deb
Package name libghc-pipes-safe-dev
Package version 2.3.1
Package release 1
Package architecture amd64
Package type deb
Category haskell
Homepage http://hackage.haskell.org/package/pipes-safe
License -
Maintainer Debian Haskell Group <pkg-haskell-maintainers@lists.alioth.debian.org>
Download size 70.78 KB
Installed size 722.00 KB

Alternatives

Package Version Architecture Repository
libghc-pipes-safe-dev_2.3.1-1_i386.deb 2.3.1 i386 Debian Main
libghc-pipes-safe-dev - - -

Requires

Name Value
libatomic1 >= 4.8
libc6 >= 2.2.5
libghc-base-dev-4.12.0.0-a86a1 -
libghc-containers-dev-0.6.0.1-b7319 -
libghc-exceptions-dev-0.10.2-29311 -
libghc-monad-control-dev-1.0.2.3-55bab -
libghc-mtl-dev-2.2.2-07ff1 -
libghc-pipes-dev-4.3.10-ce1b5 -
libghc-primitive-dev-0.6.4.0-082bf -
libghc-transformers-base-dev-0.4.5.2-b6c26 -
libghc-transformers-dev-0.5.6.2-08fea -
libgmp10 -

Provides

Name Value
libghc-pipes-safe-dev-2.3.1-07232 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libghc-pipes-safe-dev_2.3.1-1_amd64.deb
Source Package haskell-pipes-safe

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libghc-pipes-safe-dev deb package:
    # sudo apt-get install libghc-pipes-safe-dev

Files

Path
/usr/lib/haskell-packages/ghc/lib/x86_64-linux-ghc-8.6.5/libHSpipes-safe-2.3.1-D0qDKKVG9DQhKsKnr4l1s-ghc8.6.5.so
/usr/lib/haskell-packages/ghc/lib/x86_64-linux-ghc-8.6.5/pipes-safe-2.3.1-D0qDKKVG9DQhKsKnr4l1s/libHSpipes-safe-2.3.1-D0qDKKVG9DQhKsKnr4l1s.a
/usr/lib/haskell-packages/ghc/lib/x86_64-linux-ghc-8.6.5/pipes-safe-2.3.1-D0qDKKVG9DQhKsKnr4l1s/Pipes/Safe.dyn_hi
/usr/lib/haskell-packages/ghc/lib/x86_64-linux-ghc-8.6.5/pipes-safe-2.3.1-D0qDKKVG9DQhKsKnr4l1s/Pipes/Safe.hi
/usr/lib/haskell-packages/ghc/lib/x86_64-linux-ghc-8.6.5/pipes-safe-2.3.1-D0qDKKVG9DQhKsKnr4l1s/Pipes/Safe/Prelude.dyn_hi
/usr/lib/haskell-packages/ghc/lib/x86_64-linux-ghc-8.6.5/pipes-safe-2.3.1-D0qDKKVG9DQhKsKnr4l1s/Pipes/Safe/Prelude.hi
/usr/share/doc/libghc-pipes-safe-dev/buildinfo_amd64.gz
/usr/share/doc/libghc-pipes-safe-dev/changelog.Debian.gz
/usr/share/doc/libghc-pipes-safe-dev/changelog.gz
/usr/share/doc/libghc-pipes-safe-dev/copyright
/usr/share/lintian/overrides/libghc-pipes-safe-dev
/var/lib/ghc/package.conf.d/pipes-safe-2.3.1.conf

Changelog

2019-07-28 - Clint Adams <clint@debian.org>
haskell-pipes-safe (2.3.1-1) unstable; urgency=medium
* New upstream release
2018-10-01 - Ilias Tsitsimpis <iliastsi@debian.org>
haskell-pipes-safe (2.2.9-3) unstable; urgency=medium
* Remove build dependency on libghc-mtl-dev (provided by ghc-8.4.3)
2018-09-30 - Ilias Tsitsimpis <iliastsi@debian.org>
haskell-pipes-safe (2.2.9-2) unstable; urgency=medium
[ Clint Adams ]
* Set Rules-Requires-Root to no.
[ Ilias Tsitsimpis ]
* Bump debhelper compat level to 10
2018-04-09 - Clint Adams <clint@debian.org>
haskell-pipes-safe (2.2.9-1) unstable; urgency=medium
[ Ilias Tsitsimpis ]
* Use salsa.debian.org URLs in Vcs-{Browser,Git} fields
[ Clint Adams ]
* Bump to Standards-Version 4.1.4.
* New upstream release
2017-12-17 - Clint Adams <clint@debian.org>
haskell-pipes-safe (2.2.6-1) unstable; urgency=medium
[ Ilias Tsitsimpis ]
* Change Priority to optional. Since Debian Policy version 4.0.1,
priority extra has been deprecated.
* Use the HTTPS form of the copyright-format URL
* Modify d/watch and Source field in d/copyright to use HTTPS
* Declare compliance with Debian policy 4.1.1
[ Clint Adams ]
* New upstream release
2017-07-05 - Clint Adams <clint@debian.org>
haskell-pipes-safe (2.2.5-1) unstable; urgency=medium
* New upstream release
2016-10-27 - Clint Adams <clint@debian.org>
haskell-pipes-safe (2.2.4-3) unstable; urgency=medium
* Upload to unstable as part of GHC 8 transition.
2016-10-16 - Clint Adams <clint@debian.org>
haskell-pipes-safe (2.2.4-2) experimental; urgency=medium
* Temporarily build-depend on ghc 8.
2016-06-01 - Joachim Breitner <nomeata@debian.org>
haskell-pipes-safe (2.2.4-1) unstable; urgency=medium
[ Dmitry Bogatov ]
* Use secure (https) uri in Vcs-Git field in 'debian/control'
* Bump standards version to 3.9.8 (no changes needed)
[ Joachim Breitner ]
* New upstream release
2015-12-03 - Clint Adams <clint@debian.org>
haskell-pipes-safe (2.2.3-3) unstable; urgency=medium
* Switch Vcs-Git/Vcs-Browser headers to new location.

See Also

Package Description
libghc-pipes-safe-doc_2.3.1-1_all.deb safety for the pipes ecosystem; documentation
libghc-pipes-safe-prof_2.3.1-1_amd64.deb safety for the pipes ecosystem; profiling libraries
libghc-pipes-zlib-dev_0.4.4.2-2+b3_amd64.deb Zlib compression and decompression for Pipes streams
libghc-pipes-zlib-doc_0.4.4.2-2_all.deb Zlib compression and decompression for Pipes streams; documentation
libghc-pipes-zlib-prof_0.4.4.2-2+b3_amd64.deb Zlib compression and decompression for Pipes streams; profiling libraries
libghc-pointed-dev_5.0.1-5_amd64.deb pointed and copointed data
libghc-pointed-doc_5.0.1-5_all.deb pointed and copointed data; documentation
libghc-pointed-prof_5.0.1-5_amd64.deb pointed and copointed data; profiling libraries
libghc-pointedlist-dev_0.6.1-8+b3_amd64.deb zipper-like comonad which works as a list, tracking a position
libghc-pointedlist-doc_0.6.1-8_all.deb zipper-like comonad which works as a list, tracking a position.; documentation
libghc-pointedlist-prof_0.6.1-8+b3_amd64.deb zipper-like comonad which works as a list, tracking a position; profiling libraries
libghc-polynomial-dev_0.7.3-5+b3_amd64.deb haskell types and functions for working with polynomials
libghc-polynomial-doc_0.7.3-5_all.deb haskell types and functions for working with polynomials; documentation
libghc-polynomial-prof_0.7.3-5+b3_amd64.deb haskell types and functions for working with polynomials; profiling libraries
libghc-polyparse-dev_1.12.1-1_amd64.deb alternative parser combinator libraries for Haskell
Advertisement
Advertisement