libghc-dependent-map-dev_0.2.4.0-3+b3_amd64.deb


Advertisement

Description

libghc-dependent-map-dev - dependent finite maps

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename libghc-dependent-map-dev_0.2.4.0-3+b3_amd64.deb
Package name libghc-dependent-map-dev
Package version 0.2.4.0
Package release 3+b3
Package architecture amd64
Package type deb
Category haskell
Homepage https://github.com/mokus0/dependent-map
License -
Maintainer Debian Haskell Group <pkg-haskell-maintainers@lists.alioth.debian.org>
Download size 95.82 KB
Installed size 862.00 KB

Alternatives

Package Version Architecture Repository
libghc-dependent-map-dev_0.2.4.0-3+b3_i386.deb 0.2.4.0 i386 Debian Main
libghc-dependent-map-dev - - -

Requires

Name Value
libatomic1 >= 4.8
libc6 >= 2.2.5
libghc-base-dev-4.12.0.0-a86a1 -
libghc-containers-dev-0.6.0.1-b7319 -
libghc-dependent-sum-dev-0.4-6037c -
libgmp10 -

Provides

Name Value
libghc-dependent-map-dev-0.2.4.0-b1f4e -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libghc-dependent-map-dev_0.2.4.0-3+b3_amd64.deb
Source Package haskell-dependent-map

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libghc-dependent-map-dev deb package:
    # sudo apt-get install libghc-dependent-map-dev

Files

Path
/usr/lib/haskell-packages/ghc/lib/x86_64-linux-ghc-8.6.5/libHSdependent-map-0.2.4.0-KVR36WxF3ew73NkcOLZQ6g-ghc8.6.5.so
/usr/lib/haskell-packages/ghc/lib/x86_64-linux-ghc-8.6.5/dependent-map-0.2.4.0-KVR36WxF3ew73NkcOLZQ6g/libHSdependent-map-0.2.4.0-KVR36WxF3ew73NkcOLZQ6g.a
/usr/lib/haskell-packages/ghc/lib/x86_64-linux-ghc-8.6.5/dependent-map-0.2.4.0-KVR36WxF3ew73NkcOLZQ6g/Data/Dependent/Map.dyn_hi
/usr/lib/haskell-packages/ghc/lib/x86_64-linux-ghc-8.6.5/dependent-map-0.2.4.0-KVR36WxF3ew73NkcOLZQ6g/Data/Dependent/Map.hi
/usr/lib/haskell-packages/ghc/lib/x86_64-linux-ghc-8.6.5/dependent-map-0.2.4.0-KVR36WxF3ew73NkcOLZQ6g/Data/Dependent/Map/Internal.dyn_hi
/usr/lib/haskell-packages/ghc/lib/x86_64-linux-ghc-8.6.5/dependent-map-0.2.4.0-KVR36WxF3ew73NkcOLZQ6g/Data/Dependent/Map/Internal.hi
/usr/lib/haskell-packages/ghc/lib/x86_64-linux-ghc-8.6.5/dependent-map-0.2.4.0-KVR36WxF3ew73NkcOLZQ6g/Data/Dependent/Map/PtrEquality.dyn_hi
/usr/lib/haskell-packages/ghc/lib/x86_64-linux-ghc-8.6.5/dependent-map-0.2.4.0-KVR36WxF3ew73NkcOLZQ6g/Data/Dependent/Map/PtrEquality.hi
/usr/share/doc/libghc-dependent-map-dev/buildinfo_amd64.gz
/usr/share/doc/libghc-dependent-map-dev/changelog.Debian.amd64.gz
/usr/share/doc/libghc-dependent-map-dev/changelog.Debian.gz
/usr/share/doc/libghc-dependent-map-dev/copyright
/usr/share/lintian/overrides/libghc-dependent-map-dev
/var/lib/ghc/package.conf.d/dependent-map-0.2.4.0.conf

Changelog

2018-09-30 - Ilias Tsitsimpis <iliastsi@debian.org>
haskell-dependent-map (0.2.4.0-3) unstable; urgency=medium
[ Clint Adams ]
* Set Rules-Requires-Root to no.
[ Ilias Tsitsimpis ]
* Bump debhelper compat level to 10
2018-04-09 - Clint Adams <clint@debian.org>
haskell-dependent-map (0.2.4.0-2) unstable; urgency=medium
[ Ilias Tsitsimpis ]
* Change Priority to optional. Since Debian Policy version 4.0.1,
priority extra has been deprecated.
* Use the HTTPS form of the copyright-format URL
* Modify d/watch and Source field in d/copyright to use HTTPS
* Declare compliance with Debian policy 4.1.1
* Use salsa.debian.org URLs in Vcs-{Browser,Git} fields
[ Clint Adams ]
* Bump to Standards-Version 4.1.4.
2017-06-17 - Clint Adams <clint@debian.org>
haskell-dependent-map (0.2.4.0-1) unstable; urgency=medium
* New upstream release
2016-10-27 - Clint Adams <clint@debian.org>
haskell-dependent-map (0.2.3.0-3) unstable; urgency=medium
* Upload to unstable as part of GHC 8 transition.
2016-10-14 - Clint Adams <clint@debian.org>
haskell-dependent-map (0.2.3.0-2) experimental; urgency=medium
* Temporarily build-depend on ghc 8.
2016-09-04 - Clint Adams <clint@debian.org>
haskell-dependent-map (0.2.3.0-1) unstable; urgency=medium
* New upstream release
2016-05-29 - Joachim Breitner <nomeata@debian.org>
haskell-dependent-map (0.2.2.0-1) unstable; urgency=medium
[ Dmitry Bogatov ]
* Use secure (https) uri in Vcs-Git field in 'debian/control'
* Bump standards version to 3.9.8 (no changes needed)
[ Joachim Breitner ]
* New upstream release
2016-03-13 - Clint Adams <clint@debian.org>
haskell-dependent-map (0.2.1.0-1) unstable; urgency=medium
* New upstream release
2015-12-03 - Clint Adams <clint@debian.org>
haskell-dependent-map (0.1.1.3-2) unstable; urgency=medium
* Switch Vcs-Git/Vcs-Browser headers to new location.
2015-08-20 - Joachim Breitner <nomeata@debian.org>
haskell-dependent-map (0.1.1.3-1) experimental; urgency=medium
* New upstream release
* Bump standards-version to 3.9.6
* Depend on haskell-devscripts >= 0.10 to ensure that this package
builds against GHC in experimental

See Also

Package Description
libghc-dependent-map-doc_0.2.4.0-3_all.deb dependent finite maps; documentation
libghc-dependent-map-prof_0.2.4.0-3+b3_amd64.deb dependent finite maps; profiling libraries
libghc-dependent-sum-dev_0.4-3+b3_amd64.deb Dependent sum type
libghc-dependent-sum-doc_0.4-3_all.deb Dependent sum type; documentation
libghc-dependent-sum-prof_0.4-3+b3_amd64.deb Dependent sum type; profiling libraries
libghc-dependent-sum-template-dev_0.0.0.6-3+b3_amd64.deb Automatically generate instances of classes in dependent-sum package
libghc-dependent-sum-template-doc_0.0.0.6-3_all.deb Automatically generate instances of classes in dependent-sum package; documentation
libghc-dependent-sum-template-prof_0.0.0.6-3+b3_amd64.deb Automatically generate instances of classes in dependent-sum package; profiling libraries
libghc-derive-dev_2.6.5-1_amd64.deb Deriving instances for data types in Haskell
libghc-derive-doc_2.6.5-1_all.deb Deriving instances for data types in Haskell; documentation
libghc-derive-prof_2.6.5-1_amd64.deb Deriving instances for data types in Haskell; profiling libraries
libghc-deriving-compat-dev_0.5.6-1_amd64.deb backports of GHC deriving extensions
libghc-deriving-compat-doc_0.5.6-1_all.deb backports of GHC deriving extensions; documentation
libghc-deriving-compat-prof_0.5.6-1_amd64.deb backports of GHC deriving extensions; profiling libraries
libghc-descriptive-dev_0.9.5-2+b3_amd64.deb Self-describing consumers/parsers; forms, cmd-line args, JSON, etc
Advertisement
Advertisement