libextractor3_1.6-2_amd64.deb


Advertisement

Description

libextractor3 - extracts meta-data from files of arbitrary type (library)

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name libextractor3
Package version 1.6
Package release 2
Package architecture amd64
Package type deb
Installed size 492 B
Download size 110.16 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
libextractor3_1.6-2_i386.deb 1.6 i386 Debian Main
libextractor3_1.6-dmo2_i386.deb 1.6 i386 Multimedia Main
libextractor3_1.6-dmo2_amd64.deb 1.6 amd64 Multimedia Main
libextractor3 - - -

Requires

Name Value
libarchive13 >= 3.0.4
libavcodec-extra57 >= 7:3.4.1
libavcodec57 >= 7:3.4.1
libavformat57 >= 7:3.4.1
libavresample3 >= 7:3.4.1
libavutil55 >= 7:3.4.1
libbz2-1.0 -
libc6 >= 2.15
libexiv2-14 >= 0.25
libflac8 >= 1.3.0
libgcc1 >= 1:3.0
libgdk-pixbuf2.0-0 >= 2.22.0
libgif7 >= 5.1
libglib2.0-0 >= 2.12.0
libgsf-1-114 >= 1.14.24
libgstreamer-plugins-base1.0-0 >= 1.0.0
libgstreamer1.0-0 >= 1.4.0
libjpeg62-turbo >= 1.3.1
libltdl7 >= 2.4.6
libmagic1 >= 5.12
libmpeg2-4 >= 0.5.1
libogg0 >= 1.0rc3
librpm8 >= 4.14.0+dfsg1
libsmf0 >= 1.3
libstdc++6 >= 5.2
libswscale4 >= 7:3.4.1
libtidy5 >= 5.2.0
libtiff5 >= 4.0.3
libvorbis0a >= 1.1.2
libvorbisfile3 >= 1.1.2
libxml2 >= 2.6.27
zlib1g >= 1:1.1.4

Conflicts

Name Value
libextractor1c2a -

Replaces

Name Value
libextractor-plugins << 1:1.0.1-1
libextractor1c2a -

Download

Type URL
Binary Package libextractor3_1.6-2_amd64.deb
Source Package libextractor

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libextractor3 deb package:
    # sudo apt-get install libextractor3

Files

Path
/usr/lib/x86_64-linux-gnu/libextractor.so.3
/usr/lib/x86_64-linux-gnu/libextractor.so.3.1.5
/usr/lib/x86_64-linux-gnu/libextractor_common.so.1
/usr/lib/x86_64-linux-gnu/libextractor_common.so.1.0.0
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_archive.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_deb.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_dvi.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_exiv2.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_flac.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_gif.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_gstreamer.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_html.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_it.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_jpeg.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_man.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_midi.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_mime.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_mpeg.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_nsf.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_nsfe.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_odf.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_ogg.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_ole2.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_pdf.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_png.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_previewopus.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_ps.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_riff.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_rpm.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_s3m.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_sid.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_thumbnailffmpeg.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_thumbnailgtk.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_tiff.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_wav.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_xm.so
/usr/lib/x86_64-linux-gnu/libextractor/libextractor_zip.so
/usr/share/doc/libextractor3/AUTHORS
/usr/share/doc/libextractor3/NEWS.gz
/usr/share/doc/libextractor3/README
/usr/share/doc/libextractor3/TODO
/usr/share/doc/libextractor3/changelog.Debian.gz
/usr/share/doc/libextractor3/changelog.gz
/usr/share/doc/libextractor3/copyright

Changelog

2017-12-28 - Bertrand Marc <bmarc@debian.org>
libextractor (1:1.6-2) unstable; urgency=medium
* Add patches from upstream to fix CVE-2017-15922 (Closes: #880016) and 
CVE-2017-17440 (Closes: #883528).
* Standards-version: 4.1.3.
2017-10-21 - Bertrand Marc <bmarc@debian.org>
libextractor (1:1.6-1) unstable; urgency=medium
* New upstream version 1.6: fixes CVE-2017-15266, CVE-2017-15267,
CVE-2017-15600, CVE-2017-15601, CVE-2017-15602 (Closes: #878314).
* Standards-version: 4.1.1.
* Use https instead of ftp in debian/watch.
2017-09-24 - Bertrand Marc <bmarc@debian.org>
libextractor (1:1.4-1) unstable; urgency=medium
* debian/control: fix Vcs-git and Vcs-browser fields.
* Use my @debian.org address for the maintainer field and in debian/copyright.
* Migrate from a manual "-dbg" package to an automatic generated debug symbol
package:
+ debian/control: remove libextractor-dbg.
+ debian/rules: use --dbgsym-migration in override_dh_strip.
* Make libextractor3 and libextractor-dev multiarch: same.
* Use an armored upstream signing key and add the new upstream key in
debian/upstream/signing-key.asc.
* New upstream version 1.4.
* debian/copyright:
+ use copyright format 1.0.
+ update years.
* Standards-version: 4.1.0.
* Remove ffmpeg2.9 and libgiflib5.1 patches, applied upstream.
* Add one new symbol to debian/libextractor3.symbols.
* Add a patch updating m4/ax_create_pkgconfig_info.m4 to fix libextractor.pc,
thanks to Sven Joachim (Closes: #876554).
2016-04-26 - Bertrand Marc <beberking@gmail.com>
libextractor (1:1.3-4) unstable; urgency=medium
* Update debian/patches/ffmpeg2.9.patch with a new commit taken from upstream
svn, to make libextractor build with FFmpeg 2.9 (Closes: #803835).
* Standards-version: 3.9.8.
* debian/control: use secure URI for the Vcs-* fields.
2015-11-15 - Bertrand Marc <beberking@gmail.com>
libextractor (1:1.3-3) unstable; urgency=medium
* Update long description to list the supported formats.
* Add a patch cherry-picked from upstream to fix FTBFS with FFmpeg 2.9
(Closes: #803835).
* Add a patch cherry-picked from upstream to support GIF 5.1
(Closes: #803282).
* debian/control: pre-depends on ${misc:Pre-Depends} instead of
multiarch-support.
* Standards-version: 3.9.6.
2014-09-30 - Bertrand Marc <beberking@gmail.com>
libextractor (1:1.3-2) unstable; urgency=medium
* Build-depend on libmagic-dev and libavresample-dev to enable additional
plugins, thanks to Andreas Cadhalpun and update libexctractor3.symbols
accordingly (Closes: #755810).
* Build-depend on libjpeg-dev instead of libjpeg8-dev, thanks to Ondřej Surý
(Closes: #763478).
2014-01-19 - Bertrand Marc <beberking@gmail.com>
libextractor (1:1.3-1) unstable; urgency=medium
* Make uscan check the archive signature:
+ add the upstream key to debian/upstream-signing-key.pgp.
+ add the binary key to debian/source/include-binaries.
+ add pgpsigurlmangle to debian/watch.
* Imported Upstream version 1.3.
* Standards version 3.9.5:
+ remove dependency on dpkg (>= 1.15.4) | install-info.
* Build-depend on libtiff-dev instead of libtiff4-dev (Closes: #736021).
* Add a missing build-dependency on texinfo.
2013-10-28 - Bertrand Marc <beberking@gmail.com>
libextractor (1:1.2-1) unstable; urgency=low
* Imported Upstream version 1.2

See Also

Package Description
libexttextcat-2.0-0_3.4.5-1_amd64.deb Language detection library
libexttextcat-data_3.4.5-1_all.deb Language detection library - data files
libexttextcat-dev_3.4.5-1_amd64.deb Language detection library - development files
libextunix-ocaml-dev_0.1.6-1_amd64.deb Extended functions for OCaml Unix module (development package)
libextunix-ocaml_0.1.6-1_amd64.deb Extended functions for OCaml Unix module (runtime package)
libextutils-autoinstall-perl_0.64-1_all.deb module to automatically install dependencies via CPAN
libextutils-cbuilder-perl_0.280230-1_all.deb module to compile and link C code for Perl modules
libextutils-cchecker-perl_0.10-1_all.deb helper module for handling C headers and libraries
libextutils-config-perl_0.008-2_all.deb wrapper around Perl's configuration hash
libextutils-cppguess-perl_0.12-1_all.deb Perl build helper to guess C++ compiler and flags
libextutils-depends-perl_0.405-1_all.deb Perl module for building extensions that depend on other extensions
libextutils-f77-perl_1.20-1_all.deb module to compile and link FORTRAN 77 code for Perl modules
libextutils-helpers-perl_0.026-1_all.deb various portability utilities for module builders
libextutils-installpaths-perl_0.012-1_all.deb module to make Build.PL install path logic easy
libextutils-libbuilder-perl_0.08-1_all.deb Perl module to compile standard, self-contained C libraries
Advertisement
Advertisement