libevas1-engines-fb_1.21.1-5_amd64.deb


Advertisement

Description

libevas1-engines-fb - Evas module providing the Framebuffer engine

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename libevas1-engines-fb_1.21.1-5_amd64.deb
Package name libevas1-engines-fb
Package version 1.21.1
Package release 5
Package architecture amd64
Package type deb
Category libs role::shared-lib
Homepage https://www.enlightenment.org
License -
Maintainer Debian Pkg-e Team <pkg-e-devel@lists.alioth.debian.org>
Download size 42.91 KB
Installed size 94.00 KB

Alternatives

Package Version Architecture Repository
libevas1-engines-fb_1.21.1-5_i386.deb 1.21.1 i386 Debian Main
libevas1-engines-fb - - -

Requires

Name Value
libc6 >= 2.4
libecore1 >= 1.21.1-0~eo
libector1 >= 1.21.1-0~eo
libeet1 >= 1.21.1-0~eo
libeina1a >= 1.21.1-0~eo
libemile1 >= 1.21.1-0~eo
libevas1 >= 1.21.1-0~eo
libfontconfig1 >= 2.12.6
libfreetype6 >= 2.2.1
libfribidi0 >= 0.19.2
libharfbuzz0b >= 0.6.0
libjpeg62-turbo >= 1.3.1
libluajit-5.1-2 >= 2.0.4+dfsg
libpng16-16 >= 1.6.2-1
zlib1g >= 1:1.1.4

Provides

Name Value
libevas1-engine -

Replaces

Name Value
libevas-engines-extras -
libevas1-engine-fb -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libevas1-engines-fb_1.21.1-5_amd64.deb
Source Package efl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libevas1-engines-fb deb package:
    # sudo apt-get install libevas1-engines-fb

Files

Path
/usr/lib/x86_64-linux-gnu/evas/modules/engines/fb/v-1.21/module.so
/usr/share/doc/libevas1-engines-fb/changelog.Debian.gz
/usr/share/doc/libevas1-engines-fb/changelog.gz
/usr/share/doc/libevas1-engines-fb/copyright

Changelog

2019-02-12 - Ross Vandegrift <ross@kallisti.us>
efl (1.21.1-5) unstable; urgency=medium
* d/patches/25_fix_glinptr_redef.diff: Fix FTBFS on 32-bit arches with
mesa >= 18.3.
2019-02-11 - Ross Vandegrift <ross@kallisti.us>
efl (1.21.1-4) unstable; urgency=medium
* d/control:
+ efl-doc should be Multi-Arch: foreign
+ libelementary1 should be Multi-Arch: same
+ libelementary-data should be Multi-Arch: foreign
+ Bump Standards-Verison to 4.3.0, no changes required
+ Refresh package descriptions from upstream info
* d/libelementary1.symbols: add missing Build-Depends-Package field
* libelementary-data: move icon readme to docs dir
2018-10-22 - Andreas Metzler <ametzler@debian.org>
efl (1.21.1-3) unstable; urgency=medium
* Limit libunwind-dev b-d to the architectures where the package is
available.
2018-10-18 - Ross Vandegrift <ross@kallisti.us>
efl (1.21.1-2) unstable; urgency=medium
* Fix FTBFS: re-tag evas_common_scale_rgba_in_to_out_clip_smooth_mmx
symbol as arch specific for any-amd64 and any-i386.  Tag was
accidentally dropped in d7a3e88e5e.
2018-10-13 - Ross Vandegrift <ross@kallisti.us>
efl (1.21.1-1) unstable; urgency=medium
* New upstream release.
* d/patches:
+ 05-fix-signedness-mismatch.diff: drop, applied upstream
+ 50-fix-edje_recc-bashism.diff: drop, applied upstream
+ 20_disable_doxygen_timestamps.diff: defuzz
+ 99-fix-shader-regen.diff: add missing depend on ector .x file
+ 05_eina_strbuf_explicit_format_strings.diff: fix format string to build
with -Werror=format-security.
+ 10_remove_google_analytics.diff: remove remote js loading from docs
* Add new Build-Depends:
+ libxkbcommon-x11-dev is now required
+ libunwind-dev for improved backtraces
* Bump eo symbol versions for 1.21.1 release, sort libeina1a.symbols to
match order of dpkg-gensymbols output.
* d/copyright: cleanup unused paragraphs
* Ship ecore_el2_dmabuf module.
2018-09-01 - Andreas Metzler <ametzler@debian.org>
efl (1.20.7-7) unstable; urgency=medium
* Correct Breaks/Replaces of libefl-all-dev on transition packages. Use
"<< 1.20.5-1" instead of "<< ${binary:Version})". Closes: #907741
(Thanks, Adrian Bunk)
* Also drop related (now unused) lintian overrides.
2018-06-21 - Ross Vandegrift <ross@kallisti.us>
efl (1.20.7-6) unstable; urgency=low
[ Andreas Metzler ]
* Remove Nicolas Braud-Santoni from uploaders list. (Thank you!)
Closes: #901037
[ Ross Vandegrift ]
* d/patches/20_disable_doxygen_timestamps.diff: disable timestamps to
improve reproducibility of efl-doc.
* d/control: add libevas1-engines-drm to libeina1a Breaks to ensure it
is upgraded in lock-step with other EFL components.
* Try to avoid circular dependency by demoting libevas1 Depends on
libevas1-engines-x to Recommends. (Closes: #901624)
* Add the other engines to libevas1 Recommends to improve upon the
solution for #900594.
2018-06-06 - Andreas Metzler <ametzler@debian.org>
efl (1.20.7-5) unstable; urgency=low
* Change libevas1' dependency on libevas1-engine (a virtual package) to
libevas1-engines-x | libevas1-engine, preventing apt from choosing
wayland packages by default. Closes: #900594
* Move license texts to the end of debian/copyright.
global-files-wildcard-not-first-paragraph-in-dep5-copyright
* Do not ship jquery.js, it is not used.
2018-03-27 - Andreas Metzler <ametzler@debian.org>
efl (1.20.7-4) unstable; urgency=medium
* Undo workaround in previous upload, libinput-dev did the same thing, which
is the right place to do it.
* As on arm64 (try to) build with lua-old on s390x.
2018-03-18 - Andreas Metzler <ametzler@debian.org>
efl (1.20.7-3) unstable; urgency=medium
* As a temporary work around for #892956 add build-depends (and
libefl-all-dev depends) on libwacom-dev, libmtdev-dev, libevdev-dev.

See Also

Package Description
libevas1-engines-wayland_1.21.1-5_amd64.deb Evas module providing the Wayland engine
libevas1-engines-x_1.21.1-5_amd64.deb Evas module providing the X11 engines
libevas1_1.21.1-5_amd64.deb EFL advanced canvas library
libevd-0.2-0_0.2.0-1_amd64.deb Peer-to-peer inter-process communication library - Shared libraries
libevd-0.2-dev_0.2.0-1_amd64.deb Peer-to-peer inter-process communication library - Development files
libevdev-dev_1.7.0+dfsg-1_amd64.deb wrapper library for evdev devices - development files
libevdev-doc_1.7.0+dfsg-1_all.deb wrapper library for evdev devices - development docs
libevdev-tools_1.7.0+dfsg-1_amd64.deb wrapper library for evdev devices - tools
libevdev2_1.7.0+dfsg-1_amd64.deb wrapper library for evdev devices
libevdi0-dev_1.6.0+dfsg-1_all.deb EVDI driver client library dev package
libevdi0_1.6.0+dfsg-1_amd64.deb Extensible Virtual Display Interface driver client library
libevdocument3-4_3.30.2-3_amd64.deb Document (PostScript, PDF) rendering library
libevemu-dev_2.7.0-1_amd64.deb Linux Input Event Device Emulation Library - development files
libevemu3_2.7.0-1_amd64.deb Linux Input Event Device Emulation Library
libevent-2.1-6_2.1.8-stable-4_amd64.deb Asynchronous event notification library
Advertisement
Advertisement