libelektra4-python_0.8.14-5.1_amd64.deb


Advertisement

Description

libelektra4-python - elektra configuration store, python plugin

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name libelektra4-python
Package version 0.8.14
Package release 5.1
Package architecture amd64
Package type deb
Installed size 58 B
Download size 18.43 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
libelektra4-python_0.8.14-5.1_i386.deb 0.8.14 i386 Debian Main
libelektra4-python - - -

Requires

Name Value
libc6 >= 2.4
libelektra4 = 0.8.14-5.1
libgcc1 >= 1:3.0
libpython3.5 >= 3.5.0~b1
libstdc++6 >= 4.4.0

Download

Type URL
Binary Package libelektra4-python_0.8.14-5.1_amd64.deb
Source Package elektra

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libelektra4-python deb package:
    # sudo apt-get install libelektra4-python

Files

Path
/usr/lib/x86_64-linux-gnu/elektra4/libelektra-python.so
/usr/share/doc/libelektra4-python/changelog.Debian.gz
/usr/share/doc/libelektra4-python/copyright
/usr/share/lintian/overrides/libelektra4-python

Changelog

2016-05-29 - Andreas Bombe <aeb@debian.org>
elektra (0.8.14-5.1) unstable; urgency=medium
* Non-maintainer upload.
* Add patch to fix build failure due to missing include in kdbtimer.hpp
(Closes: #824463)
2015-12-13 - Pino Toscano <pino@debian.org>
elektra (0.8.14-5) unstable; urgency=medium
* Replace patch lua-fix-Key-tostring.diff with upstream
upstream_lua-fix-Key-tostring.patch.
* Replace patches python-fix-flags-in-Key.diff and lua-fix-flags-in-Key.diff
with upstream upstream_bindings-fix-size-of-KEY_FLAGS-value.patch.
* Enable the augeas plugin:
- add the libaugeas-dev build dependency
- create a new libelektra4-augeas package
* Create a new libelektra4-lua for the lua plugin.
* Create a new libelektra4-python for the python plugin.
* Improve the libelektragetenv.so handling:
- move it from elektra-bin to libelektra4, adding proper breaks/replaces
- help dh_shlibdeps finding it
- exclude it from the shared libraries (dh_makeshlibs job)
* Enable the Qt gui:
- add the qtbase-dev, qtdeclarative5-dev, libmarkdown2-dev, and discount
build dependencies
- create a new elektra-qt-gui package
* Link in as-needed mode.
* Add in libelektra4 all the plugins as suggests.
* Backport upstream commit b547ec94840f155c0fe517afdcf46043a99c8b04 to mark
the convert-hosts script as bash-specific; patch
upstream_convert-hosts-switch-to-bash.patch.
2015-12-08 - Pino Toscano <pino@debian.org>
elektra (0.8.14-4) unstable; urgency=medium
* Fix the lua binding, to not return free'd memory in Key:tostring();
patch lua-fix-Key-tostring.diff.
* Fix the handling of KEY_FLAGS in the vararg constructor of Key, in both
lua and python3 bindings; patches python-fix-flags-in-Key.diff and
lua-fix-flags-in-Key.diff.
2015-12-05 - Pino Toscano <pino@debian.org>
elektra (0.8.14-3) unstable; urgency=medium
* examples-c-pp autopkgtest: build the C++ examples with -std=c++11,
as it is required by the C++ API now.
* python3-elektra: fix path to the examples.
* Fix the elektra-getenv libc wrapper on powerpc; patch getenv-ppc.diff.
* Fix build without PATH_MAX; patch path-max.diff.
2015-11-29 - Pino Toscano <pino@debian.org>
elektra (0.8.14-2) unstable; urgency=medium
* Do not disable the documentation on arch-only builds, as that disables
also the extra man pages.
* Move ruby-ronn as normal build dependency, to be always installed.
2015-11-29 - Pino Toscano <pino@debian.org>
elektra (0.8.14-1) unstable; urgency=medium
* New upstream release.
* Update the patches:
- upstream_Fix-vararg-type-for-KEY_FLAGS.patch: drop, backported
- upstream_fix-238-keyName-example.patch: drop, backported
- private_elektratools.diff: refresh
* Re-enable usage of system gtest, as it has been fixed upstream.
* Update install files.
* Update copyright.
* Update lintian overrides.
* Make elektra-tests depend on elektra-bin, as the latter contains the
elektra-getenv stuff.
* Workaround the internal broken list_filter() cmake function; patch
avoid-list-filter.diff.
* Update symbols file.
* Add ruby-ronn as Build-Depends-Indep, as it's used in the generation of
the documentation.
2015-07-26 - Pino Toscano <pino@debian.org>
elektra (0.8.12-2) unstable; urgency=medium
* Upload to unstable.
* autopkgtest tests: switch from `...` syntax to $(...).
* Backport upstream commit aca7c1e86285319bb41dde8eb3e5feb71a902931 to fix
extraction of KEY_FLAGS varargs (crashes on powerpc, for example); patch
upstream_Fix-vararg-type-for-KEY_FLAGS.patch.
* Backport upstream commit 0b56b84154497078d7d084611b9f6adeb074b4d2 to fix
the keyName.c example; patch upstream_fix-238-keyName-example.patch.
* Update copyright.

See Also

Package Description
libelektra4-xmltool_0.8.14-5.1_amd64.deb elektra configuration store, xmltool plugin
libelektra4-yajl_0.8.14-5.1_amd64.deb elektra configuration store, yajl plugin
libelektra4_0.8.14-5.1_amd64.deb elektra configuration store, main library
libelemental-dev_1.2.0-11_amd64.deb Periodic Table viewer (development files)
libelemental-doc_1.2.0-11_all.deb Periodic Table viewer (API documentation)
libelemental0_1.2.0-11_amd64.deb Periodic Table viewer (data and shared library)
libelementary-bin_1.20.7-6_amd64.deb EFL-based widget set library - helper programs
libelementary-data_1.20.7-6_all.deb runtime data-files for libelementary
libelementary-dev_1.20.7-6_all.deb transitional EFL development package
libelementary1_1.20.7-6_amd64.deb EFL-based widget set library
libelf++0_0.3-1_amd64.deb C++11 ELF parser
libelf-dev_0.170-0.5_amd64.deb libelf1 development libraries and header files
libelf-freebsd-1_10.3~svn296373-10_amd64.deb library to read and write ELF files
libelf-freebsd-dev_10.3~svn296373-10_amd64.deb Development files for libelf (FreeBSD version)
libelf1_0.170-0.5_amd64.deb library to read and write ELF files
Advertisement
Advertisement