libctl7_4.1.4-3+b1_amd64.deb


Advertisement

Description

libctl7 - library for flexible control files

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename libctl7_4.1.4-3+b1_amd64.deb
Package name libctl7
Package version 4.1.4
Package release 3+b1
Package architecture amd64
Package type deb
Category libs role::shared-lib
Homepage http://ab-initio.mit.edu/wiki/index.php/Libctl
License -
Maintainer Thorsten Alteholz <debian@alteholz.de>
Download size 98.82 KB
Installed size 438.00 KB

Alternatives

Package Version Architecture Repository
libctl7_4.1.4-3_i386.deb 4.1.4 i386 Debian Main
libctl7 - - -

Requires

Name Value
guile-2.2-libs -
libc6 >= 2.14

Conflicts

Name Value
libctl3 -
libctl5 -
libctl6 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libctl7_4.1.4-3+b1_amd64.deb
Source Package libctl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libctl7 deb package:
    # sudo apt-get install libctl7

Files

Path
/usr/lib/x86_64-linux-gnu/libctl.so.7
/usr/lib/x86_64-linux-gnu/libctl.so.7.0.2
/usr/lib/x86_64-linux-gnu/libctlgeom.so.7
/usr/lib/x86_64-linux-gnu/libctlgeom.so.7.0.2
/usr/share/doc/libctl7/changelog.Debian.amd64.gz
/usr/share/doc/libctl7/changelog.Debian.gz
/usr/share/doc/libctl7/copyright
/usr/share/libctl/base/class.scm
/usr/share/libctl/base/ctl.scm
/usr/share/libctl/base/extern-funcs.scm
/usr/share/libctl/base/help.scm
/usr/share/libctl/base/include.scm
/usr/share/libctl/base/interaction.scm
/usr/share/libctl/base/io-vars.scm
/usr/share/libctl/base/main.c
/usr/share/libctl/base/math-utils.scm
/usr/share/libctl/base/matrix3x3.scm
/usr/share/libctl/base/simplex.scm
/usr/share/libctl/base/utils.scm
/usr/share/libctl/base/vector3.scm
/usr/share/libctl/utils/ctl-io.scm
/usr/share/libctl/utils/geom.c
/usr/share/libctl/utils/geom.scm
/usr/share/libctl/utils/nlopt-constants.scm
/usr/share/libctl/utils/nlopt.c

Changelog

2018-12-23 - Thorsten Alteholz <debian@alteholz.de>
libctl (4.1.4-3) unstable; urgency=medium
* upload to unstable
2018-11-20 - Thorsten Alteholz <debian@alteholz.de>
libctl (4.1.4-2) experimental; urgency=medium
* debian/control: libctl-dev needs to depend on guile 2.2
2018-11-17 - Thorsten Alteholz <debian@alteholz.de>
libctl (4.1.4-1) experimental; urgency=medium
* New upstream release
* debian/control: depend on guile 2.2 (Closes: #885202)
* debian/libctl7.symbols: update symbols file
* debian/missing-sources: no longer needed
* lintian-overrides related to docs no longer needed
* debian/copyright: Expat and BSD license no longer needed
* debian/control: bump standard to 4.2.1 (no change)
2018-08-13 - Thorsten Alteholz <debian@alteholz.de>
libctl (4.1.2-1) experimental; urgency=medium
* New upstream release
* debian/control: always depend on guile 2.0 (Closes: #902977)
* introduce libctlgeom (Closes: #906028, #906029)
(thanks to Ruben Undheim for the patch)
* debian/libctl7.symbols: some symbols disappeared and no soname bump
by upstream :-(
2018-06-18 - Thorsten Alteholz <debian@alteholz.de>
libctl (4.1.0-1) experimental; urgency=medium
* New upstream release
* debian/control: bump standard to 4.1.4 (no change)
* debian/control: bump soname of libctl from 6 to 7
* debian/rules: remove get-orig-source target
2018-03-17 - Thorsten Alteholz <debian@alteholz.de>
libctl (4.0.0-2) experimental; urgency=medium
* debian/control: add missing Conflicts: (Closes: #891011)
(needed for all older version, here libctl5)
* debian/control: add VCS URLs
* debian/rules: split override_dh_installdocs (Closes: #890854)
into override_dh_installdocs-arch
and override_dh_installdocs-indep
2018-02-06 - Thorsten Alteholz <debian@alteholz.de>
libctl (4.0.0-1) experimental; urgency=medium
* New upstream release
* upload to experimental
* debian/control: bump standard to 4.1.3 (no change)
* debian/control: use dh11
* debian/control: remove dependencies: autotools-dev, dh-autoreconf
* debian/control: increase soname
2016-11-03 - Thorsten Alteholz <debian@alteholz.de>
libctl (3.2.2-4) unstable; urgency=medium
* debian/rules: revert -fPIC patch (Closes: #842108)
2016-10-22 - Thorsten Alteholz <debian@alteholz.de>
libctl (3.2.2-3) unstable; urgency=medium
* debian/copyright: reorder to calm lintian
* debian/control: add ${misc:Pre-Depends} instead of multiarch-suppport
* debian/control: bump standard to 3.9.8 (no change)
* debian/rules: build everything with -fPIC (Closes: #837568)
* remove false positive overrides libctl-doc.lintian-overrides
2014-05-02 - Thorsten Alteholz <debian@alteholz.de>
libctl (3.2.2-2) unstable; urgency=medium
* debian/control: libctl-dev needs to debpend on guile 2.0 as well

See Also

Package Description
libctpl-dev_0.3.4+dfsg-1+b1_amd64.deb template engine written in C, development files
libctpl-doc_0.3.4+dfsg-1_all.deb template engine written in C, documentation files
libctpl2_0.3.4+dfsg-1+b1_amd64.deb template engine written in C
libctpp2-2v5_2.8.3-26_amd64.deb HTML template engine for C++
libctpp2-dev_2.8.3-26_amd64.deb HTML template engine for C++ (development)
libctypes-ocaml-dev_0.15.1-1_amd64.deb library for binding to C libraries using pure OCaml (dev)
libctypes-ocaml_0.15.1-1_amd64.deb library for binding to C libraries using pure OCaml (runtime)
libcubature-dev_1.0.3+ds-1_amd64.deb Multi-dimensional adaptive integration (cubature) in C
libcubature0_1.0.3+ds-1_amd64.deb Multi-dimensional adaptive integration (cubature) in C (shared lib)
libcudf-dev_0.7-5+b1_amd64.deb C library to access descriptions of package upgrade problems
libcudf-ocaml-dev_0.7-5+b1_amd64.deb OCaml library to access descriptions of package upgrade problems
libcue-dev_2.2.1-2_amd64.deb CUE Sheet Parser Library - development files
libcue2_2.2.1-2_amd64.deb CUE Sheet Parser Library
libcunit1-dev_2.1-3-dfsg-2+b12_amd64.deb Unit Testing Library for C -- development files
libcunit1-doc_2.1-3-dfsg-2_all.deb Unit Testing Library for C -- documentation
Advertisement
Advertisement