libconfig-any-perl_0.32-1_all.deb


Advertisement

Description

libconfig-any-perl - module to load configuration from different file formats

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name libconfig-any-perl
Package version 0.32
Package release 1
Package architecture all
Package type deb
Installed size 69 B
Download size 31.45 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
libconfig-any-perl_0.32-1_all.deb 0.32 all Debian Main
libconfig-any-perl - - -

Requires

Name Value
libmodule-pluggable-perl -
perl << 5.17.0
perl -

Download

Type URL
Binary Package libconfig-any-perl_0.32-1_all.deb
Source Package libconfig-any-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libconfig-any-perl deb package:
    # sudo apt-get install libconfig-any-perl

Files

Path
/usr/share/doc/libconfig-any-perl/changelog.Debian.gz
/usr/share/doc/libconfig-any-perl/changelog.gz
/usr/share/doc/libconfig-any-perl/copyright
/usr/share/man/man3/Config::Any.3pm.gz
/usr/share/man/man3/Config::Any::Base.3pm.gz
/usr/share/man/man3/Config::Any::General.3pm.gz
/usr/share/man/man3/Config::Any::INI.3pm.gz
/usr/share/man/man3/Config::Any::JSON.3pm.gz
/usr/share/man/man3/Config::Any::Perl.3pm.gz
/usr/share/man/man3/Config::Any::XML.3pm.gz
/usr/share/man/man3/Config::Any::YAML.3pm.gz
/usr/share/perl5/Config/Any.pm
/usr/share/perl5/Config/Any/Base.pm
/usr/share/perl5/Config/Any/General.pm
/usr/share/perl5/Config/Any/INI.pm
/usr/share/perl5/Config/Any/JSON.pm
/usr/share/perl5/Config/Any/Perl.pm
/usr/share/perl5/Config/Any/XML.pm
/usr/share/perl5/Config/Any/YAML.pm

Changelog

2017-06-18 - gregor herrmann <gregoa@debian.org>
libconfig-any-perl (0.32-1) unstable; urgency=medium
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
* Remove Jonathan Yu from Uploaders. Thanks for your work!
* Remove Rene Mayorga from Uploaders. Thanks for your work!
* Import upstream version 0.32.
Fixes "Removal of . from @INC causes problems for Config::Any::Perl"
(Closes: #839535)
* Update years of packaging copyright.
* Remove stanza about removed files from debian/copyright.
* debian/copyright: use HTTPS for sapo.pt URL.
* Update (build) dependencies.
* Declare compliance with Debian Policy 3.9.8.
2016-04-01 - Salvatore Bonaccorso <carnil@debian.org>
libconfig-any-perl (0.27-1) unstable; urgency=medium
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
* Import upstream version 0.27
* Bump Debhelper compat level to 9
* Update copyright years for upstream files
* Update copyright years for debian/* packaging files
* Declare compliance with Debian policy 3.9.7
* Make versioned perl (build-)dependency for JSON unversioned.
The version required for perl as alternative for libjson-pp-perl and
libjson-perl is already satified back to wheezy. Thus drop the versioned
Build-Depends-Indep and Recommends in favour of the unversioned one.
2015-05-30 - Salvatore Bonaccorso <carnil@debian.org>
libconfig-any-perl (0.26-1) unstable; urgency=medium
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
* Add debian/upstream/metadata
* Import upstream version 0.26
* Update copyright years for upstream files
* Update copyright years for debian/* packaging files
* Wrap and sort fields in debian/control file
* Declare package as autopkgtest'able
* Declare compliance with Debian policy 3.9.6
2013-09-16 - Salvatore Bonaccorso <carnil@debian.org>
libconfig-any-perl (0.24-1) unstable; urgency=low
* Imported Upstream version 0.24
* Update copyright years for included Module::Install copy
* Update copyright years for upstream files
* Add alternative for JSON:PP (in perl core since 5.13.9)
Add alternative Build-Depends-Depends and Recommends for JSON::PP.
Alternative perl (>= 5.13.9) | libjson-pp-perl to libjson-perl.
2013-08-12 - Salvatore Bonaccorso <carnil@debian.org>
libconfig-any-perl (0.23-2) unstable; urgency=low
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
* Adjust (build-)dependency for Module::Pluggable.
Module::Pluggable will be removed from Perl core in 5.20 and emits now
a warning with 5.18. Add Build-Depends-Indep and Depends on alternate
libmodule-pluggable-perl | perl (<< 5.17.0).
Thanks to Dominic Hargreaves <dom@earth.li> (Closes: #711653)
* Bump Standards-Version to 3.9.4
* Bump Debhelper compat level to 8.
Adjust versioned Build-Depends for debhelper to (>= 8).
* Update copyright years for debian/* packaging
2012-05-27 - Salvatore Bonaccorso <carnil@debian.org>
libconfig-any-perl (0.23-1) unstable; urgency=low
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* New upstream release
* Update debian/copyright file.
Update format to copyright-format 1.0 as released together with Debian
policy 3.9.3.
Update copyright years for debian/* packaging.
* Simplify dependency for libyaml-syck-perl.
Change versioned (Build-)Depends(-Indep) for libyaml-syck-perl in
alternatives to unversioned dependency. The required version is already
satisfied in squeeze.
* Bump Standards-Version to 3.9.3
2011-07-04 - Salvatore Bonaccorso <carnil@debian.org>
libconfig-any-perl (0.22-1) unstable; urgency=low
* New upstream release

See Also

Package Description
libconfig-apacheformat-perl_1.2-5_all.deb Perl module to parse Apache format config files
libconfig-augeas-perl_1.000-2+b5_amd64.deb module for manipulating configuration files through Augeas
libconfig-auto-perl_0.44-1_all.deb magical config file parser
libconfig-autoconf-perl_0.317-1_all.deb Perl module to implement some of AutoConf's macros in pure Perl
libconfig-crontab-perl_1.45-1_all.deb module to read/write Vixie-compatible crontab(5) files
libconfig-dev_1.5-0.4_amd64.deb parsing/manipulation of structured config files (development)
libconfig-doc_1.5-0.4_all.deb parsing/manipulation of structured config files (Documentation)
libconfig-file-ocaml-dev_1.2-1+b2_amd64.deb OCaml library for managing configuration files (dev files)
libconfig-file-perl_1.50-3_all.deb Parses simple configuration files
libconfig-find-perl_0.31-1_all.deb module to search configuration files using OS dependent heuristics
libconfig-general-perl_2.63-1_all.deb generic configuration module
libconfig-gitlike-perl_1.17-1_all.deb Perl module for Git-compatible config file parsing
libconfig-grammar-perl_1.12-2_all.deb grammar-based user-friendly config parser
libconfig-identity-perl_0.0019-1_all.deb module to load (and optionally decrypt) user/pass identity information
libconfig-ini-perl_0.025-1_all.deb Perl module for reading and writing .ini files
Advertisement
Advertisement