libcgi-java_0.8.1-1+b1_amd64.deb


Advertisement

Description

libcgi-java - CGI library for Java

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename libcgi-java_0.8.1-1+b1_amd64.deb
Package name libcgi-java
Package version 0.8.1
Package release 1+b1
Package architecture amd64
Package type deb
Category admin::virtualization devel::doc devel::lang:java devel::lang:python devel::library implemented-in::java implemented-in::python java role::devel-lib role::documentation role::shared-lib suite::openstack system::cloud system::virtual
Homepage http://www.matthew.ath.cx/projects/java/
License -
Maintainer Debian IoT Maintainers <debian-iot-maintainers@lists.alioth.debian.org>
Download size 23.30 KB
Installed size 51.00 KB

Alternatives

Package Version Architecture Repository
libcgi-java_0.8.1-1_i386.deb 0.8.1 i386 Debian Main
libcgi-java - - -

Requires

Name Value
libc6 >= 2.2.5

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libcgi-java_0.8.1-1+b1_amd64.deb
Source Package libmatthew-java

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libcgi-java deb package:
    # sudo apt-get install libcgi-java

Files

Path
/usr/lib/jni/libcgi-java.so
/usr/share/doc/libcgi-java/changelog.Debian.amd64.gz
/usr/share/doc/libcgi-java/changelog.Debian.gz
/usr/share/doc/libcgi-java/changelog.gz
/usr/share/doc/libcgi-java/copyright
/usr/share/java/cgi-0.6.jar
/usr/share/java/cgi.jar

Changelog

2018-05-07 - Thorsten Alteholz <debian@alteholz.de>
libmatthew-java (0.8.1-1) unstable; urgency=medium
* new upstream version (Closes: #897541)
* debian/control: add Salsa VCS URLs
* debian/control: bump standard to 4.1.4 (no changes)
2017-12-29 - Thorsten Alteholz <debian@alteholz.de>
libmatthew-java (0.8-2) unstable; urgency=medium
* debian/rules: Override JVERCFLAGS and use a supported source version. This
will fix the FTBFS with Java 9. (Closes: #873989)
Thanks to Markus Koschany for the patch!
* debian/control: bump standard to 4.1.3 (no changes)
* debian/control: use dh11
2016-11-01 - Thorsten Alteholz <debian@alteholz.de>
libmatthew-java (0.8-1) unstable; urgency=medium
* new upstream version
* fix broken debian/watch file
2016-10-15 - Thorsten Alteholz <debian@alteholz.de>
libmatthew-java (0.7.3-3) unstable; urgency=medium
* new maintainer (Closes: #762540)
* debian/control: bump standard to 3.9.8 (no changes)
2016-08-04 - Santiago Vila <sanvila@debian.org>
libmatthew-java (0.7.3-2) unstable; urgency=medium
* QA upload.
* Package is orphaned (Bug #762540), set Maintainer to "Debian QA Group".
* Switch to "3.0 (quilt)" source format.
* Apply patch from Michael Haggerty to use relative paths
in manifest file. Closes: #619890.
* Raise debhelper compat level to 9.
* Simplify debian/rules and put default-jdk-doc in Build-Depends.
* Remove cx/ath/matthew/debug/Debug.java in clean target, since it's
recreated during the build.
2010-08-05 - Matthew Johnson <mjj29@debian.org>
libmatthew-java (0.7.3-1) unstable; urgency=low
* New upstream release, fixes a memory leak (Closes: #590331)
2010-04-17 - Matthew Johnson <mjj29@debian.org>
libmatthew-java (0.7.2-3) unstable; urgency=low
* Use default-jdk-doc instead of classpath-doc (Closes: #567283)
* Fix some lintian warnings
* Don't build doc when only building arch: any packages (Closes: #561414)
2009-12-12 - Matthew Johnson <mjj29@debian.org>
libmatthew-java (0.7.2-2) unstable; urgency=low
* Convert to dh 7
* don't use default-jdk-builddep but default-jdk
2009-04-05 - Matthew Johnson <mjj29@debian.org>
libmatthew-java (0.7.2-1) unstable; urgency=low
* New Upstream Release
* Bump Standards-Version
* Bump debhelper compat
* Change to section java
2008-04-26 - Matthew Johnson <mjj29@debian.org>
libmatthew-java (0.7.1-1) unstable; urgency=low
* New Upstream Release (Closes: #476019)
* Change to use default-jdk-builddep (Closes: #477878)

See Also

Package Description
libcgi-pm-perl_4.44-1_all.deb module for Common Gateway Interface applications
libcgi-psgi-perl_0.15-2_all.deb Adapt CGI.pm to the PSGI protocol
libcgi-session-driver-chi-perl_1.0.3-2_all.deb driver for CGI::Session to use CHI as a session store
libcgi-session-driver-memcached-perl_0.04-2_all.deb Perl module to allow CGI sessions to be stored in memcache
libcgi-session-expiresessions-perl_1.13-2_all.deb automatic deletion of expired CGI sessions
libcgi-session-perl_4.48-3_all.deb persistent session data in CGI applications
libcgi-session-serialize-yaml-perl_4.26-2_all.deb YAML and YAML::Syck support for CGI::Session's serializers
libcgi-simple-perl_1.115-2_all.deb simple CGI.pm compatible OO CGI interface
libcgi-ssi-parser-perl_0.01-1.2_all.deb used in CGI scripts for parsing SSI directives
libcgi-ssi-perl_0.92-5_all.deb Perl module to use SSI from CGI scripts
libcgi-struct-xs-perl_1.04-2+b5_amd64.deb Perl module to build structures from CGI data, XS version
libcgi-test-perl_1.111-1_all.deb CGI regression test framework
libcgi-untaint-date-perl_1.00-3_all.deb CGI::Untaint input handler for date validation
libcgi-untaint-email-perl_0.03-3_all.deb input handler for CGI::Untaint to validate an email address
libcgi-untaint-perl_1.26-7_all.deb module to process CGI input parameters
Advertisement
Advertisement