libcanlock2_2b-8_amd64.deb


Advertisement

Description

libcanlock2 - library for creating and verifying Usenet cancel locks

Distribution: Debian Sid
Repository: Debian Main amd64
Package name: libcanlock2
Package version: 2b
Package release: 8
Package architecture: amd64
Package type: deb
Installed size: 36 B
Download size: 11.87 KB
Official Mirror: ftp.br.debian.org
Description: unavailable.

Alternatives

Requires

    Download

    Source package: canlock

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libcanlock2 deb package:
      # sudo apt-get install libcanlock2

    Changelog

    2016-11-29 - Florian Schlichting <fsfs@debian.org> canlock (2b-8) unstable; urgency=medium * Export hardening flags also for tests, making blhc happy * Export _all_ hardening flags * Use https for Vcs-Git * Declare compliance with Debian Policy 3.9.8 * Rebuild automatically converts postinst/postrm to trigger for ldconfig

    2015-06-28 - Florian Schlichting <fsfs@debian.org> canlock (2b-7) unstable; urgency=medium * Adopt canlock (closes: #771878) * Bump dh compat to level 9 * Add misc:Depends for libcanlock2-dev to please lintian * Add a somewhat useful Homepage field to debian/control * Switch to minimal debian/rules * Switch to source format 3.0 (quilt), unapply Debian changes to orig tar and turn them into quilt patches instead * Add install-D.patch: have install create needed directories * Convert debian/copyright to copyright-format 1.0 * Add a symbols control file * Drop obsolete libcanlock2-dev.dirs * Add hardening.patch to enable use of dpkg-buildflags * Declare compliance with Debian Policy 3.9.6 * Add Vsc-* fields to debian/control

    2009-05-13 - Laurent Fousse <laurent@komite.net> canlock (2b-6) unstable; urgency=low * Remove bashism in debian/rules (closes: #526455). Thanks Michael Bienia.

    2009-03-29 - Laurent Fousse <laurent@komite.net> canlock (2b-5) unstable; urgency=low * Fix several memleaks (closes: #520444) Thanks to Urs Janßen for reporting and providing an initial patch. * Update packaging to debhelper compat 7. * Update Standard-Version (no change needed).

    2006-03-06 - Laurent Fousse <laurent@komite.net> canlock (2b-4) unstable; urgency=low * Fix insecure buffer usage, could cause stack corruption. Thanks Andrey Melnikov for the patch (closes: #355596). * Code cleanup: included string.h in sha1.c, no more warning.

    2004-02-20 - Laurent Fousse <laurent@komite.net> canlock (2b-3) unstable; urgency=low * Added missing CFLAGS.

    2004-02-19 - Laurent Fousse <laurent@komite.net> canlock (2b-2) unstable; urgency=low * Failed test target now causes the entire build to fail. * No longer need libtool. * Fixed buffer size bug in hmac_sha1.c.

    2004-01-29 - Laurent Fousse <laurent@komite.net> canlock (2b-1) unstable; urgency=low * Initial Release (closes: #207389, #204933).

    Advertisement
    Advertisement