libc3p0-java_0.9.1.2-9_all.deb


Advertisement

Description

libc3p0-java - library for JDBC connection pooling

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name libc3p0-java
Package version 0.9.1.2
Package release 9
Package architecture all
Package type deb
Installed size 685 B
Download size 576.68 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
libc3p0-java_0.9.1.2-9_all.deb 0.9.1.2 all Debian Main
libc3p0-java - - -

Download

Type URL
Binary Package libc3p0-java_0.9.1.2-9_all.deb
Source Package c3p0

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libc3p0-java deb package:
    # sudo apt-get install libc3p0-java

Files

Path
/usr/share/doc/libc3p0-java/changelog.Debian.gz
/usr/share/doc/libc3p0-java/changelog.gz
/usr/share/doc/libc3p0-java/copyright
/usr/share/java/c3p0-0.9.1.2.jar
/usr/share/java/c3p0.jar
/usr/share/maven-repo/c3p0/c3p0/0.9.1.2/c3p0-0.9.1.2.jar
/usr/share/maven-repo/c3p0/c3p0/0.9.1.2/c3p0-0.9.1.2.pom
/usr/share/maven-repo/c3p0/c3p0/debian/c3p0-debian.jar
/usr/share/maven-repo/c3p0/c3p0/debian/c3p0-debian.pom

Changelog

2014-01-16 - Markus Koschany <apo@gambaru.de>
c3p0 (0.9.1.2-9) unstable; urgency=medium
* Team upload.
* debian/ant.properties: Disable optional Junit tests. (Closes: #725456)
* Update watch file to detect the latest upstream release.
Thanks to Bart Martens.
* Declare compliance with Debian Policy 3.9.5.
* Bump compat level to 9 and require debhelper >= 9.
2013-07-28 - Emmanuel Bourg <ebourg@apache.org>
c3p0 (0.9.1.2-8) unstable; urgency=low
* debian/control:
- Removed the unnecessary dependency on libmx4j-java
- Only suggest liblog4j1.2-java since the dependency is optional
- Updated Standards-Version to 3.9.4 (no changes)
- Use canonical URLs for the Vcs-* fields
* debian/rules:
- Improved the clean target
- Install the upstream changelog
* Updated the watch file to catch only the final releases
* debian/copyright: Converted to the Copyright Format 1.0
2012-07-09 - Damien Raude-Morvan <drazzib@debian.org>
c3p0 (0.9.1.2-7) unstable; urgency=low
* Team upload.
* Build-Depends on default-jdk (openjdk) instead of gcj-jdk.
- Fix FTBFS with new JDBC 4 and 4.1 API (d/patches/java-7-compat.patch).
- Test suite pass with openjdk (Closes: #669556).
2012-04-21 - tony mancill <tmancill@debian.org>
c3p0 (0.9.1.2-6) unstable; urgency=low
* Team upload.
* Remove Michael Koch from Uploaders.  (Closes: #653999)
* Apply patch to enable test suite and tune gcj javac output.
- Thank you to James Page.  (Closes: #615863)
* Bump Standards-Version to 3.9.3 (no changes).
* Drop needless dependency on JRE.
2010-05-21 - Torsten Werner <twerner@debian.org>
c3p0 (0.9.1.2-5) unstable; urgency=low
* Install POM file.
2010-05-03 - Torsten Werner <twerner@debian.org>
c3p0 (0.9.1.2-4) unstable; urgency=low
* Team upload
[ Thierry Carrez ]
* Depend on java2-runtime-headless instead of java2-runtime
[ Torsten Werner ]
* Remove Arnaud from uploaders list.
* Update Standards-Version: 3.8.4.
2009-09-06 - Michael Koch <konqueror@gmx.de>
c3p0 (0.9.1.2-3) unstable; urgency=low
* Build-Depend on gcj-jdk (Closes: #539177).
(Taken from Ubuntu)
* Let libc3p0-java depend on default-jre-headless instead of default-jre.
(Taken from Ubuntu)
* Updated Standards-Version to 3.8.3.
2009-05-07 - Varun Hiremath <varun@debian.org>
c3p0 (0.9.1.2-2) unstable; urgency=low
[ Michael Koch ]
* Use uscan sf.net helper for SourceForge. Fixes upstream checking.
* Updated Standards-Version to 3.7.3.
* Added Homepage field.
[ Varun Hiremath ]
* Convert to default-jdk/jre (Closes: #526273)
* Bump Standards-Version to 3.8.1
* Fix Vcs-* fileds
2007-09-16 - Varun Hiremath <varunhiremath@gmail.com>
c3p0 (0.9.1.2-1) unstable; urgency=low
* New upstream release
* Add debian/orig-tar.sh
* debian/rules: implement get-orig-source
* move debian/README.Debian to debian/REAMDE.Debian-source and update the file.
* debian/control:
+ Add Homepage and Build-Depend on debhelper (>= 5)
+ Add XS-Vcs-{Svn, Browser} headers.
+ Add myself to Uploaders.
* debian/compat: Bump compat to 5
* Remove debian/libc3p0-java.* files and install and link jars in
debian/rules using DEB_UPSTREAM VERSION.
* Fix the package version, dfsg not required as the changes have been
documented in debian/README.Debian-source.
* Add debian/orig-tar.exclude and remove pre-built docs from orig.tar.gz
2007-07-10 - Michael Koch <konqueror@gmx.de>
c3p0 (0.9.1.1.dfsg.1-2) unstable; urgency=low
* Upload to unstable.
* Clean out correctly.
* Moved debhelper and cdbs from Build-Depends-Indep to Build-Depends.
* Fixed address of FSF in debian/copyright.
* Added myself to Uploaders.

See Also

Package Description
libc6-amd64-cross_2.27-6cross1_all.deb GNU C Library: Shared libraries (for cross-compiling)
libc6-amd64-i386-cross_2.27-6cross1_all.deb GNU C Library: 64bit Shared libraries for AMD64 (for cross-compiling)
libc6-amd64-x32-cross_2.27-6cross1_all.deb GNU C Library: 64bit Shared libraries for AMD64 (for cross-compiling)
libc6-arm64-cross_2.27-6cross1_all.deb GNU C Library: Shared libraries (for cross-compiling)
libc6-armel-cross_2.27-6cross1_all.deb GNU C Library: Shared libraries (for cross-compiling)
libc6-armhf-cross_2.27-6cross1_all.deb GNU C Library: Shared libraries (for cross-compiling)
libc6-dev-amd64-cross_2.27-6cross1_all.deb GNU C Library: Development Libraries and Header Files (for cross-compiling)
libc6-dev-amd64-i386-cross_2.27-6cross1_all.deb GNU C Library: 64bit Development Libraries for AMD64 (for cross-compiling)
libc6-dev-amd64-x32-cross_2.27-6cross1_all.deb GNU C Library: 64bit Development Libraries for AMD64 (for cross-compiling)
libc6-dev-arm64-cross_2.27-6cross1_all.deb GNU C Library: Development Libraries and Header Files (for cross-compiling)
libc6-dev-armel-cross_2.27-6cross1_all.deb GNU C Library: Development Libraries and Header Files (for cross-compiling)
libc6-dev-armhf-cross_2.27-6cross1_all.deb GNU C Library: Development Libraries and Header Files (for cross-compiling)
libc6-dev-hppa-cross_2.27-6cross1_all.deb GNU C Library: Development Libraries and Header Files (for cross-compiling)
libc6-dev-i386-amd64-cross_2.27-6cross1_all.deb GNU C Library: 32-bit development libraries for AMD64 (for cross-compiling)
libc6-dev-i386-cross_2.27-6cross1_all.deb GNU C Library: Development Libraries and Header Files (for cross-compiling)
Advertisement
Advertisement