hyperrogue_10.0g-1_amd64.deb


Advertisement

Description

hyperrogue - non-euclidean graphical rogue-like game

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name hyperrogue
Package version 10.0g
Package release 1
Package architecture amd64
Package type deb
Installed size 3.56 KB
Download size 1.16 MB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
hyperrogue_10.0g-1_i386.deb 10.0g i386 Debian Main
hyperrogue - - -

Requires

Name Value
fonts-dejavu-core -
libc6 >= 2.14
libgcc1 >= 1:4.0
libgl1 -
libpng16-16 >= 1.6.2-1
libsdl-gfx1.2-5 >= 2.0.25
libsdl-mixer1.2 -
libsdl-ttf2.0-0 -
libsdl1.2debian >= 1.2.11
libstdc++6 >= 5.2

Download

Type URL
Binary Package hyperrogue_10.0g-1_amd64.deb
Source Package hyperrogue

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install hyperrogue deb package:
    # sudo apt-get install hyperrogue

Files

Path
/usr/games/hyper
/usr/share/applications/hyperrogue.desktop
/usr/share/doc/hyperrogue/changelog.Debian.gz
/usr/share/doc/hyperrogue/copyright
/usr/share/man/man6/hyper.6.gz
/usr/share/pixmaps/hyperrogue.png

Changelog

2017-09-14 - Markus Koschany <apo@debian.org>
hyperrogue (10.0g-1) unstable; urgency=medium
* Team upload.
* New upstream version 10.0g.
* Drop the +dfsg suffix because the source code is DFSG-free and we just
create our own tarball with music files included.
* Declare compliance with Debian Policy 4.1.0.
* Refresh system-dejavu.patch.
2017-07-17 - Markus Koschany <apo@debian.org>
hyperrogue (9.4n+dfsg-1) unstable; urgency=medium
* Team upload.
* New upstream version 9.4n.
* Switch to compat level 10.
* Declare compliance with Debian Policy 4.0.0.
* Use https for Format field.
* Build with all hardening flags including pie again. (Closes: #865604)
* Install new sound and music files into hyperrogue-music package.
* Explain how to obtain the sources. Remove repack.local.
* Update debian/copyright for new release.
* Fix debian/watch file.
2016-10-03 - Markus Koschany <apo@debian.org>
hyperrogue (8.3j+dfsg-3) unstable; urgency=medium
* Team upload.
* Fix FTBFS on hppa by adding -mlong-calls to DEB_CXXFLAGS_MAINT_APPEND.
Thanks to David Anglin for the report. (Closes: #839602)
2016-09-10 - Markus Koschany <apo@debian.org>
hyperrogue (8.3j+dfsg-2) unstable; urgency=medium
* Team upload.
* Implement several measures to avoid memory exhaustion and compilation
errors on weaker buildds:
- Don't build with parallel to reduce the amount of required memory.
- Add optimization.patch and use Debian's default value for compiler
optimization.
- Build with O0 optimization on arm64 and hppa to prevent compilation
errors and memory exhaustion.
* Update Homepage field.
2016-09-10 - Markus Koschany <apo@debian.org>
hyperrogue (8.3j+dfsg-1) unstable; urgency=medium
* Team upload.
* New upstream version 8.3j+dfsg. (Closes: #797024)
* New upstream release fixes FTBFS with GCC-6. (Closes: #811991)
* Drop hyperrogue-dbg package and use the automatic -dbgsym package instead.
* Declare compliance with Debian Policy 3.9.8.
* Vcs-fields: Use cgit and https.
* hyperrogue-music: Suggest hyperrogue.
* hyperrogue.desktop: Add a comment in German.
* Drop hyperrogue.menu, remove hyperrogue.xmp icon and do not convert
the png icon to xpm anymore. (Closes: #797974)
* d/rules: Change source directory to src.
* Add system-dejavu.patch and replace 10-fontconfig.patch.
* Drop 01-sdl_wm.patch. Fixed upstream.
* d/control: Only depend on fonts-dejavu-core for hyperrouge.
* d/control: Build-depend on libpng-dev.
* Update copyright for new release and add missing licenses.
* Update debian/clean and ensure that the package can be built twice in a
row.
* Fix debian/watch file.
2013-12-23 - Damyan Ivanov <dmn@debian.org>
hyperrogue (4.2+dfsg-1) unstable; urgency=medium
* Imported Upstream version 4.2+dfsg
+ adapt patches to apply cleanly with the new upstream release
+ add libgl1-mesa-dev to build-dependencies due to added -lGL
* Declare conformance with Policy 3.9.5
2013-11-27 - Damyan Ivanov <dmn@debian.org>
hyperrogue (4.0t+dfsg-1) unstable; urgency=low
[ Christian M. Amsüss ]
* Initial release. (Closes: #716924)

See Also

Package Description
hyperv-daemons_4.17.6-2_amd64.deb Support daemons for Linux running on Hyper-V
hyphen-af_6.0.5-1_all.deb Afrikaans hyphenation patterns
hyphen-as_0.9.0-1_all.deb Assamese hyphenation patterns for LibreOffice
hyphen-bg_6.0.5-1_all.deb Bulgarian hyphenation patterns
hyphen-bn_0.9.0-1_all.deb Bengali hyphenation patterns for LibreOffice
hyphen-ca_6.0.5-1_all.deb Catalan hyphenation patterns
hyphen-cs_6.0.5-1_all.deb Czech hyphenation patterns
hyphen-da_6.0.5-1_all.deb Danish hyphenation patterns
hyphen-de_6.0.5-1_all.deb German hyphenation patterns
hyphen-el_6.0.5-1_all.deb Modern Greek hyphenation patterns
hyphen-en-gb_6.0.5-1_all.deb English (GB) hyphenation patterns
hyphen-en-us_2.8.8-5_all.deb English (US) hyphenation patterns
hyphen-es_6.0.5-1_all.deb Spanish hyphenation patterns
hyphen-fr_6.0.5-1_all.deb French hyphenation patterns
hyphen-gl_6.0.5-1_all.deb Galician hyphenation patterns
Advertisement
Advertisement