gnustep-devel_7.10_all.deb


Advertisement

Description

gnustep-devel - GNUstep Development Environment -- development tools

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename gnustep-devel_7.10_all.deb
Package name gnustep-devel
Package version 7.10
Package release -
Package architecture all
Package type deb
Category devel::buildtools devel::lang:objc gnustep implemented-in::objc interface::graphical interface::x11 role::metapackage role::program suite::gnustep uitoolkit::gnustep x11::application
Homepage http://gnustep.org
License -
Maintainer Debian GNUstep maintainers <pkg-gnustep-maintainers@lists.alioth.debian.org>
Download size 5.03 KB
Installed size 12.00 KB

Alternatives

Package Version Architecture Repository
gnustep-devel_7.10_all.deb 7.10 all Debian Main
gnustep-devel - - -

Requires

Name Value
gnustep-core-devel -
gorm.app -
projectcenter.app -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package gnustep-devel_7.10_all.deb
Source Package meta-gnustep

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gnustep-devel deb package:
    # sudo apt-get install gnustep-devel

Files

Path
/usr/share/doc/gnustep-devel/changelog.gz
/usr/share/doc/gnustep-devel/copyright

Changelog

2019-02-06 - Yavor Doganov <yavor@gnu.org>
meta-gnustep (7.10) unstable; urgency=medium
* debian/control (gnustep-games) <Recommends>: Remove oolite as it has
been removed from Debian.
(gnustep-core-devel) <Suggests>: Remove gnustep-base-examples; it has
been merged into gnustep-base-doc.
(gnustep-devel) <Suggests>: Replace libpantomime1.2-dev with
libpantomime-dev.  Add libdbuskit-dev, libgorm-dev, libsteptalk-dev,
libperformance-dev, libpreferencepanes-dev, libsqlclient-dev.
(gnustep-core-doc): Mark as Multi-Arch: foreign.
(Vcs-Git, Vcs-Browser): Update following the migration to Salsa.
(Standards-Version): Bump to 4.3.0; no changes needed.
* debian/copyright: Switch to copyright-format 1.0, update Gürkan's name
and copyright years.
2018-01-16 - Gürkan Myczko <gurkan@phys.ethz.ch>
meta-gnustep (7.9) unstable; urgency=medium
* Team Upload.
[ Gürkan Myczko ]
* debian/control: add fontmanager.app, chess.app, fortunate.app,
pikopixel.app
* Bump standards version to 4.1.3.
* Bump debhelper version to 11.
2014-07-17 - Yavor Doganov <yavor@gnu.org>
meta-gnustep (7.8) unstable; urgency=medium
* debian/compat: Set to 9.
* debian/control: Reshuffle the packages so that README gets installed
in the gnustep package.
(Build-Depends): Require debhelper >= 9.
(gnustep-games) <Depends>: Remove shisen.app (Closes:
#707240) and stepbill.app (Closes: #707242) as they're no longer in
Debian.  Promote gridlock.app from Recommends to fill the gap.
(Description): Typo fix, thanks Davide Prina (Closes: #677104).
(Section): Change back to `gnustep'; seems more appropriate.
(Recommends): Add adressmanager.app, dictionaryreader.app.  Promote
agenda.app, cynthiune.app, grr.app, affiche.app, edenmath.app.  Demote
gnustep-examples, talksoup.app.
(Suggests): Add batmon.app, ftp.app, lynkeos.app, paje.app,
timemon.app.
(Vcs-Git): Use the canonical URI.
(Standards-Version): Bump to 3.9.5 (no changes needed).
* debian/rules: Replace with a minimalistic dh-style one.
2012-06-07 - Yavor Doganov <yavor@gnu.org>
meta-gnustep (7.7) unstable; urgency=low
* debian/control (Section): Change to `metapackages'.
(Homepage): New field (Closes: #676231).
(Vcs-Arch, Vcs-Git, Vcs-Browser): Switch from Arch to Git.
(Standards-Version): Switch to 3.9.3 (no changes needed).
(Description): Omit definite article, to placate lintian.  Tweaks.
(gnustep) <Suggests>: Remove biococoa.app and easydiff.app, no longer
in Debian.  Remove helpviewer.app, add grr.app.
<Depends>: Demote charmap.app to Recommends; it's not essential.
Switch preview.app | price.app order.
(gnustep-games) <Depends>: Remove mines.app (Closes: #653140).
<Recommends>: Remove gnustep, it doesn't make sense at all.
(gnustep-devel) <Depends>: Remove projectmanager.app alternative
dependency; package gone for good.
<Suggests>: Replace librsskit0-dev with librsskit-dev.
* debian/rules (build-arch, build-indep): New targets.
* debian/source/format: Switch to 3.0 (native).
* debian/copyright: Update holders/years.
2010-09-04 - Yavor Doganov <yavor@gnu.org>
meta-gnustep (7.6) unstable; urgency=high
* debian/control (gnustep) <Depends>: Remove open.app (Closes:
#597619).
<Suggests>: Remove displaycalibrator.app and stepulator.app, not in
the archive anymore.
(Standards-Version): Set to 3.9.1 (no changes needed).

See Also

Package Description
gnustep-dl2-postgresql-adaptor_0.12.0-15.1+b3_amd64.deb gnustep-dl2 adaptor to connect to PostgreSQL
gnustep-dl2-sqlite-adaptor_0.12.0-15.1+b3_amd64.deb gnustep-dl2 adaptor to connect to SQLite
gnustep-dl2_0.12.0-15.1+b3_amd64.deb Objective-C Classes needed for Database Access
gnustep-examples_1.4.0-2+b1_amd64.deb GNUstep example applications
gnustep-games_7.10_all.deb GNUstep based games
gnustep-gui-common_0.27.0-5_all.deb GNUstep GUI Library - common files
gnustep-gui-doc_0.27.0-5_all.deb Documentation for the GNUstep GUI Library
gnustep-gui-runtime_0.27.0-5_amd64.deb GNUstep GUI Library - runtime files
gnustep-icons_1.0-6_all.deb Several free icons for use with GNUstep and others
gnustep-make-doc_2.7.0-4_all.deb Documentation for GNUstep Make
gnustep-make_2.7.0-4_all.deb GNUstep build system
gnustep_7.10_all.deb User applications for the GNUstep Environment
gnutls-bin_3.6.7-2_amd64.deb GNU TLS library - commandline utilities
gnutls-doc_3.6.7-2_all.deb GNU TLS library - documentation and examples
go-bindata_3.0.7+git20151023.72.a0ff256-3+b11_amd64.deb embed data in a Go program
Advertisement
Advertisement