erlang-yapp_2.0.6+dfsg-1+b1_amd64.deb


Advertisement

Description

erlang-yapp - Erlang application for deploying Yaws webserver applications

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename erlang-yapp_2.0.6+dfsg-1+b1_amd64.deb
Package name erlang-yapp
Package version 2.0.6+dfsg
Package release 1+b1
Package architecture amd64
Package type deb
Category httpd
Homepage http://yaws.hyber.org/
License -
Maintainer Debian Erlang Packagers <pkg-erlang-devel@lists.alioth.debian.org>
Download size 79.38 KB
Installed size 128.00 KB

Alternatives

Package Version Architecture Repository
erlang-yapp_2.0.6+dfsg-1_i386.deb 2.0.6+dfsg i386 Debian Main
erlang-yapp - - -

Requires

Name Value
erlang-base >= 1:22.0.7+dfsg
erlang-base-hipe >= 1:22.0.7+dfsg
erlang-mnesia >= 1:22.0.7+dfsg
erlang-yaws = 2.0.6+dfsg-1+b1

Replaces

Name Value
yaws-yapp << 1.99

Download

Type URL
Mirror ftp.br.debian.org
Binary Package erlang-yapp_2.0.6+dfsg-1+b1_amd64.deb
Source Package yaws

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install erlang-yapp deb package:
    # sudo apt-get install erlang-yapp

Files

Path
/usr/lib/yapp
/usr/lib/yapp-0.4.2/ebin/yapp.app
/usr/lib/yapp-0.4.2/ebin/yapp.appup
/usr/lib/yapp-0.4.2/ebin/yapp.beam
/usr/lib/yapp-0.4.2/ebin/yapp_app.beam
/usr/lib/yapp-0.4.2/ebin/yapp_ets_server.beam
/usr/lib/yapp-0.4.2/ebin/yapp_event_handler.beam
/usr/lib/yapp-0.4.2/ebin/yapp_handler.beam
/usr/lib/yapp-0.4.2/ebin/yapp_mnesia_server.beam
/usr/lib/yapp-0.4.2/ebin/yapp_registry.beam
/usr/lib/yapp-0.4.2/ebin/yapp_server.beam
/usr/lib/yapp-0.4.2/ebin/yapp_sup.beam
/usr/share/doc/erlang-yapp/README
/usr/share/doc/erlang-yapp/changelog.Debian.amd64.gz
/usr/share/doc/erlang-yapp/changelog.Debian.gz
/usr/share/doc/erlang-yapp/changelog.gz
/usr/share/doc/erlang-yapp/copyright

Changelog

2018-06-26 - Sergei Golovan <sgolovan@debian.org>
yaws (2.0.6+dfsg-1) unstable; urgency=medium
* New upstream release.
* Fix version mangling in debian/watch.
2018-04-18 - Sergei Golovan <sgolovan@debian.org>
yaws (2.0.5+dfsg-1) unstable; urgency=medium
* New upstream release.
* Remove patches that are no longer needed.
* Convert debian/copyright into machine readable form.
* Fix the debian/watch uscan file to repack upstream tarballs removing
non DFSG-free sources.
* Add a note to README.Debian on listening at privileged ports via
adding the AmbientCapabilities option to the YAWS systemd unit.
2018-03-09 - Sergei Golovan <sgolovan@debian.org>
yaws (2.0.4+dfsg-3) unstable; urgency=medium
* Implement a systemd unit file.
* Replace the old svn VCS headers by the new git ones.
* Remove the deprecated autotools-dev from build dependencies.
* Move the pkgconfig file to /usr/lib/$(DEB_HOST_MULTIARCH)
* Don't change the yaws home directory ownership recursively to prevent
possible hardlink attack.
* Don't set CFLAGS manually. Use dpkg-buildflags.
* Bump standards version to 4.1.3.
2017-07-10 - Sergei Golovan <sgolovan@debian.org>
yaws (2.0.4+dfsg-2) unstable; urgency=medium
* Added a few patches from upstream which fix FTBFS with new Erlang R20.
* Bumped debhelper compatibility level to 10.
* Bumped standards version to 4.0.0.
2016-09-22 - Sergei Golovan <sgolovan@debian.org>
yaws (2.0.4+dfsg-1) unstable; urgency=medium
* New upstream release.
* Restored treating compiler warnings as errors.
* Added erlang-dialyzer to the Yaws build dependencies.
* Fixed the SVN link in debian/control.
* Removed the patch which fixes CVE-2016-1000108 because it has been
applied upstream.
2016-08-18 - Sergei Golovan <sgolovan@debian.org>
yaws (2.0.3+dfsg-1) unstable; urgency=medium
* Removed files priv/soap.xsd, priv/wsdl.xsd, priv/wsdl11soap12.xsd
from the source and binary packages because they aren't DFSG-free (they
don't permit modification). Documented this in README.Debian.
Closes: #810889.
2016-07-26 - Sergei Golovan <sgolovan@debian.org>
yaws (2.0.3-2) unstable; urgency=medium
* Applied a patch from upstream to fix CVE-2016-1000108 (passing the
HTTP_PROXY environment variable to CGI scripts). Closes: #832433.
* Finally fixed the paths of run_erl and to_erl utilities in the
/usr/bin/yaws script.
2016-07-03 - Sergei Golovan <sgolovan@debian.org>
yaws (2.0.3-1) unstable; urgency=medium
* New upstream release.
* Dropped the patch for the documentation fix since it's applied upstream.
* Bumped standards version to 3.9.8.
2016-03-26 - Sergei Golovan <sgolovan@debian.org>
yaws (2.0.2-2) unstable; urgency=medium
* Fixed the paths of run_erl and to_erl utilities in the /usr/bin/yaws
script.
* Fixed FTBFS when dpkg-buildpackage -A is called to build architecture
independent packages only (closes: #806664).
* Moved the default Yaws default web files to /usr/share/yaws/www as
this directory is listed in the config files.
* Added --chdir option to the start-stop-daemon command execution to make
sure the Yaws working directory is its home and not the root.
* Fixed the compression_level option name in docs (closes: #815207).
* Bumped standards version to 3.9.7.
2015-11-20 - Sergei Golovan <sgolovan@debian.org>
yaws (2.0.2-1) unstable; urgency=medium
* New upstream release.

See Also

Package Description
erlang-yaws_2.0.6+dfsg-1+b1_amd64.deb Erlang application which implements HTTP webserver
erlang_22.1.1+dfsg-3_all.deb Concurrent, real-time, distributed functional language
errbot_6.0+ds-1_amd64.deb Chatbot designed to be simple to extend with plugins written in Python
escputil_5.3.3-2_amd64.deb maintenance utility for Epson Stylus printers
esekeyd_1.2.7-1+b2_amd64.deb multimedia keyboard daemon for Linux
esmtp-run_1.2-17_all.deb user configurable relay-only MTA - the regular MTA
esmtp_1.2-17_amd64.deb user configurable relay-only MTA
esnacc-doc_1.8.1-1_all.deb ASN.1 to C or C++ or IDL compiler, documentation
esnacc_1.8.1-1_amd64.deb ASN.1 to C or C++ or IDL compiler
esniper_2.35.0+git20190805.7930bb4-1_amd64.deb simple, lightweight tool for sniping ebay auctions
eso-midas-testdata_19.02pl1.1-1_all.deb Test data files for ESO-MIDAS
eso-midas_19.02pl1.1-1_amd64.deb European Southern Observatory Munich Image Data Analysis System
eso-pipelines_1.2_all.deb ESO VLT Instrument pipeline collection
esorex_3.13.2+dfsg-2_amd64.deb Execution Tool for European Southern Observatory pipelines
espctag_0.4-1+b1_amd64.deb ID666 tags editor
Advertisement
Advertisement