dpatch_2.0.38_all.deb


Advertisement

Description

dpatch - patch maintenance system for Debian source packages

Distribution: Debian Sid
Repository: Debian Main amd64
Package name: dpatch
Package version: 2.0.38
Package release:
Package architecture: all
Package type: deb
Installed size: 191 B
Download size: 87.46 KB
Official Mirror: ftp.br.debian.org
Description: unavailable.

Alternatives

    Download

    Binary package: dpatch_2.0.38_all.deb
    Source package: dpatch

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install dpatch deb package:
      # sudo apt-get install dpatch

    Changelog

    2015-11-30 - Gergely Nagy <algernon@madhouse-project.org> dpatch (2.0.38) unstable; urgency=medium * Don't just install bash completion to a new place, remove the old files too. Thanks Sven Joachim <svenjoac@gmx.de> for the report and the patch! (Closes: #806337)

    2015-08-10 - Gergely Nagy <algernon@madhouse-project.org> dpatch (2.0.37) unstable; urgency=medium * Convert the packaging to debhelper: hopefully fixes all the reproducible build issues. * Install bash completion for dpatch-edit-patch to /usr/share/bash-completion/completions, as suggested by Lintian.

    2015-07-21 - Gergely Nagy <algernon@madhouse-project.org> dpatch (2.0.36) unstable; urgency=medium [ Maria Valentina Marin ] * Fix mtimes before building binary packages to produce reproducible output. (Closes: #792954) [ Gergely Nagy ] * Add -n to all gzip invocations, to avoid timestamps in gzipped files, and to aid reproducible builds. Spotted by Lintian. * Bump Standards-Version to 3.9.6, no changes needed. * Rearrange the copyright file to make it more succint, and to please Lintian. * Update the Vcs-* URLs to point to reachable locations.

    2012-02-07 - Gergely Nagy <algernon@madhouse-project.org> dpatch (2.0.35) unstable; urgency=low * Mark the package Multi-Arch: foreign, thanks Riku Voipio <riku.voipio@linaro.org>. (Closes: #658974)

    2011-12-13 - Gergely Nagy <algernon@madhouse-project.org> dpatch (2.0.34) unstable; urgency=high * The magic that was supposed to reset the timestamps of patched files failed to take the --workdir option into account. This has now been corrected. (Closes: #651948) Urgency high because this bug breaks any build that uses --workdir, and has patchutils installed.

    2011-10-23 - Gergely Nagy <algernon@madhouse-project.org> dpatch (2.0.33) unstable; urgency=low * dpatch is now DEPRECATED, please do not use it for new packages. + NEWS and manual pages updated accordingly. * dpatch-edit-patch does not fail anymore when there is binary data in the patch. Patch from Ben Brown (Closes: #638864).

    Advertisement
    Advertisement