dh-elpa_1.11_all.deb


Advertisement

Description

dh-elpa - Debian helper tools for packaging emacs lisp extensions

Distribution: Debian Sid
Repository: Debian Main amd64
Package name: dh-elpa
Package version: 1.11
Package release:
Package architecture: all
Package type: deb
Installed size: 86 B
Download size: 27.49 KB
Official Mirror: ftp.br.debian.org
Description: unavailable.

Alternatives

    Download

    Binary package: dh-elpa_1.11_all.deb
    Source package: dh-elpa

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install dh-elpa deb package:
      # sudo apt-get install dh-elpa

    Changelog

    2017-08-04 - David Bremner <bremner@debian.org> dh-elpa (1.11) unstable; urgency=medium * disable dh-elpa-Version field

    2017-08-03 - David Bremner <bremner@debian.org> dh-elpa (1.10) unstable; urgency=medium [ Sean Whitton ] * Add dh-elpa-Version: field to binary package control files. This tracks the dh-elpa version used to build the package, to make it possible to find packages that need rebuilding against newer dh-elpa. [ David Bremner ] * Treat 'emacs' as a first class flavour, anticipating Debian emacs packages using that in place of 'emacsNN'. * Fix reporting of ignored flavors on removal (cosmetic change). * Replace '2' in generated emacsen-common compat file

    2017-08-02 - Sean Whitton <spwhitton@spwhitton.name> dh-elpa (1.9) unstable; urgency=medium * Drop alternative {build-,}depends on emacs24{-nox,}. src:emacs24 will soon be removed from the archive. * Bump debhelper compat to 10.

    2017-07-08 - Sean Whitton <spwhitton@spwhitton.name> dh-elpa (1.8) unstable; urgency=medium [ David Bremner ] * License generated maintainer scripts under CC0 (roughly, public domain). [ Sean Whitton ] * Stop generating ${misc:Built-Using} substvar. No longer required since maintscripts are now licensed CC0/public domain. While the substvar was initially added to help find packages that need to be rebuilt against a more recent version of dh-elpa (see #803350), this is not the intended use of the Built-Using field, and as such it has been inconveniencing the Release Team. * Bump standards version to 4.0.0 (no changes required).

    2017-06-18 - Sean Whitton <spwhitton@spwhitton.name> dh-elpa (1.7) unstable; urgency=medium * Properly implement ignoring files containing ERT tests in .git. dh-elpa 1.4 ignored them in only --autopkgtest mode. * Update list of addons packaged outside of the elpa-* namespace. - Remove s, dash and yasnippet. * Manpage grammar fix.

    2017-01-08 - David Bremner <bremner@debian.org> dh-elpa (1.6) unstable; urgency=medium * Add an "exit 0" to xemacs case of remove script (Closes: #850036).

    2017-01-01 - Sean Whitton <spwhitton@spwhitton.name> dh-elpa (1.5) unstable; urgency=high * Add built-in packages to ${elpa:Depends} if they are also packaged separately in Debian (e.g. let-alist and seq).

    2016-12-19 - Sean Whitton <spwhitton@spwhitton.name> dh-elpa (1.4) unstable; urgency=medium * Add note to dh_elpa_test manpage about disabling its override of dh_auto_test. * Update Emacs dependency and build-dependency: Previously: emacs24-nox | emacs24 (>=24~) | emacs24-lucid (>=24~) Now: emacs25-nox | emacs25 | emacs24-nox | emacs24 - emacsXY-lucid has "Provides: emacsXY". - Update for emacs25, but retain emacs24 for the sake of backports. - Retain emacs24-nox for the sake of the backports buildds. * dh_elpa_test ignores files containing ERT tests in .git. In particular, don't try to load files in .git/dgit/unpack/fake.

    2016-09-06 - Sean Whitton <spwhitton@spwhitton.name> dh-elpa (1.3) unstable; urgency=medium * Fix version comparison in elpa.pm. Quote "0.90" so that the trailing 0 is not lost. * Override debian-watch-file-in-native-package.

    2016-08-25 - Sean Whitton <spwhitton@spwhitton.name> dh-elpa (1.2) unstable; urgency=medium * Add generated files to debian/clean: - dh_elpa - dh_elpa.1 - dh_elpa_test.1 * Add missing dependency on debhelper. * Declare source format 3.0 (native).

    Advertisement
    Advertisement