dh-ada-library_6.12_amd64.deb


Advertisement

Description

dh-ada-library - Debian helper for Ada libraries

Distribution: Debian Sid
Repository: Debian Main amd64
Package name: dh-ada-library
Package version: 6.12
Package release:
Package architecture: amd64
Package type: deb
Installed size: 459 B
Download size: 153.34 KB
Official Mirror: ftp.br.debian.org
Description: unavailable.

Alternatives

    Download

    Source package: dh-ada-library

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install dh-ada-library deb package:
      # sudo apt-get install dh-ada-library

    Changelog

    2017-08-10 - Nicolas Boulenguez <nicolas@debian.org> dh-ada-library (6.12) unstable; urgency=medium * Upload to unstable. * Disable wrong assertion (library options defined in same project). Caused a FTBFS for libtemplates-parser/17.2-1 on hppa. * Stop warning about recent timestamps, gcc-7 handles SOURCE_DATE_EPOCH. * Standards-Version: 4.0.1 (no changes). * Drop explicit rules targets confusing dh.

    2017-07-02 - Nicolas Boulenguez <nicolas@debian.org> dh-ada-library (6.11) experimental; urgency=medium * Rebuild with gnat-7. * Install projects into libgpr upstream default /usr/share/gpr. * Recommend: gnat instead of Depend: an explicit version list. * Standards-Version: 4.0.0, debhelper 10. * Drop description-possibly-contains-homepage lintian override.

    2016-08-26 - Nicolas Boulenguez <nicolas@debian.org> dh-ada-library (6.10) experimental; urgency=medium * Let libgpr compute the path to ALI files even with non-default source file extensions (used by libgnatcoll).

    2016-08-11 - Nicolas Boulenguez <nicolas@debian.org> dh-ada-library (6.9) experimental; urgency=medium * Rebuild with libgpr instead of libgnatprj and libgnatvsn. * Stop buggy attempts to manage memory. Free environment variables before starting a new project, but reuse existing trees. * Add basic runtime regression tests. * Report surprising timestamps only for Ada, others do not affect ALIs.

    2016-04-26 - Nicolas Boulenguez <nicolas@debian.org> dh-ada-library (6.8) unstable; urgency=medium * Rebuild with gnat-6, libgnatprj6 and libgnatvsn6. * Libgnatvsn/prj will soon Build-Depend: gprbuild, we might as well use it. * Standards-Version: 3.9.8 (no changes).

    2016-04-06 - Nicolas Boulenguez <nicolas@debian.org> dh-ada-library (6.7) unstable; urgency=medium * Do not require -dbg packages, as debhelper now generates -dbgsym. * Add gnat-6 to the compiler list. * Activate all hardening build flags. * Override vcs-field-uses-insecure-uri lintian tag. * Standards-Version 3.9.7 (no changes).

    2015-12-05 - Nicolas Boulenguez <nicolas@debian.org> dh-ada-library (6.6) unstable; urgency=medium * Do not attempt to parse any project when called with -i/--indep. Should fix FTBFS #806603 for asis architecture-independant packages.

    2015-10-22 - Nicolas Boulenguez <nicolas@debian.org> dh-ada-library (6.5) unstable; urgency=medium * Depends: +gnat-5 -gnat-4.6 in list of Ada compilers. * Rely on 'dpkg-query --search gnatmake' to know current Ada package (5), instead of 'gnatmake --help' (gnat-5.2 is not a Debian package). * Build-Depends: gnat-5 but avoid relying on project support by gnatmake. Using gprbuild instead would cause a circular build-dependency. * Take ALI files from Object_Dir instead of Library_ALI_Dir.

    2015-05-05 - Nicolas Boulenguez <nicolas@debian.org> dh-ada-library (6.4) unstable; urgency=medium * Warn against non deterministic ALI for sources newer than changelog.

    2014-11-09 - Nicolas Boulenguez <nicolas@debian.org> dh-ada-library (6.3) unstable; urgency=medium * When parsing "gnatmake --version", select major.minor with a regular expression (gnat-4.9 >= 4.9.1-4 appends a revision). Closes: #768805.

    Advertisement
    Advertisement