command-not-found_0.2.38-4_all.deb


Advertisement

Description

command-not-found - Suggest installation of packages in interactive bash sessions

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name command-not-found
Package version 0.2.38
Package release 4
Package architecture all
Package type deb
Installed size 55 B
Download size 12.24 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
command-not-found_0.2.38-4_all.deb 0.2.38 all Debian Main
command-not-found - - -

Requires

Name Value
apt-file >= 3.0~exp1~
lsb-release -
python-gdbm -
python:any >= 2.7.5-5~

Download

Type URL
Binary Package command-not-found_0.2.38-4_all.deb
Source Package command-not-found

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install command-not-found deb package:
    # sudo apt-get install command-not-found

Files

Path
/etc/zsh_command_not_found
/usr/bin/command-not-found
/usr/lib/command-not-found
/usr/sbin/update-command-not-found
/usr/share/command-not-found/command-not-found
/usr/share/command-not-found/CommandNotFound/CommandNotFound.py
/usr/share/command-not-found/CommandNotFound/__init__.py
/usr/share/command-not-found/CommandNotFound/util.py
/usr/share/doc/command-not-found/README
/usr/share/doc/command-not-found/README.Debian
/usr/share/doc/command-not-found/changelog.Debian.gz
/usr/share/doc/command-not-found/copyright
/usr/share/man/man8/update-command-not-found.8.gz
/usr/share/python/runtime.d/command-not-found.rtupdate

Changelog

2016-11-15 - Julian Andres Klode <jak@debian.org>
command-not-found (0.2.38-4) unstable; urgency=medium
* Handle packages without a section in Contents (Closes: #616448)
2016-04-01 - Julian Andres Klode <jak@debian.org>
command-not-found (0.2.38-3) unstable; urgency=medium
* Upload to unstable for nthykier
2016-01-09 - Julian Andres Klode <jak@debian.org>
command-not-found (0.2.38-2) experimental; urgency=medium
* Use apt-file 3.0 (Closes: #807745)
* Recommend 'apt' instead of 'apt-get'
2015-08-25 - Stefano Rivera <stefanor@debian.org>
command-not-found (0.2.38-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Port from python-support to dh_python2 (Closes: #785969)
* Drop XB-Python-Version, unused.
2009-11-02 - Julian Andres Klode <jak@debian.org>
command-not-found (0.2.38-1) unstable; urgency=low
* Update to latest release
- Prints an error message if the command could not be found in the
database (Closes: #551377)
* Packaging changes:
- Use python-support instead of python-central.
- Switch to the new 3.0 (quilt) source format.
* Bugfixing:
- Create symlinks for command-not-found in /usr/lib (used by bash),
and in /usr/bin for manual invocation (Closes: #543747)
- Strip package names so they don't contain newlines (Closes: #521276)
- Fix typo in the description (Closes: #503629)
- Use mode 0644 for the database files (Closes: #522450), and set
the umask to 022 while running the update-command-not-found script.
- Set -e in the maintainer scripts, reported by lintian.
* Change update-command-not-found to only add the section to the database
filenames. Delete old cache files in postinst, so users only get the
new ones.
* Stop installing /etc/bash_command_not_found, since the standard one
included in bash works now.
2008-10-24 - Julian Andres Klode <jak@debian.org>
command-not-found (0.2.26-1) unstable; urgency=low
* Initial Upload to Debian (Closes: #418613)
* Fetch the data from available apt sources and drop command-not-found-data:
- update-command-not-found: Script to update the cache using apt-file files.
- patches/adjust-paths.diff: Move databases to /var/cache/command-not-found
- patches/no-enable-component.diff: Remove 'enable the component' messages
* Re-do packaging
- Do not install using setup.py, but simply copy needed files
- Make the Python modules private
- Move the command-not-found script to /usr/share/command-not-found
- Build-Depend on debhelper, quilt and python-central only
* other packaging stuff
- Upgrade Policy Version to 3.8.0
- debhelper compat level 7
- Rewrite copyright file (machine-interpretable)
* patches/bts.diff: Point to information on how to report bugs in Debian,
and not to Launchpad. Also update the version number.
2008-10-15 - Michael Vogt <michael.vogt@ubuntu.com>
command-not-found (0.2.26ubuntu1) intrepid; urgency=low
* scan.data updated to current intrepid
2008-10-15 - Colin Watson <cjwatson@ubuntu.com>
command-not-found (0.2.25ubuntu2) intrepid; urgency=low
[ Era Eriksson ]
* Print where-to-find-command, incorrect-PATH, and crash-guard messages to
stderr rather than stdout (LP: #212723).
[ Colin Watson ]
* Fix various crash bugs in the crash handler (LP: #269821).
* Adjust crash handler syntax to be friendly to Python 2.4 (LP: #234540).
2008-09-25 - Michael Vogt <michael.vogt@ubuntu.com>
command-not-found (0.2.25ubuntu1) intrepid; urgency=low
* command-not-found data updated for beta
2008-09-12 - Michael Vogt <michael.vogt@ubuntu.com>
command-not-found (0.2.24ubuntu1) intrepid; urgency=low
* updated scan.data for alpha-6

See Also

Package Description
commit-patch_2.5-1_all.deb utility to commit fine grained patches to source code control repositories
common-lisp-controller_7.11_all.deb Common Lisp source and compiler manager
comparepdf_1.0.1-1.1_amd64.deb command line tool for comparing two PDF files
compartment_1.1.0-5_amd64.deb Confine services in a limited environment
compass-blend-modes-plugin_0.0.3+20150331~dfsg-2_all.deb use standard color blending functions in Sass
compass-blueprint-plugin_1.0.0-3_all.deb Compass extension for blueprint CSS framework
compass-bootstrap-sass-plugin_3.3.5.1-5.1_all.deb Compass plugin implementing Twitter's Bootstrap
compass-breakpoint-plugin_2.7.1-1_all.deb really simple media queries with Sass
compass-color-schemer-plugin_0.2.8+20140309-3_all.deb create color schemes with ease
compass-fancy-buttons-plugin_1.1.1~20120313-6_all.deb Compass plugin implementing fancy CSS3 buttons
compass-h5bp-plugin_1.0.0-4_all.deb Compass extension for HTML5 Boilerplate
compass-layoutgala-plugin_0.2.1-1_all.deb Compass plugin implementing the Layout-gala CSS styles
compass-normalize-plugin_7.0.0-1_all.deb Sass version of Normalize.css
compass-sassy-maps-plugin_0.4.0-5_all.deb map helper functions for Sass maps
compass-singularitygs-plugin_1.8.0-1_all.deb advanced responsive grid system for Sass and Compass
Advertisement
Advertisement