bzr-builddeb_2.8.10_all.deb


Advertisement

Description

bzr-builddeb - bzr plugin for Debian package management

Distribution: Debian Sid
Repository: Debian Main amd64
Package name: bzr-builddeb
Package version: 2.8.10
Package release:
Package architecture: all
Package type: deb
Installed size: 898 B
Download size: 143.77 KB
Official Mirror: ftp.br.debian.org
Description: unavailable.

Alternatives

Provides

  • bzr-buildpackage

    Download

    Source package: bzr-builddeb

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install bzr-builddeb deb package:
      # sudo apt-get install bzr-builddeb

    Changelog

    2016-07-07 - Jelmer Vernoo─│ <jelmer@debian.org> bzr-builddeb (2.8.10) unstable; urgency=medium * Bump standards version to 3.9.8 (no changes). * Re-add myself to uploaders.

    2014-07-05 - Jelmer Vernooij <jelmer@debian.org> bzr-builddeb (2.8.9) unstable; urgency=medium * Use canonical URL in Vcs-Bzr control header. * Use Canonical URL in Vcs-Browser field. * Re-add myself to uploaders.

    2014-05-14 - Andrew Starr-Bochicchio <asb@debian.org> bzr-builddeb (2.8.8) unstable; urgency=low [ Iain Lane ] * debian/tests/control: Add python-distro-info and libalgorithm-merge-perl to test depends; the former is required to compare release names and the latter for dpkg-mergechangelogs to generate the expected output (it does different things with conflicts in 3-way merges depending on the presence of this library). (Closes: #727238) [ Andrew Starr-Bochicchio ] * Display a helpful error message if dh-make is not installed (LP: #641418). * Deprecate --v3 option for the dh-make command. dh_make has been creating v3 source packages since 2010 (LP: #811723). * quilt.py: quilt_unapplied should only return patch basenames regardless of whether or not QUILT_PATCHES_PREFIX is set. Fixes test failure with quilt > 0.63-2. * import_dsc.py: Use calendar.timegm instead of time.mktime when importing the timestamp. Thanks to Anders Kaseorg! (LP: #475983). * Bump Standards-Version to 3.9.5, no changes.

    2013-09-10 - Andrew Starr-Bochicchio <asb@debian.org> bzr-builddeb (2.8.7) unstable; urgency=low * tests/blackbox/test_import_dsc.py: - Explicitly pass '--format=1.0' to dpkg-source inorder to silence "no source format specified" warnings printed to stderr (Closes: #711042). * tests/test_import_dsc.py: - As of dpkg 1.17.0, source format '3.0 (native)' strictly enforces that native packages do not have a Debian revision. Use "0.1" instead of "0.1-1" for the version number in test_extract_format3_native (Closes: #720003). * debian/control: Add myself to Uploaders. * debian/tests/control: - Remove the depricated no-build-needed Features flag and add Restrictions: allow-stderr.

    2013-05-22 - Andrew Starr-Bochicchio <asb@debian.org> bzr-builddeb (2.8.6) unstable; urgency=low * Team upload. * Upload to unstable. * Move to minimal dh style rules file. * Drop bzr-svn from Build-Depends-Indep and Suggests (Closes: #709288). * Bump Standards-Version to 3.9.4, no changes needed. * Drop deprecated debian/pycompat and debian/pyversions files. * Add autopkgtests.

    2012-07-09 - Jelmer Vernooij <jelmer@debian.org> bzr-builddeb (2.8.5) experimental; urgency=low * Cope with quilt output being empty in error message. LP: #1014543 * Remove myself and Reinhard from uploaders. * Don't consider .gitignore when looking for upstream sources.

    2012-03-19 - Jelmer Vernooij <jelmer@debian.org> bzr-builddeb (2.8.4) unstable; urgency=low * Add dependency on quilt. LP: #951207 * Cope with missing tags when looking up upstream versions. * Skip quilt unapplying for trees that can not be copied (such as _PreviewTree). LP: #950419 * Document the argument for --export-upstream. LP: #959065

    2012-03-03 - Jelmer Vernooij <jelmer@debian.org> bzr-builddeb (2.8.3) unstable; urgency=low * Fix patch unapplying from DirStateRevisionTrees. LP: #923688 * Bump distro-info dependency back to a recommends, to ease backporting. * Cope with the deprecation of Tree.inventory in bzr/2.6. LP: #934247 * Generate xz files with the 'xz' utility rather than the Python 'lzma' module, as the latter uses options not supported by pristine- xz. Closes: #660721 * Merge fix from Joel Pickett to fix typo in orig-dir option help description. LP: #945413 * Bump standards version to 3.9.3 (no changes).

    Advertisement
    Advertisement