boa-constructor_0.6.1-16_all.deb


Advertisement

Description

boa-constructor - RAD tool for Python and wxWindows application

Distribution: Debian Sid
Repository: Debian Main amd64
Package name: boa-constructor
Package version: 0.6.1
Package release: 16
Package architecture: all
Package type: deb
Installed size: 17.63 KB
Download size: 12.08 MB
Official Mirror: ftp.br.debian.org
Description: unavailable.

Alternatives

    Download

    Source package: boa-constructor

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install boa-constructor deb package:
      # sudo apt-get install boa-constructor

    Changelog

    2016-03-25 - Reiner Herrmann <reiner@reiner-h.de> boa-constructor (0.6.1-16) unstable; urgency=low * QA upload. * Bump Standards-Version to 3.9.7. * Remove Vcs-* fields pointing to dead URLs. * Use SOURCE_DATE_EPOCH instead of BUILD_DATE, and depend on required debhelper version. * Sort files for boa.apphelp.htb archive. * Remove menu file. * Add Keywords to desktop file. * Don't install redundant license file. * Convert debian/copyright to DEP5. * Drop Python version restriction.

    2015-09-01 - Santiago Vila <sanvila@debian.org> boa-constructor (0.6.1-15) unstable; urgency=medium * QA upload. * debian/rules: Add TZ=UTC. Now it should be reproducible.

    2015-08-27 - Santiago Vila <sanvila@debian.org> boa-constructor (0.6.1-14) unstable; urgency=medium * QA upload. * debian/rules: set mtimes and modes of files before zipping them.

    2014-08-07 - Olly Betts <olly@survex.com> boa-constructor (0.6.1-13) unstable; urgency=medium * QA upload. * Update to depend on python-wxgtk3.0 rather than python-wxgtk2.8: + New patch: wxpy3.0-compat.patch + Update/rename select_wxpython_2_8.patch to select_wxpython_3_0.patch. * Disable use of wx.media - this never worked in Debian, but now the module is gone too. * "Standards-Version: 3.9.5" - no changes required. * Update to debhelper compat level 9. * debian/README.source: Remove since it's obsolete with source format "3.0 (quilt)".

    2011-11-07 - Charlie Smotherman <cjsmo@cableone.net> boa-constructor (0.6.1-12) unstable; urgency=low * Orphaning package. * Update package to use wxwidgets2.8 (Closes: #645759). * Bump Standards-Version to 3.9.2, no changes required.

    2011-02-15 - Charlie Smotherman <cjsmo@cableone.net> boa-constructor (0.6.1-11) unstable; urgency=low * debian/source: - switched to using source format 3.0 (quilt). * debian/control: - increase min python version to (>=2.6.6-11~). - after a discussion with Luca Falavigna I am taking over maintenance of the package. Added my info to Maintainers: field - bumped Standards-Version to 3.9.1, no changes needed. - removed dependency on quilt. - removed dependency on python-support. - use X-P-V instead of XS-P-V, increase version to 2.6 * debian/rules: - removed "--with quilt", added "--with python2". - changed override to "dh_python2" and corrected syntax.

    2010-06-07 - Luca Falavigna <dktrkranz@debian.org> boa-constructor (0.6.1-10) unstable; urgency=low * debian/patches/string_exceptions.patch: - Do not use string exceptions, not supported by Python 2.6 * debian/control: - Bump Standards-Version to 3.8.4, no changes required.

    2009-11-27 - Luca Falavigna <dktrkranz@debian.org> boa-constructor (0.6.1-9) unstable; urgency=low * Do not install embedded tarfile, zipfile and xmlrpclib modules, they are provided by stdlib (closes: #556355): + debian/patches/stdlib.patch: - Adjust files to load modules from stdlib. + debian/patches/no_maxint.patch: - Drop change on tarfile.py, it will not be installed anymore. + debian/rules: - Exclude affected files from the package.

    2009-11-14 - Luca Falavigna <dktrkranz@debian.org> boa-constructor (0.6.1-8) unstable; urgency=low * Do not install embedded pyparsing module, suggest python-pyparsing instead, wx25upgrade.py needs it (Closes: #555367). * Do not install embedded ConfigParser module (Closes: #555426).

    2009-08-27 - Luca Falavigna <dktrkranz@debian.org> boa-constructor (0.6.1-7) unstable; urgency=low * Update my e-mail address. * Remove DM-Upload-Allowed field. * Switch to debhelper 7: - Bump compat level to 7. - Minimize debian/rules. - Build-Depend on debhelper (>= 7.0.50) and quilt (>= 0.46-7). * debian/patches/no_double_free.patch: - Do not attempt to free menu objects twice (Closes: #532988). * Depend on ${misc:Depends} to fix a lintian warning. * Bump Standards-Version to 3.8.3, no changes required. * Fix some wxWindows spelling errors in the description.

    Advertisement
    Advertisement