blt_2.5.3+dfsg-4+b1_amd64.deb


Advertisement

Description

blt - graphics extension library for Tcl/Tk - run-time

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename blt_2.5.3+dfsg-4+b1_amd64.deb
Package name blt
Package version 2.5.3+dfsg
Package release 4+b1
Package architecture amd64
Package type deb
Category libs role::shared-lib
Homepage http://blt.sourceforge.net/
License -
Maintainer Sergei Golovan <sgolovan@debian.org>
Download size 14.71 KB
Installed size 31.00 KB

Alternatives

Package Version Architecture Repository
blt_2.5.3+dfsg-4_i386.deb 2.5.3+dfsg i386 Debian Main
blt - - -

Requires

Name Value
tk8.6-blt2.5 = 2.5.3+dfsg-4+b1

Download

Type URL
Mirror ftp.br.debian.org
Binary Package blt_2.5.3+dfsg-4+b1_amd64.deb
Source Package blt

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install blt deb package:
    # sudo apt-get install blt

Files

Path
/usr/share/doc/blt/README.Debian
/usr/share/doc/blt/changelog.Debian.amd64.gz
/usr/share/doc/blt/changelog.Debian.gz
/usr/share/doc/blt/changelog.gz
/usr/share/doc/blt/copyright

Changelog

2018-01-30 - Sergei Golovan <sgolovan@debian.org>
blt (2.5.3+dfsg-4) unstable; urgency=medium
* Rebuild to restore binary compatibility with the current Tcl/Tk 8.6
(closes: #888818).
* Bump the debhelper compatibility level to 10.
* Remove usage of autotools-dev and dh_autoreconf since they aren't
necessary for debhelper compatibility level 10.
* Bump the standards version to 4.1.3.
2015-11-25 - Sergei Golovan <sgolovan@debian.org>
blt (2.5.3+dfsg-3) unstable; urgency=medium
* Added the autotools-dev build dependency to replace the outdated
config.guess and config.sub by newer ones.
2015-11-25 - Sergei Golovan <sgolovan@debian.org>
blt (2.5.3+dfsg-2) unstable; urgency=medium
* Fixed the distclean target in Makefile.in which fixes FTBFS when build
twice in a row (closes: #791601).
* Fixed the override_dh_installdoc target in debian/rules to fix FTBFS
when dpkg-buildpackage -A is called for building the architecture-
independent packages only (closes: #805999).
* debian/patches/autoreconf.patch: fix autotools input for
compatibility with recent autoconf.  Thanks to Helmut Grohne
<helmut@subdivi.de> and Steve Langasek <vorlon@debian.org>
(closes: #772590).
* debian/patches/pkgindex.patch: correct this patch to patch the
configure.in source, not the generated configure script.
* debian/patches/install.patch: fix the distclean targets.
* debian/patches/*: remove patching of autogenerated configure
* Drop debian/rules override_dh_clean target, which gets it wrong.
2014-11-21 - Sergei Golovan <sgolovan@debian.org>
blt (2.5.3+dfsg-1) unstable; urgency=medium
* Removed non-distributable files library/dd_protocols/* from the source
package (closes: #769814).
* Split out the tk8.6-blt2.5 package to reflect the changed library soname.
The 8.6 suffix is added because this package works only with Tcl/Tk 8.6.
Added breaks header with all packages dependent on blt which included
the previous library soname. This prevents partial upgrades
(closes: #751767).
* Bumped the standards version to 3.9.6.
2014-07-09 - Sergei Golovan <sgolovan@debian.org>
blt (2.5.3-4) unstable; urgency=medium
* Made blt-dev replace blt (<< 2.5) because the doc-base file is moved to
the former package from the latter.
* Added patch which fixes BLT stubs declaration.
* Added a few patches which eliminate GCC warnings about incompatible
pointer types, using possibly unitialized variables, unused variables
and casts to/from pointer from/to integer of different size. This
fixes a few segfaults in demos (but not all of them).
2014-07-06 - Sergei Golovan <sgolovan@debian.org>
blt (2.5.3-3) unstable; urgency=medium
* Added missing headers to bltNsUtil.c to fix build failures on 64bit
architectures.
2014-07-04 - Sergei Golovan <sgolovan@debian.org>
blt (2.5.3-2) unstable; urgency=medium
* Restored forgotten call to dh_autotools-dev_updateconfig and explicitly
supplied --host option to the configure call to build the package on
kfreebsd-* architectures.
2014-07-04 - Sergei Golovan <sgolovan@debian.org>
blt (2.5.3-1) unstable; urgency=low
* New maintainer Sergei Golovan (closes: #664092).
* New upstream and new upstream release.
* Reviewed and refreshed patches.
* Added a patch from the FreeBSD BLT port. It allows BLT to work when it's
built with Tcl/Tk 8.6 (closes: #753476).
* Moved HTML documentation from blt to blt-dev.
2014-06-13 - Matthias Klose <doko@debian.org>
blt (2.4z-9) unstable; urgency=high
* QA upload.
* Build using Tcl/Tk 8.6.
2014-04-16 - Sergei Golovan <sgolovan@debian.org>
blt (2.4z-8) unstable; urgency=low
* QA upload.
* Fixed build with newer Tcl/Tk package which switched from shlibs to
symbols. (Closes: #724882)

See Also

Package Description
bluebird-gtk-theme_1.3-1_all.deb blue GTK+ theme from the Shimmer Project
bluedevil_5.14.5-1_amd64.deb KDE Bluetooth stack
bluefish-data_2.2.10-3_all.deb advanced Gtk+ text editor (data)
bluefish-plugins_2.2.10-3_amd64.deb advanced Gtk+ text editor (plugins)
bluefish_2.2.10-3_amd64.deb advanced Gtk+ text editor for web and software development
blueman_2.1.1-1+b1_amd64.deb Graphical bluetooth manager
bluemon_1.4-7_amd64.deb Activate or deactivate programs based on Bluetooth link quality
blueproximity_1.2.5-6_all.deb locks/unlocks your desktop tracking a bluetooth device
bluetooth_5.50-1_all.deb Bluetooth support (metapackage)
bluewho_0.1-2_all.deb notifies new discovered bluetooth devices
bluez-cups_5.50-1+b1_amd64.deb Bluetooth printer driver for CUPS
bluez-hcidump_5.50-1+b1_amd64.deb Analyses Bluetooth HCI packets
bluez-obexd_5.50-1+b1_amd64.deb bluez obex daemon
bluez-test-scripts_5.50-1_all.deb test scripts of bluez
bluez-test-tools_5.50-1+b1_amd64.deb test tools of bluez
Advertisement
Advertisement