bittorrent_3.4.2-12_all.deb


Advertisement

Description

bittorrent - Original BitTorrent client - console tools

Distribution: Debian Sid
Repository: Debian Main amd64
Package name: bittorrent
Package version: 3.4.2
Package release: 12
Package architecture: all
Package type: deb
Installed size: 161 B
Download size: 48.25 KB
Official Mirror: ftp.br.debian.org
Description: unavailable.

Alternatives

    Download

    Source package: bittorrent

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install bittorrent deb package:
      # sudo apt-get install bittorrent

    Changelog

    2016-01-10 - Mattia Rizzolo <mattia@debian.org> bittorrent (3.4.2-12) unstable; urgency=medium * QA upload. * Orphan the package, see #810612. * Split out a python-bittorrent package. * debian/patches/fix-readme-file.patch: add: + Remove instructions which only concern Windows systems. + Remove references to files which aren't in the package, and adjust executable names (./whatever.py -> whatever). + Fix two example commands which had incorrect arguments. * debian/patches/btshow-meta-info.patch: add: + Now bittorrent checks file type before trying to extract any information. * debian/patches/btmakemetafile.patch: add: + Set piece_len_exp to 18 if no exp defined. * Move to short dh syntax and debhelper compat 9. Also use pybuild. * Run wrap-and-sort. * debian/control: + Merge Build-Depends-Indep into Build-Depends. + Bump Standards-Versions to 3.9.6, no further changes needed. + Remove the homepage, the original project is not really active anymore. + Build-Depend on python instead of python-all-dev. + Use source:Version instead of Source-Version substvar. + Add Vcs-* fields, pointing to a collab-maint repo * Remove useless maintainer scripts. * Remove useless debian/pyversions file. * Fix some spelling-error-in-manpage in bittorrent-downloader.bittorrent.1.

    2015-08-18 - Martin Pitt <mpitt@debian.org> bittorrent (3.4.2-11.7) unstable; urgency=medium * Non-maintainer upload. * Convert to dh_python2. (Closes: #785966) * debian/control: Add missing ${misc:Depends}.

    2014-08-15 - Olly Betts <olly@survex.com> bittorrent (3.4.2-11.6) unstable; urgency=medium * Non-maintainer upload. * Update to source format "3.0 (quilt)". * Update to use python-wxgtk3.0. (Closes: #757431) * Apply patch from Ben Finney to update Python code to not throw string exceptions, which are no longer supported. (Closes: #585222) * Install bittorrent.ico and fix paths in scripts so it gets used. (Closes: #733447) * Fix 'Torent' typo in short description. (Closes: #424856, #673131) * debian/control: Update to use 'Homepage:'. (Closes: #615435, #615465) * debian/bittorrent.docs: Apply patch from Benjamin Kerensa to replace unsupported shell brace expansion. (Closes: #688620)

    2013-07-14 - Luca Falavigna <dktrkranz@debian.org> bittorrent (3.4.2-11.5) unstable; urgency=low * Non-maintainer upload. * Drop useless dh_python call (Closes: #715296). * Drop useless XB-Python-Version fields. * Drop useless pycompat file.

    2011-11-24 - Olly Betts <olly@survex.com> bittorrent (3.4.2-11.4) unstable; urgency=low * Non-maintainer upload. * Update to depend on python-wxgtk2.8 rather than python-wxgtk2.6 - should be a low risk change, as with default alternatives 2.8 will already get used if installed, and 2.8 has twice as many installs according to popcon. (Closes: #645618)

    2009-10-19 - Kumar Appaiah <akumar@debian.org> bittorrent (3.4.2-11.3) unstable; urgency=low * Non-maintainer upload. * Build-Depend on python-all-dev (>= 2.5.4) for python.mk use.

    2009-10-17 - Bastian Venthur <venthur@debian.org> bittorrent (3.4.2-11.2) unstable; urgency=low * Non-maintainer upload. * Fix "manipulates site-packages/ directly, failing with Python 2.6" Applied and uploaded Kumar's patch, thanks dude! (Closes: #547811)

    2008-05-25 - Peter Eisentraut <petere@debian.org> bittorrent (3.4.2-11.1) unstable; urgency=low * Non-maintainer upload. * Fix bashism in debian/rules. Closes: #477252.

    2007-05-15 - Michael Janssen <jamuraa@debian.org> bittorrent (3.4.2-11) unstable; urgency=low * Add LSB logging functionality. (thanks David!) Closes: #384724 * Clarify short desciptions of packages. Closes: #418964. * Moved initscript into examples directory, as it was largely unused. Closes: #423901. * Example initscript now honors START_BTTRACK. Closes: 369831.

    2006-10-18 - Michael Janssen <jamuraa@debian.org> bittorrent (3.4.2-10) unstable; urgency=low * Remove dependency on obselete python-wxgtk2.4.

    Advertisement
    Advertisement