autojump_22.5.0-2_all.deb


Advertisement

Description

autojump - shell extension to jump to frequently used directories

Distribution: Debian Sid
Repository: Debian Main amd64
Package name: autojump
Package version: 22.5.0
Package release: 2
Package architecture: all
Package type: deb
Installed size: 156 B
Download size: 35.90 KB
Official Mirror: ftp.br.debian.org
Description: unavailable.

Alternatives

    Download

    Binary package: autojump_22.5.0-2_all.deb
    Source package: autojump

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install autojump deb package:
      # sudo apt-get install autojump

    Changelog

    2016-11-24 - Tanguy Ortolo <tanguy+debian@ortolo.eu> autojump (22.5.0-2) unstable; urgency=medium * debian/autojump.install: install the Zsh completion file to /usr/share/zsh/vendor-completions. (Closes: #843580)

    2016-10-09 - Tanguy Ortolo <tanguy+debian@ortolo.eu> autojump (22.5.0-1) unstable; urgency=medium * New upstream release. * debian/watch: switch to version 4 and use substitutions to make it more generic.

    2016-07-23 - Tanguy Ortolo <tanguy+debian@ortolo.eu> autojump (22.3.4-1) unstable; urgency=medium * New upstream release. * debian/control: - switch Vcs-* URLs to HTTPS. - update Standards-Version to 3.9.8 (no change needed).

    2016-03-31 - Tanguy Ortolo <tanguy+debian@ortolo.eu> autojump (22.3.0-1) unstable; urgency=medium * New upstream release. * debian/control: - update Standards-Version (no change needed). - build-depend on debhelper >= 9. * debian/compat: change to recommended compatibility level 9. * debian/rules: correct the position of dh's --with option, after the commands.

    2015-07-24 - Tanguy Ortolo <tanguy+debian@ortolo.eu> autojump (22.2.4-1) unstable; urgency=medium * New upstream release. * Upstream developer changed, and so did the project website. * debian/control: - update Homepage to new website. - update Build-Depends: + no longer need to build jumpapplet's manpage from DocBook. + use dh_python. - update Enhances: + only Bash >= 4.0 is supported). + add Fish which is now supported. + remove old package zsh-beta which no longer exists. (Closes: #785361) - update Standards-Version to 3.9.6 (no change needed). * debian/watch: update to new website. * debian/copyright: update dates. * debian/patches: refresh (adaptations were needed, but no semantic change). * debian/rules: - disable automatic test, which always tries to download dependencies even if they are already present, which fails without a connection to the Internet. - disable dh_pysupport, which would install maintainer script to byte-compile modules for Python 2.7, which is useless since autojump is run with Python 3. - use dh_python3. - add comments to explain that automatic build and install are disabled and files are manually installed with dh_install instead. * debian/autojump.install: - install Python libraries to /usr/share/autojump. - install autojump to /usr/share/autojump. * debian/autojump.links: - make /usr/bin/autojump a symlink to /usr/share/autojump/autojump (this solves the library import path problem).

    2014-06-08 - Tanguy Ortolo <tanguy+debian@ortolo.eu> autojump (21.7.1-1) unstable; urgency=medium * New upstream release. * debian/autojump.install: install the Fish shell plugin. * debian/control: - Enhances fish. - update Standards-Version to 3.9.5 (no change needed). * debian/patches/remove-makefile-test.patch: remove, applied upstream.

    2013-08-15 - Tanguy Ortolo <tanguy+debian@ortolo.eu> autojump (21.6.9-1) unstable; urgency=low * New upstream release. * debian/patches: - fix-arbitrary-code-flaw.patch: removed, part of that upstream release. - fix-dict-bug.patch: removed, part of that upstream release. - fix-manpage.patch: removed, no longer needed. - runtests-shebang.patch, fix-tests.patch: removed as the tests no longer exist. - remove-makefile-test.patch: remove references to the removed tests in the makefile so it can be built. - man-source.patch, move-to-usrshare.patch: refresh.

    2013-04-28 - Tanguy Ortolo <tanguy+debian@ortolo.eu> autojump (21.5.1-2) experimental; urgency=low * debian/patches: new patches + fix-arbitrary-code-flaw.patch: pick a fix for an arbitrary code execution flaw. (Closes: #706252) (CVE-2013-2012) + fix-dict-bug.patch: fix a bug that rendered the --purge option unusable. (Closes: #705516)

    Advertisement
    Advertisement