apper_1.0.0-2+b1_amd64.deb


Advertisement

Description

apper - KDE package management tool using PackageKit

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename apper_1.0.0-2+b1_amd64.deb
Package name apper
Package version 1.0.0
Package release 2+b1
Package architecture amd64
Package type deb
Category admin::package-management implemented-in::c++ kde role::plugin uitoolkit::qt
Homepage https://www.kde.org/applications/system/apper/
License -
Maintainer Matthias Klumpp <mak@debian.org>
Download size 320.51 KB
Installed size 1.39 MB

Alternatives

Package Version Architecture Repository
apper_1.0.0-2_i386.deb 1.0.0 i386 Debian Main
apper - - -

Requires

Name Value
apper-data >= 1.0.0-2
kio -
libappstreamqt2 >= 0.12.8
libc6 >= 2.14
libkf5completion5 >= 4.97.0
libkf5configcore5 >= 4.97.0
libkf5coreaddons5 >= 4.100.0
libkf5dbusaddons5 >= 4.99.0
libkf5i18n5 >= 4.97.0
libkf5iconthemes5 >= 4.96.0
libkf5itemviews5 >= 4.96.0
libkf5jobwidgets5 >= 4.96.0
libkf5kiocore5 >= 4.96.0
libkf5kiowidgets5 >= 4.96.0
libkf5notifications5 >= 4.96.0
libkf5service-bin -
libkf5service5 >= 4.96.0
libkf5solid5 >= 4.97.0
libkf5widgetsaddons5 >= 4.96.0
libkf5xmlgui5 >= 4.96.0
libkworkspace5-5 >= 4:5.8.1
libpackagekitqt5-1 -
libqt5core5a >= 5.11.0~rc1
libqt5dbus5 >= 5.0.2
libqt5gui5 >= 5.7.0
libqt5widgets5 >= 5.11.0~rc1
libqt5xmlpatterns5 >= 5.0.2
libstdc++6 >= 4.1.1
packagekit >= 0.8.6
policykit-1-gnome -
polkit-kde-1 -
software-properties-kde -

Replaces

Name Value
apper-appsetup << 0.7.2

Download

Type URL
Mirror ftp.br.debian.org
Binary Package apper_1.0.0-2+b1_amd64.deb
Source Package apper

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install apper deb package:
    # sudo apt-get install apper

Files

Path
/usr/bin/apper
/usr/lib/x86_64-linux-gnu/apper/libapper_private.so
/usr/lib/x86_64-linux-gnu/libexec/apper-pk-session
/usr/lib/x86_64-linux-gnu/qt5/plugins/kded_apperd.so
/usr/share/apperd/apperd.notifyrc
/usr/share/applications/org.kde.apper.desktop
/usr/share/applications/org.kde.apper_installer.desktop
/usr/share/applications/org.kde.apper_settings.desktop
/usr/share/applications/org.kde.apper_updates.desktop
/usr/share/dbus-1/services/kde-org.freedesktop.PackageKit.service
/usr/share/doc/apper/changelog.Debian.amd64.gz
/usr/share/doc/apper/changelog.Debian.gz
/usr/share/doc/apper/copyright
/usr/share/kservices5/kded/apperd.desktop
/usr/share/man/ca/man1/apper.1.gz
/usr/share/man/de/man1/apper.1.gz
/usr/share/man/es/man1/apper.1.gz
/usr/share/man/et/man1/apper.1.gz
/usr/share/man/hu/man1/apper.1.gz
/usr/share/man/it/man1/apper.1.gz
/usr/share/man/man1/apper.1.gz
/usr/share/man/nl/man1/apper.1.gz
/usr/share/man/pt/man1/apper.1.gz
/usr/share/man/pt_BR/man1/apper.1.gz
/usr/share/man/sv/man1/apper.1.gz
/usr/share/man/uk/man1/apper.1.gz
/usr/share/metainfo/org.kde.apper.appdata.xml

Changelog

2019-01-26 - Matthias Klumpp <mak@debian.org>
apper (1.0.0-2) unstable; urgency=medium
* Acknowledge NMU
* Switch to dh compat level 12
* Recommend apt-config-icons instead of shipping our own config snippet
* Add Install-apper-binary-as-TARGET-instead-of-PROGRAM.patch from upstream:
- Install apper binary as TARGET instead of PROGRAM. This allows us to
drop an ugly chrpath hack from d/rules.
* Add Update-AppStream-metadata.patch from upstream:
- Remove AppStream generator complaints and make screenshots appear again.
* Add Fix-proxy-file-watching.patch from upstream
* Add Fix-apperd-metadata.patch from upstream:
- Removes journal warning
* Add Removed-background-gradient.patch from upstream:
- Fixes UX issues
* Bump standards version (no changes needed)
2018-09-22 - Adrian Bunk <bunk@debian.org>
apper (1.0.0-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Add upstream fix for FTBFS with Qt 5.11,
thanks to Reiner Herrmann. (Closes: #906971)
2018-02-21 - Matthias Klumpp <mak@debian.org>
apper (1.0.0-1) unstable; urgency=medium
* New upstream version: 1.0.0
- Builds with recent PackageKit-Qt (Closes: #888155)
- Resolves some drawing issues (Closes: #876846)
* Update d/watch
* Update VCS and homepage URLs
* Build without Limba support
* Use dh compat level 11
* Drop all patches: Applied upstream
* Update build deps
- Drop stale build-dep on kdelibs5-dev (Closes: #883586)
- Don't build-depend on kio-dev transitional package (Closes: #885385)
* fix-build-with-editorigins.patch: Fix FTBFS when EDIT_ORIGNS_DESKTOP_NAME
is defined
* Update install files
* d/rules: Remove some cruft
2017-01-19 - Matthias Klumpp <mak@debian.org>
apper (0.9.2+git20161222-3) unstable; urgency=medium
* Enable AppStream icon download explicitly
* Don't install the updater Plasmoid (Closes: #851117)
- The updater Plasmoid is currently broken and will need some
work to be revived. We can not ship with it for Debian Stretch.
Having two default-enabled updater icons also is very confusing
to users, so if the updater gets ported to recent QtQuick and
received upstream fixes, we can bring it back as separate package.
2017-01-08 - Matthias Klumpp <mak@debian.org>
apper (0.9.2+git20161222-2) unstable; urgency=medium
* Hack around rpath oddness (Closes: #849956)
* apper-icon.patch: Set the right icon for Apper
2016-12-22 - Matthias Klumpp <mak@debian.org>
apper (0.9.2+git20161222-1) unstable; urgency=medium
* New upstream Git snapshot: 0.9.2+git20161222
- The package is brought back to unstable due to a lot of
users requesting it, but since it is essentially dead upstream
and I do not know how well it works for most users,
I will drop it from the Debian Stretch release if it is found to
be unfit and issues can not be fixed in time.
Any help (patches! - and testing) is appreciated.
* Use secure Vcs-* URLs
* Bump dh compat level to 10
* Drop manual debug package in favor of automatic dbgsym packages
2015-09-30 - Matthias Klumpp <mak@debian.org>
apper (0.9.2+git20150930-1) experimental; urgency=medium
* New upstream Git snapshot: 0.9.2+git20150930 (e0bf3649)
* Drop patches: Applied upstream
2015-08-26 - Matthias Klumpp <mak@debian.org>
apper (0.9.2-3) unstable; urgency=medium
* Build-depend on libdebconf-kde0-dev
* Depend on appstream instead of appstream-index
2015-06-21 - Matthias Klumpp <mak@debian.org>
apper (0.9.2-2) unstable; urgency=medium
* Upload to unstable
2015-04-26 - Matthias Klumpp <mak@debian.org>
apper (0.9.2-1) experimental; urgency=medium
* New upstream release: 0.9.2
* Drop all patches: Applied upstream
* Fix compiler warning
* Only depend on Limba on linux-any

See Also

Package Description
appmenu-gtk-module-common_0.7.3-1_all.deb Common files for GtkMenuShell D-Bus exporter
appmenu-gtk2-module_0.7.3-1_amd64.deb GtkMenuShell D-Bus exporter (GTK+2.0)
appmenu-gtk3-module_0.7.3-1_amd64.deb GtkMenuShell D-Bus exporter (GTK+3.0)
appmenu-registrar_0.7.3-2_amd64.deb Appmenu DBusMenu registrar
approx_5.10-2_amd64.deb caching proxy server for Debian archive files
appstream-doc_0.12.9-1_all.deb Developer documentation for AppStream
appstream-generator_0.8.0-1_amd64.deb Generator for AppStream metadata
appstream-glib-doc_0.7.16-1_all.deb Developer documentation for the libappstream-glib library
appstream-util_0.7.16-1_amd64.deb Utility to work with AppStream metadata
appstream_0.12.9-1_amd64.deb Software component metadata management
apriltag_0.10.0-4+b1_amd64.deb AprilTags Visual Fiducial System
aprsdigi_3.10.0-2+b1_amd64.deb digipeater for APRS
aprx_2.9.0+dfsg-2_amd64.deb APRS Digipeater and iGate
apsfilter_7.2.6-2_all.deb Magic print filter with automatic file type recognition
apt-build_0.12.47+b1_amd64.deb frontend to apt to build, optimize and install packages
Advertisement
Advertisement