apcupsd_3.14.14-3_amd64.deb


Advertisement

Description

apcupsd - APC UPS Power Management (daemon)

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename apcupsd_3.14.14-3_amd64.deb
Package name apcupsd
Package version 3.14.14
Package release 3
Package architecture amd64
Package type deb
Category admin admin::power-management hardware::power hardware::power:ups interface::daemon interface::graphical interface::text-mode interface::x11 network::server role::program scope::utility uitoolkit::gtk uitoolkit::ncurses use::monitor x11::application
Homepage http://www.apcupsd.org/
License -
Maintainer Thorsten Alteholz <debian@alteholz.de>
Download size 259.08 KB
Installed size 895.00 KB

Alternatives

Package Version Architecture Repository
apcupsd_3.14.14-3_i386.deb 3.14.14 i386 Debian Main
apcupsd - - -

Requires

Name Value
libc6 >= 2.27
libgcc1 >= 1:4.2
libusb-0.1-4 >= 2:0.1.12
libwrap0 >= 7.6-4~
lsb-base -

Provides

Name Value
ups-monitor -

Conflicts

Name Value
ups-monitor -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package apcupsd_3.14.14-3_amd64.deb
Source Package apcupsd

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install apcupsd deb package:
    # sudo apt-get install apcupsd

Files

Path
/etc/apcupsd/apccontrol
/etc/apcupsd/apcupsd.conf
/etc/apcupsd/changeme
/etc/apcupsd/commfailure
/etc/apcupsd/commok
/etc/apcupsd/hosts.conf
/etc/apcupsd/killpower
/etc/apcupsd/multimon.conf
/etc/apcupsd/offbattery
/etc/apcupsd/onbattery
/etc/apcupsd/ups-monitor
/etc/default/apcupsd
/etc/init.d/apcupsd
/etc/init.d/ups-monitor
/lib/apcupsd/prestart
/lib/systemd/system/apcupsd.service
/lib/systemd/system/ups-monitor.service
/lib/systemd/system-shutdown/apcupsd_shutdown
/sbin/apcaccess
/sbin/apctest
/sbin/apcupsd
/usr/share/doc/apcupsd/DISCLAIMER
/usr/share/doc/apcupsd/Developers
/usr/share/doc/apcupsd/ReleaseNotes.gz
/usr/share/doc/apcupsd/changelog.Debian.gz
/usr/share/doc/apcupsd/changelog.gz
/usr/share/doc/apcupsd/copyright
/usr/share/doc/apcupsd/examples/usb.conf.gz
/usr/share/lintian/overrides/apcupsd
/usr/share/man/man5/apcupsd.conf.5.gz
/usr/share/man/man8/apcaccess.8.gz
/usr/share/man/man8/apccontrol.8.gz
/usr/share/man/man8/apctest.8.gz
/usr/share/man/man8/apcupsd.8.gz

Changelog

2019-08-24 - Thorsten Alteholz <debian@alteholz.de>
apcupsd (3.14.14-3) unstable; urgency=medium
* debian/control: bump standard to 4.3.0 (no changes)
* debian/control: do not depend on rst2pd (-> #929954)
(Closes: #935616)
2018-03-25 - Thorsten Alteholz <debian@alteholz.de>
apcupsd (3.14.14-2) unstable; urgency=medium
* debian/control: bump standard to 4.1.4 (no changes)
* debian/control: use dh11 (mostly)
* debian/control: add salsa VCS URLs
* debian/control: remove dependency for dh-systemd
* debian/control: use prio optional
* debian/control: remove dependency for python-imaging (Closes: #892950)
(dependency does not seem to be needed anymore)
* debian/local/*: replace /etc/apcupsd/powerfail by file created
with PWRFAILDIR from config
(Closes: #541660, #572727, #576703)
* debian/copyright: use https in URL
* debian/control: drop dependency on libgconf2-dev (Closes: #885820)
* debian/control: drop dependency on libgtk2.0-dev again
* debian/rules: do not build with --enable-gapcmon
Unfortunately gconf2 shall be removed from Debian.
Upstream needs to move from gconf to gsettings.
As long as this did not happen, we can not build
the frontend any longer. (Closes: #889670, #878209)
2017-10-04 - Thorsten Alteholz <debian@alteholz.de>
apcupsd (3.14.14-1) unstable; urgency=medium
* new maintainer (Closes: #866835)
* debian/control: bump standard to 4.1.0 (no changes)
* debian/control: use dh10
* debian/control: remove useless dependency on dh-autoreconf
and autotools-dev
* debian/control: add dependency on lsb-base to apcupsd
* debian/apcupsd.servive: wait for network.online (Closes: #865620)
* debian/rules: build with --enable-gapcmon
new dependencies: libgtk2.0-dev, libgconf2-dev
* add 14-update-conf.patch (Closes: #849404)
clarification for LOCKFILE usage in apcupsd.conf
* debian/copyright: update
2017-01-17 - Christian Hofstaedtler <zeha@debian.org>
apcupsd (3.14.14-0.3) unstable; urgency=medium
* Non-maintainer upload.
* Split pre-start actions from init script to /usr/share/apcupsd/prestart.
* Add systemd unit, ignoring /etc/defaults/apcupsd. (Closes: #849401)
* Set default UPSTYPE/UPSCABLE to "usb", to avoid poking the serial line
with the default configuration.
* Remove APCACCESS variable from /etc/defaults/apcupsd.
* Drop explicit build-dependency on libssl-dev. libsnmp-dev pulls it
in for us.
* Build with --enable-modbus-usb. (Closes: #844418)
* Revert to libusb-dev for modbus-usb. The generic Linux driver does
not actually use libusb.
2016-07-21 - Christian Hofstaedtler <zeha@debian.org>
apcupsd (3.14.14-0.2) unstable; urgency=medium
* Non-maintainer upload.
* Fix FTBFS on arch:all buildd, patch from Santiago Vila.
(Closes: #831804)
2016-07-16 - Christian Hofstaedtler <zeha@debian.org>
apcupsd (3.14.14-0.1) unstable; urgency=medium
* Non-maintainer upload.
* New upstream version. (Closes: #448147, #580225, #824942)
* Refresh and drop obsolete patches.
* Follow docs path change from homepage to manual
* Update source path for manpages
* Drop options configure no longer understands
* Set source format to 3.0 (quilt) instead of using quilt directly
* Convert to dh-style build rules and use compat 9
* Explicitly set path to shutdown(1) (Closes: #828834)
* Enable hardening flags for daemons
* Use cat when /usr is already umounted or wall is missing (Closes: #709612)
* Remove long gone Uploader, thanks Stefan Ritter (Closes: #831451)
* Hook killpower into systemd-shutdown.
Hook script from Fedora, thanks. And mask ups-monitor.service,
which is only relevant for /etc/init.d/halt.
(Closes: #807689)
* Update Homepage (Closes: #816121)
* Remove version number from generated conffiles (Closes: #322970)

See Also

Package Description
apel_10.8+0.20120427-21_all.deb portable library for emacsen
apertium-af-nl_0.2.0~r58256-2_all.deb Apertium translation data for the Afrikaans-Dutch pair
apertium-all-dev_3.5.2-1_all.deb Metapackage for all tools required for Apertium development
apertium-apy_0.11.5-1_all.deb Apertium APY service
apertium-arg-cat_0.1.0~r64925-2_all.deb Apertium translation data for the Aragonese-Catalan pair
apertium-arg_0.1.2~r65494-2_all.deb Apertium single language data for Aragonese
apertium-bel-rus_0.2.0~r81186-2_all.deb Apertium translation data for the Belarusian-Russian pair
apertium-bel_0.1.0~r81357-2_all.deb Apertium single language data for Belarusian
apertium-br-fr_0.5.0~r61325-3_all.deb Apertium linguistic data to translate between Breton and French
apertium-ca-it_0.1.1~r57554-2_all.deb Apertium translation data for the Catalan-Italian pair
apertium-cat-srd_1.0.0~r82995-2_all.deb Apertium translation data for the Catalan-Sardinian pair
apertium-cat_2.6.0-1_all.deb Apertium single language data for Catalan
apertium-crh-tur_0.3.0~r83159-2_all.deb Apertium translation data for the Crimean Tatar-Turkish pair
apertium-crh_0.2.0~r83161-2_all.deb Apertium single language data for Crimean Tatar
apertium-cy-en_0.1.1~r57554-4_all.deb Apertium translation data for the Welsh-English pair
Advertisement
Advertisement