alex4_1.1-7_amd64.deb


Advertisement

Description

alex4 - Alex the Allegator 4 - a retro platform game

Distribution: Debian Sid
Repository: Debian Main amd64
Package name: alex4
Package version: 1.1
Package release: 7
Package architecture: amd64
Package type: deb
Installed size: 149 B
Download size: 58.44 KB
Official Mirror: ftp.br.debian.org
Description: unavailable.

Alternatives

    Download

    Binary package: alex4_1.1-7_amd64.deb
    Source package: alex4

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install alex4 deb package:
      # sudo apt-get install alex4

    Changelog

    2016-09-15 - Markus Koschany <apo@debian.org> alex4 (1.1-7) unstable; urgency=medium * Team upload. [ Markus Koschany ] * Use compat level 10. * Declare compliance with Debian Policy 3.9.8. * Vcs-Browser: Use https. * Drop dpkg-dev build-dependency. * alex4.desktop: Add keywords and a comment in German. [ Jackson Doak ] * Drop build-dependency on hardening-wrapper. (Closes: #836750)

    2013-06-09 - Paul Wise <pabs@debian.org> alex4 (1.1-6) unstable; urgency=low * Team upload. * Add alex4.ini so that sound works (LP: #560664) * Add myself to uploaders * Build against liballegro4-dev instead (Closes: #710598) * Use the same longtitle in the Debian menu as the desktop comment * Use the canonical Vcs-* fields * Bump Standards-Version to 3.9.4, no changes needed

    2011-05-07 - Evgeni Golov <evgeni@debian.org> alex4 (1.1-5) unstable; urgency=low * Team upload. * Include defs.h *after* particle.h, thus not redifining __unused from glibc's bits/stat.h Closes: #624884 * Standards-Version: 3.9.2

    2011-03-09 - Peter Pentchev <roam@ringlet.net> alex4 (1.1-4) unstable; urgency=low * Update the unix-port patch a bit: - place the libraries at the end of the linker invocation line to fix the build on Ubuntu natty with the binutils-gold linker. I couldn't reproduce the FTBFS on Debian with binutils-gold-2.21.0.20110302-1, but it seems a really sensible change to make anyway :) Closes: #617465 - put the aldumb library before the Allegro libraries that it depends on - honor CPPFLAGS, CFLAGS and LDFLAGS * Convert to the 3.0 (quilt) source format. * Add misc:Depends to the alex4-data package just in case. * Expand the alex4-data package's long description. * Bump the debhelper compatibility level to 8 and minimize the rules file using debhelper override targets. * Bump Standards-Version to 3.9.1 with no changes. * Use dpkg-buildflags to obtain the default values for CPPFLAGS, CFLAGS and LDFLAGS. * Convert the copyright file to the DEP 5 candidate format and add my copyright notice on the debian/* packaging. * Convert all patch file headers to the DEP 3 format. * Build with -Werror if the non-standard "werror" build option is set. * Add the compiler-warnings patch to fix some, well, compiler warnings. * Harden the build unless the "nohardening" build option is set. * Add myself to the list of uploaders.

    2009-06-07 - Gonéri Le Bouder <goneri@rulezlan.org> alex4 (1.1-3) unstable; urgency=low [ Paul Wise ] * Add a watch file explaining the upstream status [ Peter De Wachter ] * Honor the HOME environment variable. (Closes: #507950) * Applied a patch to bring down the game's CPU usage to a more reasonable level. This limits the frame rate to 50Hz (the speed of the game logic). This also fixes a bug that made the level selection screen unresponsive on some systems. * Bump Standards-Version to 3.8.1: - Renamed 'configure' target to 'patch'. * Rename from-fedora.patch to unix-port.patch * Refresh debian/copyright * rules: clean up [ Gonéri Le Bouder ] * Complet Peter changelog part

    2008-03-19 - Peter De Wachter <pdewacht@gmail.com> alex4 (1.1-2) unstable; urgency=low * Build-Depend on liballegro4.2-dev >= 4.2.2-2 - which has a versioned shlibs file (Closes: #467526) - allegro-config no longer tells us to link against unneeded libraries.

    2008-01-19 - Peter De Wachter <pdewacht@gmail.com> alex4 (1.1-1) unstable; urgency=low * Initial release (Closes: #463033)

    Advertisement
    Advertisement