addresses.framework_0.4.8-2_all.deb


Advertisement

Description

addresses.framework - Database API backend framework for GNUstep

Distribution: Debian Sid
Repository: Debian Main amd64
Package name: addresses.framework
Package version: 0.4.8
Package release: 2
Package architecture: all
Package type: deb
Installed size: 19 B
Download size: 10.23 KB
Official Mirror: ftp.br.debian.org
Description: unavailable.

Alternatives

    Download

    Source package: addresses-for-gnustep

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install addresses.framework deb package:
      # sudo apt-get install addresses.framework

    Changelog

    2015-11-16 - Eric Heintzmann <heintzmann.eric@free.fr> addresses-for-gnustep (0.4.8-2) unstable; urgency=medium * Fix danggling symlinks in libaddressview-dev and libaddresses-dev (Closes: # 805201) * Update debian/watch file.

    2015-11-03 - Eric Heintzmann <heintzmann.eric@free.fr> addresses-for-gnustep (0.4.8-1) unstable; urgency=low * New upstream release (Closes: #512382) * Repackage from scratch: - Use source format 3.0 (quilt) - Drop CDBS support - Bump DH_COMPAT to 9 - Bump Standards-Version to 3.9.6 - Rewrite debian/copyright file - Add Homepage field in debian/control - Update to new menu structure (Closes: #496042) - Add Build-Dependency to dh-exec - Replace obsolete var ${Source-Version} by ${binary:Version} in debian/control file - Add ${misc:Depends} to all binaries packages dependencies in debian/control file as recommended by lintian - Remove duplicate section fields in debian/control file - As recommended by lintian, replace versionned Conflicts fields by Breaks fields in debian/control file - Update watch file - According to debian policy 9.1.1, move Resources dir in /usr/share: use dh_link and dpkg-maintscript-helper (and thus add dependency to dpkg >= 1.17.14) to create a symlink from old to new location. - Add libaddresses0.symbol and libaddressview0.symbol files in debian dir - Use debian build flags in debian/rules - Remove lintian override files (new packages are lintian free) - Pass -n to dh_makeshlibs in debian/rules to avoid lintian warning - Don't build VCFViewer (need gworkspace inspector lib wich is not present in debian sid) and LDAPAddressBook (need gsldap wich is not packaged in debian) in debian/rules file * Apply fix-adserver-format.patch to allow building package with "-Werror=format-security" Objective C compiler flag

    2015-06-02 - Eric Heintzmann <Heintzmann.Eric@free.fr> addresses-for-gnustep (0.4.7-3) unstable; urgency=medium * Update maintainer address (Closes: #768131)

    2014-10-29 - Yavor Doganov <yavor@gnu.org> addresses-for-gnustep (0.4.7-2) unstable; urgency=medium * Team upload. * Apply minimal fix to make the package usable with the current GNUstep libraries (Closes: #749721): - Fix overflow in implicit constant conversion; - Fix improper use of non-existent method; - Do not set string of a NSTextView to nil.

    2007-10-04 - Hubert Chathi <uhoreg@debian.org> addresses-for-gnustep (0.4.7-1) unstable; urgency=low * New upstream release. * Upload to unstable. * Update download location in copyright file.

    2007-07-11 - Hubert Chan <uhoreg@debian.org> addresses-for-gnustep (0.4.6-9) experimental; urgency=low * Recompile with new GNUstep libraries. * Apply patch by Nicola Pero to work with new gnustep-make.

    2006-12-19 - Hubert Chan <uhoreg@debian.org> addresses-for-gnustep (0.4.6-8) unstable; urgency=low * Rename adtool to addresstool to avoid conflict with adtool package. (closes: #403753) * Update debian/control to agree with overrides file for .framework packages.

    2006-11-16 - Hubert Chan <uhoreg@debian.org> addresses-for-gnustep (0.4.6-7) unstable; urgency=low * Apply patch for improved compatibility with Apple's VCards. (closes: #385124) * Add GNUstep tool symlink for tools in address-goodies-for-gnustep, and write manpages. * Update my maintaner address.

    2006-08-30 - Hubert Chan <hubert@uhoreg.ca> addresses-for-gnustep (0.4.6-6) unstable; urgency=low * Recompile with new GNUstep libraries. * Bump standards version to 3.7.2. (no changes) * Remove build-conflicts, which are not needed any more. * Fix license header in copyright file.

    Advertisement
    Advertisement