rott_1.1.2+svn287-3_i386.deb


Advertisement

Description

rott - SDL-Port of Rise of the Triad

Property Value
Distribution Debian Sid
Repository Debian Contrib i386
Package filename rott_1.1.2+svn287-3_i386.deb
Package name rott
Package version 1.1.2+svn287
Package release 3
Package architecture i386
Package type deb
Category contrib/games game::fps interface::graphical interface::x11 role::program uitoolkit::sdl use::gameplaying x11::application
Homepage https://icculus.org/rott/
License -
Maintainer Debian Games Team <pkg-games-devel@lists.alioth.debian.org>
Download size 462.84 KB
Installed size 1.72 MB

Alternatives

Package Version Architecture Repository
rott_1.1.2+svn287-3_amd64.deb 1.1.2+svn287 amd64 Debian Contrib
rott - - -

Requires

Name Value
libc6 >= 2.4
libsdl-mixer1.2 -
libsdl1.2debian >= 1.2.11

Download

Type URL
Mirror ftp.br.debian.org
Binary Package rott_1.1.2+svn287-3_i386.deb
Source Package rott

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install rott deb package:
    # sudo apt-get install rott

Files

Path
/usr/games/rott-commercial
/usr/games/rott-shareware
/usr/share/applications/rott.desktop
/usr/share/doc/rott/13todo.txt
/usr/share/doc/rott/README.Debian
/usr/share/doc/rott/README.gz
/usr/share/doc/rott/changelog.Debian.gz
/usr/share/doc/rott/cheats.txt.gz
/usr/share/doc/rott/cmdline.txt
/usr/share/doc/rott/copyright
/usr/share/doc/rott/hacker.txt.gz
/usr/share/doc/rott/readme.txt.gz
/usr/share/doc/rott/wad.txt
/usr/share/icons/hicolor/scalable/apps/rott.svg
/usr/share/lintian/overrides/rott
/usr/share/man/man6/rott-commercial.6.gz
/usr/share/man/man6/rott-shareware.6.gz
/usr/share/man/man6/rott.6.gz

Changelog

2018-01-15 - Simon McVittie <smcv@debian.org>
rott (1.1.2+svn287-3) unstable; urgency=medium
* Team upload
* Suggest kdialog instead of kde-baseapps-bin (see #885839)
* Update Vcs-* to point to salsa.debian.org
* Use https URLs for Homepage and Source
* Use https for d/copyright Format
* Standards-Version: 4.1.3 (no further changes)
* Use debhelper compat level 11
- Remove redundant dh-autoreconf build-dependency
* Set Rules-Requires-Root to no
* Enable full compiler hardening
2015-10-09 - Fabian Greffrath <fabian@debian.org>
rott (1.1.2+svn287-2) unstable; urgency=medium
* Show a dialog box if files are missing. Based on patches and
wordings by Alexandre Detiste, thank you very much (Closes: #790407).
+ Replace the unhelpful "W_InitFiles: no files found" error message
with instructions to read README.Debian.
+ Improve README.Debian with clear instructions on how to use
game-data-packager to locate/download the game data, build the
possible rott-*-data Debian package(s), and install it/them.
+ Add "Suggests: zenity | kde-baseapps-bin | x11-utils | libnotify-bin"
for the supported dialog box applications.
* Do not recommend any soundfont at all, leave this to the
libsdl-mixer1.2 package.
* Update Uploaders field and Debian packaging copyright with my
<fabian@debian.org> address.
* Remove rott.menu file and icons in XPM and PNG formats, install upstream's
SVG icon.
* Fix the rott.desktop file.
+ Remove hard-coded fullscreen mode and resolution.
+ Add keywords.
2015-05-11 - Fabian Greffrath <fabian+debian@greffrath.com>
rott (1.1.2+svn287-1) unstable; urgency=medium
* New upstream SVN snapshot.
+ Remove all patches that were applied upstream.
+ Upstream switched build system to Autotools, add
"Build-Depends: dh-autoreconf" and adapt debian/rules accordingly.
* Add debian/README.source file to document how the Debian source
tarball was created, add debian/gbp.conf file to force xz compression.
* Bump Standards-Version to 3.9.6.
* Move g-d-p from Depends to Recommends, drop virtual rott-data package from
alternative dependencies.
2015-04-30 - Fabian Greffrath <fabian+debian@greffrath.com>
rott (1.1.2-3) unstable; urgency=medium
* Make the "commercial" variant recognize all supported
multiplayer map files and set 'gamestate.Product' accordingly.
This saves us from building the SUPERROTT and SITELICENSE variants
which had their multiplayer map file names hard-coded.
Adjust documentation and packaging accordingly.
* Fix missing fog on level Foggy Mountain (Closes: #775530).
Light level is calculated based on scaled texture and sprite height
and is thus resolution-dependent, fix special-casing for fog.
Thanks Alexandre Detiste for the bug report!
* Fix scaling of the weapon sprite.
* Fix scaling of the sky texture.
2014-06-18 - Stephen Kitt <skitt@debian.org>
rott (1.1.2-2) unstable; urgency=low
* Team upload.
[ Fabian Greffrath ]
* Remove "Recommends: timidity" and the corresponding advice in
debian/README.Debian. Installing any package containing a soundfont
should be sufficient for music playback to work (see #498984).
* Run "wrap-and-sort -asb".
* Fix a segfault in the Darian level, original bug report and patch
by Luc Habert (Closes: #700977).
* Color crosshair by player health.
* Replace the icon with a self-drawn alternative in three different
formats and provide a reproduction rule in debian/rules.
* Enable parallel builds.
* Correctly append to CFLAGS in debian/rules.
* Fix conflicting types in variable declarations (Closes: #751510),
thanks Michael Tautschnig.
[ Stephen Kitt ]
* Drop obsolete Lintian override; rott-sitelicense is no longer
detected as an extra license file.
* Use the canonical 1.0 copyright format URI.
* Standards-Version 3.9.5, no further change required.

See Also

Package Description
rtcw-common_1.51.c+dfsg1-2_i386.deb common files for Return to Castle Wolfenstein
rtcw-server_1.51.c+dfsg1-2_i386.deb standalone server for Return to Castle Wolfenstein
rtcw_1.51.c+dfsg1-2_i386.deb game engine for Return to Castle Wolfenstein
ruby-googlecharts_1.6.12-1_all.deb Ruby library to generate charts using Google Chart API
ruby-graphiql-rails_1.4.10-1_all.deb mountable GraphiQL endpoint for Rails
ruby-pgplot_0.1.9-3+b2_i386.deb Ruby interface to the PGPLOT graphics library
sabnzbdplus_2.3.6+dfsg-1_all.deb web-based binary newsreader with nzb support
sandboxgamemaker_2.8.2+dfsg-1+b3_i386.deb 3D game maker and 3D game design program
sapgui-package_0.0.10+nmu1_all.deb utility to build SAP GUI related Debian packages
sdic-edict_2.1.3-22_all.deb installer for EDICT dictionaries for sdic
sdic-eijiro_2.1.3-22_all.deb installer for EIJIRO dictionaries for sdic
sdic-gene95_2.1.3-22_all.deb installer for GENE95 dictionaries for sdic
sdic_2.1.3-22_all.deb Emacs interface for Japanese dictionaries
spectemu-common_0.94a-20+b1_i386.deb Fast 48k ZX Spectrum Emulator (common files)
spectemu-x11_0.94a-20+b1_i386.deb Fast 48k ZX Spectrum Emulator for X11
Advertisement
Advertisement