microcode.ctl_1.18~0+nmu2_i386.deb


Advertisement

Description

microcode.ctl - Intel IA32/IA64 CPU Microcode Utility (transitional package)

Property Value
Distribution Debian Sid
Repository Debian Contrib i386
Package name microcode.ctl
Package version 1.18~0+nmu2
Package architecture i386
Package type deb
Installed size 35 B
Download size 8.65 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
microcode.ctl_1.18~0+nmu2_amd64.deb 1.18~0+nmu2 amd64 Debian Contrib
microcode.ctl - - -

Requires

Name Value
dpkg >= 1.15.7.2
intel-microcode >> 1
iucode-tool -

Conflicts

Name Value
intel-microcode << 1

Download

Type URL
Binary Package microcode.ctl_1.18~0+nmu2_i386.deb
Source Package microcode.ctl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install microcode.ctl deb package:
    # sudo apt-get install microcode.ctl

Files

Path
/usr/share/doc/microcode.ctl/changelog.gz
/usr/share/doc/microcode.ctl/copyright

Changelog

2012-09-16 - Henrique de Moraes Holschuh <hmh@debian.org>
microcode.ctl (1.18~0+nmu2) unstable; urgency=medium
* Non-maintainer upload.
* Add changelog entries for 1.17-13.2 and 1.17-13.1 (closes: #687835)
Missing changelog entries wreak havok with the BTS version tracking,
this is not simply a cosmetic fix.
2012-09-02 - Henrique de Moraes Holschuh <hmh@debian.org>
microcode.ctl (1.18~0+nmu1) unstable; urgency=low
* Non-maintainer upload.
* Replace microcode.ctl with a transitional package, to migrate
systems to the new intel-microcode package
+ Change to empty native package, debhelper compat level 7
+ debian/copyright: update
+ Move to contrib/oldlibs, priority extra
+ Remove replaces of a package not seen in the last decade
+ Change description to that of a transitional package
+ Depend on intel-microcode (>> 1) which superseded installing
microcode updates, and on iucode-tool, which superseded
the processing of microcode directly downloaded from Intel
+ Conflict with intel-microcode (<< 1) to be able to remove
/usr/share/misc/intel-microcode.dat which might have been
installed either by microcode.ctl's update-intel-microcode
script or by intel-microcode (<< 1).
+ Use dpkg-maintscript-helper to remove the initscript
+ Remove /usr/share/misc/intel-microcode.dat if still present when
configuring, and regenerates the initramfs in that case.  This
avoids left-over cruft microcode in the initramfs for the case
where update-intel-microcode was used, and we're being configured
together with intel-microcode (>> 1)
* This upload effectively removes microcode.ctl from Debian.  Close all
open bugs against microcode.ctl:
+ closes: #282583, #500802, #563910, #571408, #593845, #597039, #608675
+ closes: #627261, #660121, #663360, #664492, #674667, #684104
2012-01-18 - Christian Perrier <bubulle@debian.org>
microcode.ctl (1.17-13.2) unstable; urgency=low
* Non-maintainer upload.
* Fix pending l10n issues. Debconf translations:
- Brazilian Portuguese (Flamarion Jorge).  Closes: #622662
- Dutch; (Jeroen Schot).  Closes: #633834
- Italian (Francesca Ciceri).  Closes: #656246
2011-03-31 - Christian Perrier <bubulle@debian.org>
microcode.ctl (1.17-13.1) unstable; urgency=low
* Non-maintainer upload.
* Fix pending l10n issues. Debconf translations:
- Danish (Joe Hansen).  Closes: #595630
- Japanese (Hideki Yamane).  Closes: #599890
- Slovak (Ivan Masár).  Closes: #619312
2009-10-07 - Giacomo Catenazzi <cate@debian.org>
microcode.ctl (1.17-13) unstable; urgency=low
* update-intel-microcode: retrieve the first firmware in the RSS
applying patch from Hajo Moeller (Closes: #549699)
* remove possible needless dependency on po-debconf (Closes: #539943)
2009-07-26 - Giacomo Catenazzi <cate@debian.org>
microcode.ctl (1.17-12) unstable; urgency=low
* Downgrade intel-microcode to Recommends, removing the circular
dependency (Closes: #530338), giving some more visibility.
* extract microcode to a temporary file, in case wget will fail
(Closes: #500798)
* Remove support for old broken kernels  (Closes: #501074)
* Changed the priority and the default of debconf question:
don't download microcode by default (Closes: #529982)
* no bashism in actual init.d script, so let allow /bin/sh to
parse it (Closes: #534049)
* Improve the output on errors (Closes: #495146), and handle
better the errors
* exit imediately if no Intel processors are found (Closes: #515760)
* bump to policy 2.8.2
2009-03-17 - Giacomo Catenazzi <cate@debian.org>
microcode.ctl (1.17-11) unstable; urgency=low
* Fix "Invalid parameter for modprobe call in rc script"
in debian/microcode.ctl.init(Closes: #519904)
* Update Galician translation, thanks to Marce Villarino (Closes: #512244)
* Bumped version-standards to 3.8.1, no changes needed
* Correct lintian command-with-path-in-maintainer-script.
* add homepage to debian/control

See Also

Package Description
muttdown_0.2-1_all.deb Compiles annotated text mail into html using the Markdown standard
nvidia-installer-cleanup_20151021+8_i386.deb cleanup after driver installation with the nvidia-installer
nvidia-kernel-common_20151021+8_i386.deb NVIDIA binary kernel module support files
nvidia-modprobe_390.25-1_i386.deb utility to load NVIDIA kernel modules and create device nodes
nvidia-persistenced_390.25-1_i386.deb daemon to maintain persistent software state in the NVIDIA driver
nvidia-settings-legacy-304xx_304.137-2_i386.deb tool for configuring the NVIDIA graphics driver (304xx legacy version)
nvidia-settings-legacy-340xx_340.107-1_i386.deb tool for configuring the NVIDIA graphics driver (340xx legacy version)
nvidia-settings_390.67-1_i386.deb tool for configuring the NVIDIA graphics driver
nvidia-support_20151021+8_i386.deb NVIDIA binary graphics driver support files
nvidia-xconfig_390.25-1_i386.deb deprecated X configuration tool for non-free NVIDIA drivers
nvpy_1.0.0+git20171203.c91062c-1_all.deb Simplenote-syncing note-taking tool
ooniprobe_2.3.0-1_all.deb probe for the Open Observatory of Network Interference (OONI)
opendict-plugins-lingvosoft_0.8-2.1_all.deb plugins for OpenDict - LingvoSoft Online Dictionaries
openmw-cs_0.44.0-1_i386.deb Replacement of The Elder Scrolls Construction Set
openmw-data_0.44.0-1_all.deb Resources for the OpenMW engine
Advertisement
Advertisement