python3-flask-migrate_1.7.0-1_all.deb


Advertisement

Description

python3-flask-migrate - SQLAlchemy migrations for Flask using Alembic and Python 3

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename python3-flask-migrate_1.7.0-1_all.deb
Package name python3-flask-migrate
Package version 1.7.0
Package release 1
Package architecture all
Package type deb
Category python
Homepage https://pypi.python.org/pypi/Flask-Migrate
License -
Maintainer Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Download size 8.58 KB
Installed size 55.00 KB
Flask-Migrate is an extension that handles SQLAlchemy database migrations for
Flask applications using Alembic. The database operations are provided as
command line arguments for Flask-Script.
This is the Python 3 package

Alternatives

Package Version Architecture Repository
python3-flask-migrate_1.7.0-1_all.deb 1.7.0 all Debian Main
python3-flask-migrate - - -

Requires

Name Value
alembic >= 0.6
python3-alembic -
python3-flask >= 0.9
python3-flask-script -
python3-flask-sqlalchemy -
python3:any >= 3.3.2-2~

Download

Type URL
Mirror ftp.br.debian.org
Binary Package python3-flask-migrate_1.7.0-1_all.deb
Source Package flask-migrate

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python3-flask-migrate deb package:
    # sudo apt-get install python3-flask-migrate

Files

Path
/usr/lib/python3/dist-packages/Flask_Migrate-1.7.0.egg-info/PKG-INFO
/usr/lib/python3/dist-packages/Flask_Migrate-1.7.0.egg-info/dependency_links.txt
/usr/lib/python3/dist-packages/Flask_Migrate-1.7.0.egg-info/not-zip-safe
/usr/lib/python3/dist-packages/Flask_Migrate-1.7.0.egg-info/requires.txt
/usr/lib/python3/dist-packages/Flask_Migrate-1.7.0.egg-info/top_level.txt
/usr/lib/python3/dist-packages/flask_migrate/__init__.py
/usr/lib/python3/dist-packages/flask_migrate/templates/flask/README
/usr/lib/python3/dist-packages/flask_migrate/templates/flask/alembic.ini.mako
/usr/lib/python3/dist-packages/flask_migrate/templates/flask/env.py
/usr/lib/python3/dist-packages/flask_migrate/templates/flask/script.py.mako
/usr/lib/python3/dist-packages/flask_migrate/templates/flask-multidb/README
/usr/lib/python3/dist-packages/flask_migrate/templates/flask-multidb/alembic.ini.mako
/usr/lib/python3/dist-packages/flask_migrate/templates/flask-multidb/env.py
/usr/lib/python3/dist-packages/flask_migrate/templates/flask-multidb/script.py.mako
/usr/share/doc/python3-flask-migrate/changelog.Debian.gz
/usr/share/doc/python3-flask-migrate/copyright

Changelog

2016-02-18 - Orestis Ioannou <orestis@oioannou.com>
flask-migrate (1.7.0-1) unstable; urgency=medium
* Team upload.
* New upstream release
* Provide python 3 package
* Switch to pypi.debian.net for watch file
* Add missing Vcs fields
* Pump up s-d version to 3.9.7, no changes needed
* Run wrap-and-sort
2014-01-08 - Thomas Bechtold <toabctl@debian.org>
flask-migrate (1.2.0-1) unstable; urgency=medium
* New upstream release.
2014-01-08 - Thomas Bechtold <toabctl@debian.org>
flask-migrate (1.1.1-1) unstable; urgency=medium
* New upstream release.
* debian/rules: enable testsuite. tests/ dir is now included in upstream
tarball from pypi.
* debian/control: Add python-flask-script, python-flask-sqlalchemy and
alembic to Build-Depends. Needed for testsuite.
2014-01-03 - Thomas Bechtold <toabctl@debian.org>
flask-migrate (1.1.0-1) unstable; urgency=medium
* Initial release (Closes: #734040).

See Also

Package Description
python3-flask-openid_1.2.5+dfsg-2_all.deb OpenID support for Flask applications (Python 3)
python3-flask-principal_0.4.0-1_all.deb identity management for Flask
python3-flask-rdf_0.2.0-1_all.deb Flask decorator to output RDF using content negotiation (Python 3)
python3-flask-restful_0.3.5-1_all.deb REST API framework for Flask applications (Python3 Module)
python3-flask-script_2.0.5-2_all.deb set of utilities for use with the Flask framework and Python 3
python3-flask-silk_0.2-5_all.deb FamFamFam Silk icon set for Flask applications (Python 3)
python3-flask-sqlalchemy_2.1-3_all.deb adds SQLAlchemy support to your Python 3 Flask application
python3-flask-testing_0.4.2-1_all.deb unit testing utilities for the Flask micro web framework
python3-flask_0.12.1-1_all.deb micro web framework based on Werkzeug and Jinja2 - Python 3.x
python3-flaskext.multistatic_1.0-1_all.deb Simple flask plugin for overriding static files (Python 3)
python3-flaskext.wtf_0.12-2_all.deb Simple integration of Flask and WTForms (Python 3)
python3-flexmock_0.10.2-1_all.deb Mock/Stub/Spy library for Python 3
python3-flickrapi_2.1.2-5_all.deb Flickr API wrapper for Python 3
python3-flufl.bounce_2.3-4_all.deb email bounce detectors (Python 3)
python3-flufl.enum_4.1.1-1_all.deb yet another Python enumeration package (Python 3)
Advertisement
Advertisement