python-h5py_2.7.0-1_i386.deb


Advertisement

Description

python-h5py - general-purpose Python interface to hdf5 (Python 2)

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename python-h5py_2.7.0-1_i386.deb
Package name python-h5py
Package version 2.7.0
Package release 1
Package architecture i386
Package type deb
Category python
Homepage http://www.h5py.org/
License -
Maintainer Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>
Download size 552.59 KB
Installed size 2.74 MB
HDF5 for Python (h5py) is a general-purpose Python interface to the
Hierarchical Data Format library, version 5. HDF5 is a versatile, mature
scientific software library designed for the fast, flexible storage of
enormous amounts of data.
From a Python programmer's perspective, HDF5 provides a robust way to
store data, organized by name in a tree-like fashion. You can create
datasets (arrays on disk) hundreds of gigabytes in size, and perform
random-access I/O on desired sections. Datasets are organized in a
filesystem-like hierarchy using containers called "groups", and accessed
using the tradional POSIX /path/to/resource syntax.
H5py provides a simple, robust read/write interface to HDF5 data from
Python. Existing Python and Numpy concepts are used for the interface;
for example, datasets on disk are represented by a proxy class that
supports slicing, and has dtype and shape attributes. HDF5 groups are
presented using a dictionary metaphor, indexed by name.
This package provides h5py for the Python 2 interpreter.

Alternatives

Package Version Architecture Repository
python-h5py_2.7.1-2~nd90+1_amd64.deb 2.7.1 amd64 NeuroDebian Main
python-h5py_2.7.1-2~nd90+1_i386.deb 2.7.1 i386 NeuroDebian Main
python-h5py_2.7.0-1_amd64.deb 2.7.0 amd64 Debian Main
python-h5py - - -

Requires

Name Value
libc6 >= 2.4
libhdf5-100 -
python >= 2.7~
python << 2.8
python-numpy >= 1:1.10.0~b1
python-numpy-abi9 -
python-six -
python:any << 2.8
python:any >= 2.7.5-5~

Download

Type URL
Mirror ftp.br.debian.org
Binary Package python-h5py_2.7.0-1_i386.deb
Source Package h5py

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-h5py deb package:
    # sudo apt-get install python-h5py

Files

Path
/usr/lib/python2.7/dist-packages/h5py/__init__.py
/usr/lib/python2.7/dist-packages/h5py/_conv.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/h5py/_errors.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/h5py/_objects.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/h5py/_proxy.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/h5py/defs.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/h5py/h5.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/h5py/h5a.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/h5py/h5ac.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/h5py/h5d.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/h5py/h5ds.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/h5py/h5f.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/h5py/h5fd.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/h5py/h5g.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/h5py/h5i.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/h5py/h5l.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/h5py/h5o.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/h5py/h5p.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/h5py/h5r.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/h5py/h5s.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/h5py/h5t.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/h5py/h5z.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/h5py/highlevel.py
/usr/lib/python2.7/dist-packages/h5py/ipy_completer.py
/usr/lib/python2.7/dist-packages/h5py/utils.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/h5py/version.py
/usr/lib/python2.7/dist-packages/h5py-2.7.0.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/h5py-2.7.0.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/h5py-2.7.0.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/h5py-2.7.0.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/h5py/_hl/__init__.py
/usr/lib/python2.7/dist-packages/h5py/_hl/attrs.py
/usr/lib/python2.7/dist-packages/h5py/_hl/base.py
/usr/lib/python2.7/dist-packages/h5py/_hl/compat.py
/usr/lib/python2.7/dist-packages/h5py/_hl/dataset.py
/usr/lib/python2.7/dist-packages/h5py/_hl/datatype.py
/usr/lib/python2.7/dist-packages/h5py/_hl/dims.py
/usr/lib/python2.7/dist-packages/h5py/_hl/files.py
/usr/lib/python2.7/dist-packages/h5py/_hl/filters.py
/usr/lib/python2.7/dist-packages/h5py/_hl/group.py
/usr/lib/python2.7/dist-packages/h5py/_hl/selections.py
/usr/lib/python2.7/dist-packages/h5py/_hl/selections2.py
/usr/lib/python2.7/dist-packages/h5py/tests/__init__.py
/usr/lib/python2.7/dist-packages/h5py/tests/common.py
/usr/lib/python2.7/dist-packages/h5py/tests/hl/__init__.py
/usr/lib/python2.7/dist-packages/h5py/tests/hl/test_attribute_create.py
/usr/lib/python2.7/dist-packages/h5py/tests/hl/test_dataset_getitem.py
/usr/lib/python2.7/dist-packages/h5py/tests/hl/test_dataset_swmr.py
/usr/lib/python2.7/dist-packages/h5py/tests/hl/test_datatype.py
/usr/lib/python2.7/dist-packages/h5py/tests/hl/test_dims_dimensionproxy.py
/usr/lib/python2.7/dist-packages/h5py/tests/hl/test_file.py
/usr/lib/python2.7/dist-packages/h5py/tests/hl/test_threads.py
/usr/lib/python2.7/dist-packages/h5py/tests/old/__init__.py
/usr/lib/python2.7/dist-packages/h5py/tests/old/common.py
/usr/lib/python2.7/dist-packages/h5py/tests/old/test_attrs.py
/usr/lib/python2.7/dist-packages/h5py/tests/old/test_attrs_data.py
/usr/lib/python2.7/dist-packages/h5py/tests/old/test_base.py
/usr/lib/python2.7/dist-packages/h5py/tests/old/test_dataset.py
/usr/lib/python2.7/dist-packages/h5py/tests/old/test_datatype.py
/usr/lib/python2.7/dist-packages/h5py/tests/old/test_dimension_scales.py
/usr/lib/python2.7/dist-packages/h5py/tests/old/test_file.py
/usr/lib/python2.7/dist-packages/h5py/tests/old/test_file_image.py
/usr/lib/python2.7/dist-packages/h5py/tests/old/test_group.py
/usr/lib/python2.7/dist-packages/h5py/tests/old/test_h5.py
/usr/lib/python2.7/dist-packages/h5py/tests/old/test_h5d_direct_chunk_write.py
/usr/lib/python2.7/dist-packages/h5py/tests/old/test_h5f.py
/usr/lib/python2.7/dist-packages/h5py/tests/old/test_h5p.py
/usr/lib/python2.7/dist-packages/h5py/tests/old/test_h5t.py
/usr/lib/python2.7/dist-packages/h5py/tests/old/test_objects.py
/usr/lib/python2.7/dist-packages/h5py/tests/old/test_selections.py
/usr/lib/python2.7/dist-packages/h5py/tests/old/test_slicing.py
/usr/share/doc/python-h5py/README.Debian
/usr/share/doc/python-h5py/README.rst
/usr/share/doc/python-h5py/changelog.Debian.gz
/usr/share/doc/python-h5py/copyright

Changelog

2017-04-07 - Ghislain Antony Vaillant <ghisvail@gmail.com>
h5py (2.7.0-1) unstable; urgency=medium
* Run DEP-8 tests for all supported Python versions
* Add missing i-deps on python{,3}-numpy-dbg (Closes: #858727)
* Source future releases from PyPI
* New upstream release
* Rebase patch queue
- Drop 0002-Fix-arch-name-for-ppc64le.patch, applied upstream
- Drop 0003-Fix-version_tuple-to-make-it-PEP440-compliant.patch, applied
upstream
2017-01-25 - Ghislain Antony Vaillant <ghisvail@gmail.com>
h5py (2.7.0~rc3-1) unstable; urgency=medium
* New upstream release (Closes: #851162)
* Rebase patch queue
- Drop 0002-Explicity-specify-endianess-of-expected-output-type.patch,
applied upstream
* Cherry pick upstream fix for builds on ppc64el
- New patch 0002-Fix-arch-name-for-ppc64le.patch
* Cherry-pick proposed fix for version numbers
- New patch 0003-Fix-version_tuple-to-make-it-PEP440-compliant.patch
2017-01-12 - Ghislain Antony Vaillant <ghisvail@gmail.com>
h5py (2.7.0~rc2-2) unstable; urgency=medium
* Cherry-pick proposed fix for FTBFS on mips and s390x (Closes: #850699)
- New patch 0002-Explicity-specify-endianess-of-expected-output-type.patch
2017-01-05 - Ghislain Antony Vaillant <ghisvail@gmail.com>
h5py (2.7.0~rc2-1) unstable; urgency=medium
* Switch to git-dpm
- The patch queue is numbered now
- The gbp configuration has been dropped
* New upstream release
* Rebase the patch queue
- Drop 0002-Disable-broken-tests.patch, fixed upstream
- Drop 0003-Package-Config-Fix-Detection.patch, applied upstream
* Drop versioned dependency on Cython, no longer required
* Adjust the minimum version of Python 3 to 3.3
* Upgrade the packaging to debhelper 10
* Support the nodoc build profile
- Add appropriate build dependency on dpkg-dev
- Mark build dependencies for the documentation as !nodoc
- Add build dependency on sphinx-common for dh_sphinxdoc
- Do not build the documentation if nodoc is requested
* Fix incomplete care of debug packages
- Use nominal set of install dependencies for each -dbg package
- Add missing dh_strip override for each -dbg package
* Add missing Built-Using for the Sphinx documentation
2016-12-01 - Ghislain Antony Vaillant <ghisvail@gmail.com>
h5py (2.6.0-2) unstable; urgency=medium
* Cherry-pick upstream patch fixing HDF5 detection.
- New patch Package-Config-Fix-Detection.patch.
Thanks to Iain Lane for reporting (Closes: #846351)
* Bump standards version to 3.9.8, no changes required.
* Use HTTPS for the copyright Format URI.
* Drop superfluous Testsuite field.
* Mark -doc package Multi-Arch: foreign.
* Suggest install of -doc package.
* Call dh_numpy{,3} in dh_python{2,3} overrides.
* Enable hardening.
* Cosmetic fixups in rules file.
* Update gbp.conf with current repository layout.
* Simplify the packaging testsuite.
2016-02-02 - Ghislain Antony Vaillant <ghisvail@gmail.com>
h5py (2.6.0-1) unstable; urgency=medium
* New upstream release.
* d/gbp.conf: no patch numbering.
* Update patch queue:
- Drop 0002-prevent-cython-dep.patch, no longer required.
- Drop drop-mpiposix.patch, unused.
- Refresh Disable-usage-of-rpath.patch.
* Update build dependencies:
- Raise versioned depends on cython to 0.19.
- Drop versioned depends on numpy and sphinx.
* Update copyright:
- add myself to the copyright holders of the debian files.
- add missing copyright information for vendored files.
- cme fix, wrap and sort.
* Add patch disabling broken tests acknowledged upstream.
Thanks to Gilles Filippini. (Closes: #797476)
2016-01-26 - Ghislain Antony Vaillant <ghisvail@gmail.com>
h5py (2.5.0-3) unstable; urgency=medium
* Add missing install dependencies for debug packages.
* d/control: use secure VCS-Git URI.

See Also

Package Description
python-hachoir-core_1.3.3-4_all.deb Core of Hachoir framework: parse and edit binary files
python-hachoir-metadata_1.3.3-2_all.deb Program to extract metadata using Hachoir library
python-hachoir-parser_1.3.4-2_all.deb Package of Hachoir parsers used to open binary files
python-hachoir-regex_1.0.5-2_all.deb regular expressions manipulation Python library
python-hachoir-subfile_0.5.3-3_all.deb find subfiles in any binary stream
python-hachoir-urwid_1.1-3_all.deb Binary file explorer using Hachoir and urwid libraries
python-hachoir-wx_0.3-3_all.deb wxWidgets GUI for the hachoir binary parser
python-hacking-doc_0.11.0-2.1~deb9u1_all.deb Flake8 OpenStack Hacking Guidelines Enforcement plugins - doc
python-hacking_0.11.0-2.1~deb9u1_all.deb Flake8 OpenStack Hacking Guidelines Enforcement plugins - Python 2.x
python-halberd_0.2.4-2_all.deb Python2 HTTP load balancer detector
python-hamcrest_1.8.0-1_all.deb Hamcrest framework for matcher objects (Python 2)
python-happybase_0.8-2_all.deb developer-friendly Python library to interact with Apache HBase
python-haproxy-log-analysis_2.0~b0-1_all.deb generate aggregate statistics from HAProxy HTTP logs (Python 2)
python-hashids_1.2.0-1_all.deb Python implementation of hashids
python-hdate_1.6.02-1_i386.deb Provides a library that help use Hebrew dates (Python bindings)
Advertisement
Advertisement