python-epydoc_3.0.1+dfsg-14_all.deb


Advertisement

Description

python-epydoc - tool for documenting Python modules

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename python-epydoc_3.0.1+dfsg-14_all.deb
Package name python-epydoc
Package version 3.0.1+dfsg
Package release 14
Package architecture all
Package type deb
Category devel::docsystem devel::lang:python implemented-in::python interface::commandline interface::graphical interface::x11 python role::documentation role::program scope::application uitoolkit::tk x11::application
Homepage http://epydoc.sourceforge.net/
License -
Maintainer Kenneth J. Pronovici <pronovic@debian.org>
Download size 214.82 KB
Installed size 1.07 MB
Epydoc is a tool for generating API documentation for Python modules based on
their docstrings.  A lightweight markup language called epytext can be used to
format docstrings and to add information about specific fields, such as
parameters and instance variables.  Epydoc also understands docstrings written
in ReStructuredText, Javadoc, and plaintext.
This package contains the epydoc and epydocgui commands, their manpages, and
their associated Python modules.
Epydoc supports two output formatters: HTML and LaTeX.  You must install the
suggested dependencies in order to generate documentation in DVI, PostScript,
or PDF format using the LaTeX formatter.

Alternatives

Package Version Architecture Repository
python-epydoc_3.0.1+dfsg-14_all.deb 3.0.1+dfsg all Debian Main
python-epydoc - - -

Requires

Name Value
python:any << 2.8
python:any >= 2.7.5-5~

Conflicts

Name Value
python2.1-epydoc -
python2.2-epydoc -
python2.3-epydoc -

Replaces

Name Value
python2.1-epydoc << 2.0-2
python2.2-epydoc << 2.0-2
python2.3-epydoc << 2.0-2

Download

Type URL
Mirror ftp.br.debian.org
Binary Package python-epydoc_3.0.1+dfsg-14_all.deb
Source Package epydoc

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-epydoc deb package:
    # sudo apt-get install python-epydoc

Files

Path
/usr/bin/epydoc
/usr/bin/epydocgui
/usr/lib/python2.7/dist-packages/epydoc-3.0.1.egg-info
/usr/lib/python2.7/dist-packages/epydoc/__init__.py
/usr/lib/python2.7/dist-packages/epydoc/apidoc.py
/usr/lib/python2.7/dist-packages/epydoc/checker.py
/usr/lib/python2.7/dist-packages/epydoc/cli.py
/usr/lib/python2.7/dist-packages/epydoc/compat.py
/usr/lib/python2.7/dist-packages/epydoc/docbuilder.py
/usr/lib/python2.7/dist-packages/epydoc/docintrospecter.py
/usr/lib/python2.7/dist-packages/epydoc/docparser.py
/usr/lib/python2.7/dist-packages/epydoc/docstringparser.py
/usr/lib/python2.7/dist-packages/epydoc/gui.py
/usr/lib/python2.7/dist-packages/epydoc/log.py
/usr/lib/python2.7/dist-packages/epydoc/util.py
/usr/lib/python2.7/dist-packages/epydoc/docwriter/__init__.py
/usr/lib/python2.7/dist-packages/epydoc/docwriter/dotgraph.py
/usr/lib/python2.7/dist-packages/epydoc/docwriter/html.py
/usr/lib/python2.7/dist-packages/epydoc/docwriter/html_colorize.py
/usr/lib/python2.7/dist-packages/epydoc/docwriter/html_css.py
/usr/lib/python2.7/dist-packages/epydoc/docwriter/html_help.py
/usr/lib/python2.7/dist-packages/epydoc/docwriter/latex.py
/usr/lib/python2.7/dist-packages/epydoc/docwriter/plaintext.py
/usr/lib/python2.7/dist-packages/epydoc/docwriter/xlink.py
/usr/lib/python2.7/dist-packages/epydoc/markup/__init__.py
/usr/lib/python2.7/dist-packages/epydoc/markup/doctest.py
/usr/lib/python2.7/dist-packages/epydoc/markup/epytext.py
/usr/lib/python2.7/dist-packages/epydoc/markup/javadoc.py
/usr/lib/python2.7/dist-packages/epydoc/markup/plaintext.py
/usr/lib/python2.7/dist-packages/epydoc/markup/pyval_repr.py
/usr/lib/python2.7/dist-packages/epydoc/markup/restructuredtext.py
/usr/lib/python2.7/dist-packages/epydoc/test/__init__.py
/usr/lib/python2.7/dist-packages/epydoc/test/util.py
/usr/share/doc/python-epydoc/README.Debian
/usr/share/doc/python-epydoc/README.txt
/usr/share/doc/python-epydoc/changelog.Debian.gz
/usr/share/doc/python-epydoc/copyright
/usr/share/man/man1/epydoc.1.gz
/usr/share/man/man1/epydocgui.1.gz
/usr/share/pyshared/epydoc-3.0.1.egg-info
/usr/share/pyshared/epydoc/__init__.py
/usr/share/pyshared/epydoc/apidoc.py
/usr/share/pyshared/epydoc/checker.py
/usr/share/pyshared/epydoc/cli.py
/usr/share/pyshared/epydoc/compat.py
/usr/share/pyshared/epydoc/docbuilder.py
/usr/share/pyshared/epydoc/docintrospecter.py
/usr/share/pyshared/epydoc/docparser.py
/usr/share/pyshared/epydoc/docstringparser.py
/usr/share/pyshared/epydoc/gui.py
/usr/share/pyshared/epydoc/log.py
/usr/share/pyshared/epydoc/util.py
/usr/share/pyshared/epydoc/docwriter/__init__.py
/usr/share/pyshared/epydoc/docwriter/dotgraph.py
/usr/share/pyshared/epydoc/docwriter/html.py
/usr/share/pyshared/epydoc/docwriter/html_colorize.py
/usr/share/pyshared/epydoc/docwriter/html_css.py
/usr/share/pyshared/epydoc/docwriter/html_help.py
/usr/share/pyshared/epydoc/docwriter/latex.py
/usr/share/pyshared/epydoc/docwriter/plaintext.py
/usr/share/pyshared/epydoc/docwriter/xlink.py
/usr/share/pyshared/epydoc/markup/__init__.py
/usr/share/pyshared/epydoc/markup/doctest.py
/usr/share/pyshared/epydoc/markup/epytext.py
/usr/share/pyshared/epydoc/markup/javadoc.py
/usr/share/pyshared/epydoc/markup/plaintext.py
/usr/share/pyshared/epydoc/markup/pyval_repr.py
/usr/share/pyshared/epydoc/markup/restructuredtext.py
/usr/share/pyshared/epydoc/test/__init__.py
/usr/share/pyshared/epydoc/test/util.py

Changelog

2016-06-16 - Kenneth J. Pronovici <pronovic@debian.org>
epydoc (3.0.1+dfsg-14) unstable; urgency=medium
* Fix line endings in deterministic-sort-2.patch.
* Add new patch weakref-types.patch (closes: #827416).
- This is a request from the Reproducible Builds project
- This patch removes memory addresses for weakref.* instances
2016-06-13 - Kenneth J. Pronovici <pronovic@debian.org>
epydoc (3.0.1+dfsg-13) unstable; urgency=medium
* Bump standards version to 3.9.8.0 (no packaging changes).
* Add new patch manpage-types.patch.
- This patch fixes several misspellings discovered by Lintian.
* Add new patch deterministic-sort-2.patch (closes: #825968).
- This is a request from the Reproducible Builds project
- This patch makes several more types of ordering deterministic
* Change X-Python-Version from 2.1 to 2.4 in debian/control.
- This is necessary to support deterministic-sort-2.patch
- Practically, there is no effect, since Debian only has Python 2.7
2015-08-17 - Kenneth J. Pronovici <pronovic@debian.org>
epydoc (3.0.1+dfsg-12) unstable; urgency=medium
* Rename honour_source_date_epoch.patch to source-date.patch
* Adjust build-time.patch so comments are more consistent with other patches.
* Adjust source-date.patch so comments are more consistent with other patches.
* Add new patch deterministic-sort.patch (closes: #795835).
- This is a request from the Reproducible Builds project
- This patch makes class and modules ordering predictable
* Add new patch hide-memory-addresses.patch (closes: #795826).
- This is a request from the Reproducible Builds project
- This patch fixes __repr__ so memory addresses don't appear in docs
2015-08-11 - Kenneth J. Pronovici <pronovic@debian.org>
epydoc (3.0.1+dfsg-11) unstable; urgency=medium
* Remove diffutils from build deps; not necessary because it's essential.
2015-08-11 - Kenneth J. Pronovici <pronovic@debian.org>
epydoc (3.0.1+dfsg-10) unstable; urgency=medium
* Add support for the Debian continuous integration environment.
- Update debian/control to list Testsuite: autopkgtest
- Add debian/tests/control to list tests for CI environment
- Update debian/rules to run smoke tests via debian/smoketest
- Add build deps on diffutils to support the smoke tests
2015-08-05 - Kenneth J. Pronovici <pronovic@debian.org>
epydoc (3.0.1+dfsg-9) unstable; urgency=medium
* Fix all patches to eliminate the unnecessary leading # character.
2015-07-12 - Kenneth J. Pronovici <pronovic@debian.org>
epydoc (3.0.1+dfsg-8) unstable; urgency=medium
* Add patches/honour_source_date_epoch.patch (closes: #790899)
- This is a request from the Reproducible Builds project
- The new patch adds support for SOURCE_DATE_EPOCH to generate timestamps.
2015-05-10 - Kenneth J. Pronovici <pronovic@debian.org>
epydoc (3.0.1+dfsg-7) unstable; urgency=medium
* Update Recommends and Suggests for both python-epydoc and epydoc-doc.
- epydoc-doc: Recommend the chromium browser rather than iceweasel, since
that is the browser I test with day-to-day. 
- python-epydoc: move ghostscript and texlive dependencies to Suggests to
reduce the minimum install size for typical users (texlive is huge).
* Update the Description for python-epydoc.
- Update the description to indicate that suggested dependencies must be
installed to generate documentation in DVI, PostScript, or PDF format
using the LaTeX formatter.
2015-04-28 - Kenneth J. Pronovici <pronovic@debian.org>
epydoc (3.0.1+dfsg-6) unstable; urgency=medium
* Bump standards version to 3.9.6.1 (no packaging changes).
* Update debian/copyright to list 2015 as the copyright date on my changes.
* Add dh-python to Build-Depends, to silence build-time warning.
* Add patches/build-time.patch (closes: #783326).
- This is a request from the Reproducible Builds project
- The new patch adds a new --no-include-build-time command-line option

See Also

Package Description
python-escript-doc_5.0-3_all.deb Documentation for Escript/Finley
python-escript-mpi_5.0-3_i386.deb Escript/Finley finite elements Python2 system (OpenMP + MPI)
python-escript_5.0-3_i386.deb Escript/Finley finite elements Python2 system (with OpenMP)
python-esmre_0.3.1-3+b2_i386.deb Regular expression acceleration in Python2
python-espeak_0.5-1+b4_i386.deb Python bindings for eSpeak
python-et-xmlfile_1.0.1-2_all.deb low memory library for creating large XML files (Python 2)
python-etcd_0.4.3-2_all.deb Python Etcd client library
python-ethtool_0.12-1.1_i386.deb Python bindings for the ethtool kernel interface
python-evemu_2.6.0-0.1_i386.deb Linux Input Event Device Emulation Library - Python bindings
python-eventlet-doc_0.19.0-6_all.deb concurrent networking library - doc
python-eventlet_0.19.0-6_all.deb concurrent networking library - Python 2.x
python-evtx_0.5.3b-3+deb9u1_all.deb parser for recent Windows Event Log files -- Python 2 version
python-ewmh-doc_0.1.5-1_all.deb Python interface to EWMH-compliant window managers (common documentation)
python-ewmh_0.1.5-1_all.deb Python interface to EWMH-compliant window managers (Python 2)
python-exactimage_0.9.1-16+b1_i386.deb fast image manipulation library (Python bindings)
Advertisement
Advertisement