ocaml-findlib_1.6.2-1+b1_i386.deb


Advertisement

Description

ocaml-findlib - management tool for OCaml libraries

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename ocaml-findlib_1.6.2-1+b1_i386.deb
Package name ocaml-findlib
Package version 1.6.2
Package release 1+b1
Package architecture i386
Package type deb
Category devel::buildtools devel::lang:ocaml devel::packaging implemented-in::ocaml interface::commandline ocaml role::program scope::utility
Homepage http://projects.camlcity.org/projects/findlib.html
License -
Maintainer Debian OCaml Maintainers <debian-ocaml-maint@lists.debian.org>
Download size 285.49 KB
Installed size 1.00 MB
The "findlib" OCaml library provides a scheme to manage reusable
software components (packages), and includes tools that support this
scheme. Packages are collections of OCaml modules for which
metainformation can be stored. The packages are kept in the
filesystem hierarchy, but with strict directory structure. The
library contains functions to look the directory up that stores a
package, to query metainformation about a package, and to retrieve
dependency information about multiple packages.
This package contains a tool (ocamlfind) that allows the user to
enter queries on the command-line. In order to simplify compilation
and linkage, there are new frontends, all driven by ocamlfind, for
the various OCaml compilers that can directly deal with packages.

Alternatives

Package Version Architecture Repository
ocaml-findlib_1.6.2-1+b1_amd64.deb 1.6.2 amd64 Debian Main
ocaml-findlib - - -

Requires

Name Value
libc6 >= 2.7
libfindlib-ocaml -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package ocaml-findlib_1.6.2-1+b1_i386.deb
Source Package findlib

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ocaml-findlib deb package:
    # sudo apt-get install ocaml-findlib

Files

Path
/etc/bash_completion.d/ocamlfind
/usr/bin/ocamlfind
/usr/share/doc/ocaml-findlib/QUICKSTART.gz
/usr/share/doc/ocaml-findlib/README.gz
/usr/share/doc/ocaml-findlib/changelog.Debian.gz
/usr/share/doc/ocaml-findlib/changelog.Debian.i386.gz
/usr/share/doc/ocaml-findlib/copyright
/usr/share/man/man1/ocamlfind.1.gz
/usr/share/man/man5/META.5.gz
/usr/share/man/man5/findlib.conf.5.gz
/usr/share/man/man5/site-lib.5.gz

Changelog

2016-06-09 - Stéphane Glondu <glondu@debian.org>
findlib (1.6.2-1) unstable; urgency=medium
* New upstream release
* Update Vcs-*
* Bump Standards-Version to 3.9.8
2015-10-08 - Stéphane Glondu <glondu@debian.org>
findlib (1.5.5-2) unstable; urgency=medium
* Add `directory' directive to META.bytes
* Bump debhelper compat level to 9
* Delete obsolete README.source
* Upload to unstable
2015-02-18 - Stéphane Glondu <glondu@debian.org>
findlib (1.5.5-1) experimental; urgency=medium
* New upstream release
- compile with OCaml 4.02.1
- compile without camlp4, drop camlp4 patches
- compile without labltk, drop wizard
- install findlib.cmxs
* Bump Standards-Version to 3.9.6 (no changes)
2014-03-27 - Stéphane Glondu <glondu@debian.org>
findlib (1.4.1-1) unstable; urgency=medium
* New upstream release
2013-12-02 - Stéphane Glondu <glondu@debian.org>
findlib (1.4-2) unstable; urgency=low
* Upload to unstable
2013-07-11 - Stéphane Glondu <glondu@debian.org>
findlib (1.4-1) experimental; urgency=low
* New upstream release
* Update Vcs-*
* Bump Standards-Version to 3.9.4
2012-11-25 - Stéphane Glondu <glondu@debian.org>
findlib (1.3.3-1) experimental; urgency=low
* New upstream release
2012-06-21 - Stéphane Glondu <glondu@debian.org>
findlib (1.3.2-1) experimental; urgency=low
* New upstream release
- incompatible with 3.x versions of OCaml shipped by Debian
2012-06-05 - Stéphane Glondu <glondu@debian.org>
findlib (1.3.1-1) unstable; urgency=low
* New upstream release
- documentation sources are now included in the official upstream
tarball, repackaging is no longer needed
* Update debian/copyright
2012-02-28 - Stéphane Glondu <glondu@debian.org>
findlib (1.2.8+debian-1) unstable; urgency=low
* New upstream release
* Switch debian/copyright to format 1.0
* Bump Standards-Version to 3.9.3

See Also

Package Description
ocaml-interp_4.02.3-9_i386.deb OCaml interactive interpreter and standard libraries
ocaml-libs_3.12.0.1_all.deb OCaml core libraries (metapackage)
ocaml-melt_1.4.0-1+b3_i386.deb LaTeX with OCaml (tools)
ocaml-mingw-w64-i686_4.01.0~20140328-1+b2_i386.deb OCaml cross-compiler based on mingw -- 32 bit compiler
ocaml-mingw-w64_4.01.0~20140328-1+b2_i386.deb OCaml cross-compiler based on mingw -- Meta-package
ocaml-mode_4.02.3-9_all.deb major mode for editing Objective Caml in Emacs
ocaml-native-compilers_4.02.3-9_i386.deb Native code compilers of the OCaml suite (the .opt ones)
ocaml-nox_4.02.3-9_i386.deb ML implementation with a class-based object system (no X)
ocaml-source_4.02.3-9_all.deb Sources for Objective Caml
ocaml-tools_20120103-4_all.deb tools for OCaml developers
ocaml-ulex08_0.8-10+b7_i386.deb OCaml lexer generator with Unicode support - CamlP5 version
ocaml-ulex_1.1-2+b4_i386.deb OCaml lexer generator with Unicode support
ocaml_4.02.3-9_i386.deb ML language implementation with a class-based object system
ocamldsort_0.16.0-5_i386.deb dependency sorter for OCaml source files
ocamlgraph-editor_1.8.6-1+b2_i386.deb graphical graph editor based on hyperbolic geometry
Advertisement
Advertisement