libumfpack5_4.5.4-1_i386.deb


Advertisement

Description

libumfpack5 - sparse LU factorization library

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename libumfpack5_4.5.4-1_i386.deb
Package name libumfpack5
Package version 4.5.4
Package release 1
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage http://www.suitesparse.com
License -
Maintainer Debian Science Team <debian-science-maintainers@lists.alioth.debian.org>
Download size 146.11 KB
Installed size 767.00 KB
Suitesparse is a collection of libraries for computations involving
sparse matrices.
The UMFPACK library provides a set of routines solving sparse linear systems
via LU factorization.

Alternatives

Package Version Architecture Repository
libumfpack5_4.5.4-1_amd64.deb 4.5.4 amd64 Debian Main
libumfpack5 - - -

Requires

Name Value
libamd2 >= 4.5.2
libblas.so.3 -
libblas3 -
libc6 >= 2.4
libcholmod3 >= 4.5.2
liblapack.so.3 -
liblapack3 -
libsuitesparseconfig4 >= 4.5.2

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libumfpack5_4.5.4-1_i386.deb
Source Package suitesparse

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libumfpack5 deb package:
    # sudo apt-get install libumfpack5

Files

Path
/usr/lib/i386-linux-gnu/libumfpack.so.5
/usr/lib/i386-linux-gnu/libumfpack.so.5.7.6
/usr/share/doc/libumfpack5/NEWS.Debian.gz
/usr/share/doc/libumfpack5/changelog.Debian.gz
/usr/share/doc/libumfpack5/changelog.gz
/usr/share/doc/libumfpack5/copyright
/usr/share/lintian/overrides/libumfpack5

Changelog

2016-12-17 - Sébastien Villemot <sebastien@debian.org>
suitesparse (1:4.5.4-1) unstable; urgency=medium
* New upstream version 4.5.4
2016-10-30 - Sébastien Villemot <sebastien@debian.org>
suitesparse (1:4.5.3-2) unstable; urgency=medium
* Remove Christophe Prud'homme from Uploaders (per MIA team request).
Thanks Christophe for your contributions to that package! (Closes: #835011)
* Bump to debhelper compat level 10.
* Stop using dh-exec.
2016-05-17 - Sébastien Villemot <sebastien@debian.org>
suitesparse (1:4.5.3-1) unstable; urgency=low
* Release to unstable.
* Imported Upstream version 4.5.3.
2016-05-04 - Sébastien Villemot <sebastien@debian.org>
suitesparse (1:4.5.3~beta-1) experimental; urgency=low
* Imported Upstream version 4.5.3~beta
* d/copyright: reflect upstream changes.
* Switch to dh (instead of cdbs).
* Upstream committed to ABI tracking, so drop older system for
generating SONAMES.
* Use new upstream build system for compiling shared libraries.
* Drop all patches (except buildflags.patch), no longer needed.
* Enable METIS support (through Debian package, not embedded copy).
* Add package for RBio (librbio).
* Drop package for CSparse (libcsparse), superseded by libcxsparse.
* Add symbols files (except for SPQR lib which has C++ code).
* Bump Standards-Version to 3.9.8, no changes needed.
* Use secure URLs for Vcs-* fields.
2016-01-19 - Sébastien Villemot <sebastien@debian.org>
suitesparse (1:4.4.6-1) unstable; urgency=medium
* Imported Upstream version 4.4.6
* Bump SOVERSION for libspqr and libsuitesparseconfig.
* Drop libsuitesparse-dbg package, migrate to automatic debug packages.
* libsuitesparse-doc: suggest instead of recommending BLAS and ATLAS doc.
Also replace transitional libblas-doc package by liblapack-doc and
liblapack-doc-man.
* Remove old Conflicts/Replaces against old ufsparse/umfpack4 packages.
2015-11-20 - Sébastien Villemot <sebastien@debian.org>
suitesparse (1:4.4.5-2) unstable; urgency=low
* Upload to unstable.
2015-09-25 - Sébastien Villemot <sebastien@debian.org>
suitesparse (1:4.4.5-1) experimental; urgency=low
* Imported Upstream version 4.4.5
* debian/copyright: reflect upstream changes.
* Bump SOVERSION for libcholmod, libklu and libsuitesparseconfig.
2015-04-10 - Sébastien Villemot <sebastien@debian.org>
suitesparse (1:4.4.4-1) experimental; urgency=low
* Imported Upstream version 4.4.4
* Bump SOVERSION for libspqr and libsuitesparseconfig.
* Fix typo in description of libccolamd. (Closes: #768365)
* Overhaul long package descriptions. (Closes: #633042)
2015-02-08 - Sébastien Villemot <sebastien@debian.org>
suitesparse (1:4.4.3-1) experimental; urgency=low
* Imported Upstream version 4.4.3
* debian/copyright: update, rewrite using machine-readable format 1.0.
* Bump library SONAMEs.
* Update patches.
+ Merge all patches related to shared libraries building in
shared_libraries.patch.
+ Separate patch for BLAS library (use-generic-blas.patch) from the one
disabling METIS (disable-metis.patch).
+ Give more explicit names to remaining patches, and use the .patch
extension.
* Ship libsuitesparseconfig in a separate package.
This is now necessary because the library contains a global symbol, shared
between several SuiteSparse libraries.
* Bump Standards-Version to 3.9.6, no changes needed.
* Update debian/watch for new tarball location.
* debian/control: update homepage URL.
* Ship cs.h from both CSparse and CXSparse.
CSparse and CXSparse both provide a header named cs.h. Previously, only the
CXSparse version was provided. Both versions are now provided in separate
subdirectories of /usr/include/suitesparse. A toplevel symlink pointing to
the CXSparse version is left for backward compatibility.
* Add missing SuiteSparse_config in long description of libsuitesparse-dev.
* Regenerate debian/control from the clean rule (instead of using a
dedicated target). This seems acceptable, since it's done in
gnome-pkg-tools.

See Also

Package Description
libumlib-dev_0.8.2-1.1+b1_i386.deb View-OS in user space - Development files
libumlib0_0.8.2-1.1+b1_i386.deb View-OS in user space - Support library for modules
libumockdev-dev_0.8.12-1_i386.deb development files and documentation for libumockdev
libumockdev0_0.8.12-1_i386.deb hardware mocking testbed for bug reports and regression tests
libunac1-dev_1.8.0-6_i386.deb A C programmer's library that removes accents from a string
libunac1_1.8.0-6_i386.deb The unac programming library - runtime version
libunbound-dev_1.6.0-3+deb9u2_i386.deb static library, header files, and docs for libunbound
libunbound2_1.6.0-3+deb9u2_i386.deb library implementing DNS resolution and validation
libuncommons-maths-java-doc_1.2.3-1_all.deb Maths library for Java - Documentations
libuncommons-maths-java_1.2.3-1_all.deb Maths library for Java
libuncommons-watchmaker-framework-java_0.7.1-1_all.deb Framework for Evolutionary Computation
libuncommons-watchmaker-swing-java_0.7.1-1_all.deb Framework for Evolutionary Computation - Swing library
libunibilium-dev_1.2.0-1_i386.deb simple, self-contained terminfo library (development files)
libunibilium0_1.2.0-1_i386.deb simple, self-contained terminfo library
libunibreak-dev_1.1-2_i386.deb line breaking library for Unicode (development files)
Advertisement
Advertisement