libjson-glib-1.0-0_1.2.6-1_i386.deb


Advertisement

Description

libjson-glib-1.0-0 - GLib JSON manipulation library

Distribution: Debian 9 (Stretch)
Repository: Debian Main i386
Package name: libjson-glib-1.0-0
Package version: 1.2.6
Package release: 1
Package architecture: i386
Package type: deb
Installed size: 319 B
Download size: 178.44 KB
Official Mirror: ftp.br.debian.org
JSON-GLib is a library for parsing, generating and manipulating JavaScript Object Notation (JSON) data streams using the GLib type system. It allows manipulating JSON data types with a Document Object Model API. It also allows serializing and deserializing simple or complex GObjects to and from JSON data types.

Alternatives

    Download

    Source package: json-glib

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libjson-glib-1.0-0 deb package:
      # sudo apt-get install libjson-glib-1.0-0

    Changelog

    2017-03-16 - Michael Biebl <biebl@debian.org> json-glib (1.2.6-1) unstable; urgency=medium * New upstream release. * Re-add gnome-get-source.mk include. * Drop private symbols for the custom marshaller. Upstream now uses the generic one provided by GLib.

    2016-08-07 - Michael Biebl <biebl@debian.org> json-glib (1.2.2-1) unstable; urgency=medium * New upstream release. * Convert from cdbs to dh. * Bump Standards-Version to 3.9.8. * Drop dbg package now that we have automatic dbgsym packages. * Ensure proper upgrade from libjson-glib-1.0-0-dbg to new dbgsym packages by using dh_strip --dbgsym-migration. Bump Build-Depends on debhelper accordingly.

    2016-03-24 - Andreas Henriksson <andreas@fatal.se> json-glib (1.2.0-1) unstable; urgency=medium * New upstream release. * Bump Standards-Version to 3.9.7 * Drop debian/patches/0001-tests-builder-Don-t-duplicate-test-names.patch - merged upstream. * Updated debian/libjson-glib-1.0-0.symbols with many additions.

    2015-10-02 - Iain Lane <laney@debian.org> json-glib (1.0.4-2) unstable; urgency=medium [ Michael Biebl ] * Drop obsolete Conflicts/Replaces. [ Iain Lane ] * debian/patches/0001-tests-builder-Don-t-duplicate-test-names.patch: Cherry-pick. Don't duplicate test names, so as not to fail to build with glib 2.46. * debian/rules: Run testsuite verbosely

    2015-05-23 - Michael Biebl <biebl@debian.org> json-glib (1.0.4-1) unstable; urgency=medium * New upstream relese. * Wrap dependencies. * Install typelib files into multiarch paths. * Mark gir and dev packages as Multi-Arch: same and the doc package as Multi-Arch: foreign. * Update Homepage: URL. * Update debian/copyright using the machine-readable copyright format 1.0. * Bump Standards-Version to 3.9.6. * Install upstream provided man pages via .install file. * Mark private symbols for the marshaller as (optional).

    2014-07-13 - Andreas Henriksson <andreas@fatal.se> json-glib (1.0.2-1) unstable; urgency=medium [ Andreas Henriksson ] * Drop sledge-hammer and bump dh compat to 9 - This fixes the -dbg vs multiarch issues Thanks to Julien Cristau for the hint. * New upstream release. [ Colin Watson ] * use dh-autoreconf for better new-port coverage (Closes: #732301)

    2014-03-25 - Andreas Henriksson <andreas@fatal.se> json-glib (1.0.0-1) unstable; urgency=medium * New upstream release. * Bump glib build-dependency to 2.37.6 according to configure.ac * Switch DEB_MAKE_CHECK_TARGET from "test" to "check". - make test doesn't exist (anymore?). * Build-depend on libxml2-utils and xsltproc for manpage generation. * Bump Standards-Version to 3.9.5 * Bump gtk-doc-tools build-dependency to >= 1.20 according to configure.ac * Update debian/libjson-glib-1.0-0.symbols with added symbols. * Add json-glib-tools package. * Use sledge-hammer on -dbg package because of multiarch. - we don't need debug info for the trivial binaries in -tools.

    2013-09-24 - Andreas Henriksson <andreas@fatal.se> json-glib (0.16.2-1) unstable; urgency=low [ Jeremy Bicha ] * Update homepage [ Andreas Henriksson ] * New upstream release

    2013-06-18 - Laurent Bigonville <bigon@debian.org> json-glib (0.16.0-1) unstable; urgency=low [ Michael Biebl ] * Change section of gir1.2-json-1.0 to introspection. [ Josselin Mouette ] * Update repository URL. [ Laurent Bigonville ] * New upstream release - Bump libglib2.0-dev build-dependency to 2.34.0 - debian/libjson-glib-1.0-0.symbols: Adjust .symbols file, the dropped symbols were not part of the public API * debian/control.in: - Bump Standards-Version to 3.9.4 (no further changes) - Use canonical URL's for VCS fields * debian/rules: Use DEB_LDFLAGS_MAINT_APPEND instead of LDFLAGS and include buildflags.mk to avoid overriding hardening flags * Add libjson-glib-1.0-common package: Upstream is now shipping translations

    Advertisement
    Advertisement