libglibmm-2.4-1v5_2.50.0-1_i386.deb


Advertisement

Description

libglibmm-2.4-1v5 - C++ wrapper for the GLib toolkit (shared libraries)

Property Value
Distribution Debian 9 (Stretch)
Repository Debian Main i386
Package filename libglibmm-2.4-1v5_2.50.0-1_i386.deb
Package name libglibmm-2.4-1v5
Package version 2.50.0
Package release 1
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage http://www.gtkmm.org/
License -
Maintainer Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Download size 688.34 KB
Installed size 2.40 MB
GLib is a low-level general-purpose library used mainly by GTK+/GNOME
applications, but is useful for other programs as well.
glibmm is the C++ wrapper for GLib.
This package contains shared libraries.

Alternatives

Package Version Architecture Repository
libglibmm-2.4-1v5_2.50.0-1_amd64.deb 2.50.0 amd64 Debian Main
libglibmm-2.4-1v5 - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
libglib2.0-0 >= 2.50.0
libsigc++-2.0-0v5 >= 2.8.0
libstdc++6 >= 5.2

Conflicts

Name Value
libglibmm-2.4-1c2a -

Replaces

Name Value
libglibmm-2.4-1c2a -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libglibmm-2.4-1v5_2.50.0-1_i386.deb
Source Package glibmm2.4

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libglibmm-2.4-1v5 deb package:
    # sudo apt-get install libglibmm-2.4-1v5

Files

Path
/usr/lib/i386-linux-gnu/libgiomm-2.4.so.1
/usr/lib/i386-linux-gnu/libgiomm-2.4.so.1.3.0
/usr/lib/i386-linux-gnu/libglibmm-2.4.so.1
/usr/lib/i386-linux-gnu/libglibmm-2.4.so.1.3.0
/usr/lib/i386-linux-gnu/libglibmm_generate_extra_defs-2.4.so.1
/usr/lib/i386-linux-gnu/libglibmm_generate_extra_defs-2.4.so.1.3.0
/usr/share/doc/libglibmm-2.4-1v5/AUTHORS
/usr/share/doc/libglibmm-2.4-1v5/NEWS.gz
/usr/share/doc/libglibmm-2.4-1v5/README
/usr/share/doc/libglibmm-2.4-1v5/changelog.Debian.gz
/usr/share/doc/libglibmm-2.4-1v5/changelog.gz
/usr/share/doc/libglibmm-2.4-1v5/copyright

Changelog

2016-09-20 - Michael Biebl <biebl@debian.org>
glibmm2.4 (2.50.0-1) unstable; urgency=medium
* New upstream release.
* Bump Build-Depends on libglib2.0-dev to (>= 2.50.0) as per configure.ac.
* Bump SHVER to 2.50.0.
2016-09-14 - Michael Biebl <biebl@debian.org>
glibmm2.4 (2.49.7-1) unstable; urgency=medium
* New upstream development release.
* Bump SHVER to 2.49.7.
* Don't compress example .cc files.
* Bump Build-Depends on libglib2.0-dev to (>= 2.49.7) as per configure.ac.
2016-09-14 - Michael Biebl <biebl@debian.org>
glibmm2.4 (2.49.5-1) unstable; urgency=medium
* New upstream development release
* Refresh debian/patches/01-disable-tls-test.patch.
* Bump Build-Depends on libsigc++-2.0-dev to (>= 2.9.1) as per configure.ac.
* Bump SHVER to 2.49.5.
* Convert from cdbs to dh.
* Bump debhelper compat level to 10.
* Stop building static libraries.
* Bump Standards-Version to 3.9.8.
2016-04-15 - Michael Biebl <biebl@debian.org>
glibmm2.4 (2.48.1-1) unstable; urgency=medium
* New upstream release.
* Update Build-Depends as per configure.ac:
- Bump libglib2.0-dev to (>= 2.48.0)
- Bump libsigc++-2.0-dev to (>= 2.8.0)
- Bump mm-common to (>= 0.9.10)
* Bump SHVER to 2.46.0.
* Drop libglibmm-2.4-dbg package now that we have automatic dbgsym packages.
* Ensure proper upgrade from libglibmm-2.4-dbg to new dbgsym packages by
using dh_strip --dbgsym-migration.
Bump Build-Depends on debhelper accordingly.
2015-12-15 - Michael Biebl <biebl@debian.org>
glibmm2.4 (2.46.3-1) unstable; urgency=medium
* New upstream release.
2015-11-20 - Michael Biebl <biebl@debian.org>
glibmm2.4 (2.46.2-1) unstable; urgency=medium
* New upstream release.
2015-09-27 - Michael Biebl <biebl@debian.org>
glibmm2.4 (2.46.1-1) unstable; urgency=medium
* New upstream release.
* Refresh patches.
* Update Build-Depends as per configure.ac:
- Bump libglib2.0-dev to (>= 2.46.0)
- Bump libsigc++-2.0-dev to (>= 2.5.4)
- Bump mm-common to (>= 0.9.8)
2015-08-08 - Michael Biebl <biebl@debian.org>
glibmm2.4 (2.44.0-3) unstable; urgency=medium
* Upload to unstable.
2015-08-06 - Michael Biebl <biebl@debian.org>
glibmm2.4 (2.44.0-2) experimental; urgency=medium
[ Sebastien Bacher ]
* Rename libglibmm-2.4-1c2a to libglibmm-2.4-1v5 for GCC 5 abi change.
* Add Conflict/Replaces against the old library package.
* Bump Build-Depends on libsigc++-2.0-dev to ensure it was built with GCC 5.
2015-05-07 - Michael Biebl <biebl@debian.org>
glibmm2.4 (2.44.0-1) unstable; urgency=medium
* Use default compression for binary packages.
* New upstream release.
* Bump minimum glib version to 2.44.0 as per configure.ac.
* Bump Standards-Version to 3.9.6. No further changes.
* Set pkg-gnome-maintainers@lists.alioth.debian.org as Maintainer, add
Deng Xiyue to Uploaders.
* Bump SHVER to 2.44.0.

See Also

Package Description
libglibmm-2.4-dev_2.50.0-1_i386.deb C++ wrapper for the GLib toolkit (development files)
libglibmm-2.4-doc_2.50.0-1_all.deb C++ wrapper for the GLib toolkit (documentation)
libglide2-dev_2002.04.10ds1-12_i386.deb graphics library for 3Dfx Voodoo 2 based cards - development files
libglide2_2002.04.10ds1-12_i386.deb graphics library for 3Dfx Voodoo 2 based cards - shared libraries
libglide3-dev_2002.04.10ds1-12_i386.deb graphics library for 3Dfx Voodoo 3+ based cards - development files
libglide3_2002.04.10ds1-12_i386.deb graphics library for 3Dfx Voodoo 3+ based cards - shared libraries
libglm-dev_0.9.8.3-3_all.deb C++ library for OpenGL GLSL type-based mathematics
libglm-doc_0.9.8.3-3_all.deb documentation for the OpenGL Mathematics (GLM) library
libglobalarrays-dev_5.4~beta~r10636+dfsg-5_i386.deb Distributed Shared-Memory Programming Environment (development)
libglobjects-dev_1.0.0-2_i386.deb development files for globjects
libglobjects1_1.0.0-2_i386.deb cross-platform C++ wrapper for OpenGL API objects
libglobus-authz-callout-error-dev_3.6-1_i386.deb Globus Toolkit - Globus authz error library Development Files
libglobus-authz-callout-error-doc_3.6-1_all.deb Globus Toolkit - Globus authz error library Documentation Files
libglobus-authz-callout-error0_3.6-1_i386.deb Globus Toolkit - Globus authz error library
libglobus-authz-dev_3.15-1_i386.deb Globus Toolkit - Globus authz library Development Files
Advertisement
Advertisement